could not find mozilla runtime

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
New Member
Posts: 1
Joined: August 14th, 2011, 10:37 am

Post Posted August 14th, 2011, 10:58 am

could not find mozilla runtime. firefox 5.0.1. I searched the build and there is no file called firefox-bin

linux 2.6.39, GCC 4.6.0

Compiled and installed XULRunner 5.0.1. I don't know how to test it, so I assume it's ok.

Compiled firefox 5.0.1 with use_LIBXUL_DIST.patch and the correct configure switches --with-system-xul --with-xul-sdk=.... or somesuch.

Running firefox ALWAYS gives this response: Could not find mozilla runtime.

I tried replacing /usr/bin/firefox with a symlink to /usr/lib64/firefox-5.0.1/firefox.

I tried renaming it firefox-bin.

I tried editing to call 'firefox' instead of 'mozilla-bin'.

I tried export PATH=$PATH:/usr/lib64/xulrunner-5.0.1:/usr/lib64/xulrunner-devel-5.0.1/bin:/usr/lib64/firefox-5.0.1 export LD_LIBRARY_PATH=/usr/xulrunner-devel-5.0.1/lib:/usr/lib64/firefox-5.0.1

I tried recompiling. I searched the source tree and the build tree for 'firefox-bin' and 'mozilla-bin'. Not found.

I tried compiling firefox 3.xxxx, but it will not compile with GCC 4.6.0. It wants -fpermissive, but adding that to the mozconfig file made no difference. Trying 'alias c++="c++ -fpermissive"' made no difference. Trying CXX="c++ -fpermissive" made no difference.


User avatar
Posts: 1231
Joined: April 22nd, 2003, 11:57 pm

Post Posted August 17th, 2011, 1:01 pm

Without install firefox this is where my firefox executable ends up
/sourcetrees/programs/mozilla/obj-i686-pc-linux-gnu/ffpgo/browser/dist/bin/firefox %u
the file firefox in the line above calls firefox-bin
from my .mozconfig
mk_add_options MOZ_OBJDIR=/sourcetrees/programs/mozilla/obj-@CONFIG_GUESS@/ffpgo

Did you do an install after building?
Also sometimes everything may work, but the system doesn't "know" that the executable is available - after compiling and installing something in particular, I run "sudo ldconfig" to force the system to acknowledge the new file
man ldconfig
ldconfig(8) ldconfig(8)

ldconfig - configure dynamic linker run-time bindings

ldconfig [OPTION...]

ldconfig creates, updates, and removes the necessary links and cache (for use by the run-time linker, to the most recent shared libraries found in the
directories specified on the command line, in the file /etc/, and in the trusted directories (/usr/lib and /lib). ldconfig checks the header and
file names of the libraries it encounters when determining which versions should have their links updated. ldconfig ignores symbolic links when scanning for

Return to Third Party/Unofficial Builds

Who is online

Users browsing this forum: No registered users and 1 guest