MozillaZine

"--disable-ldap" doesn't disable ldap

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
agirolimax
 
Posts: 15
Joined: February 19th, 2009, 10:08 am

Post Posted March 2nd, 2012, 5:58 pm

Attempting to build Seamonkey-2.7.2 fails with the following:

Code: Select all
make -C ./../ldap/sdks/c-sdk
make[3]: Entering directory `/usr/tmp/comm-release/ldap/sdks/c-sdk'
Makefile:42: config/autoconf.mk: No such file or directory
../../../config/config.mk:57: /config/autoconf.mk: No such file or directory
Makefile:55: *** target file `depend' has both : and :: entries.  Stop.
make[3]: Leaving directory `/usr/tmp/comm-release/ldap/sdks/c-sdk'
make[2]: *** [tier_platform] Error 2
make[2]: Leaving directory `/usr/tmp/comm-release/mozilla'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/usr/tmp/comm-release/mozilla'
make: *** [default] Error 2


I have tried to disable ldap with each of the following in turn:
--disable-ldap \
--without-ldap \
--with-ldap=no \

It seems as if the initial test for 'ldap' may have been disabled, but the configuration has not been properly passed on to the makefiles.

'glibc-2.13'
'gcc-4.5.3'
'bash-4.1.11'
'autoconf-2.68''

thank you

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted March 3rd, 2012, 10:33 am

Bug 599615 --disable-ldap breaks thunderbird build
Mark Banner (:standard8) wrote:The basic cause was the switch to libxul and the new configuration doesn't easily support --disable-ldap at the moment. I'm considering just removing it or disabling that option for libxul builds.

Why do you need to have that option in your mozconfig?

Phil

agirolimax
 
Posts: 15
Joined: February 19th, 2009, 10:08 am

Post Posted March 3rd, 2012, 7:21 pm

Thanks Phil,

I am in the process of building the entire system from the bottom up, with one eye to reducing dependencies whenever possible.

I saw no need for the presence of both 'ldap' and 'ssl' support. Have I made some grievous error in this?

Although I have built and installed 'openldap', nothing is so far linked to it except 'cups', which needs more attention in any case.

agirolimax
 
Posts: 15
Joined: February 19th, 2009, 10:08 am

Post Posted March 4th, 2012, 7:01 pm

Problems with 'ldap' persist.

With 'openldap' correctly installed, "--disable-ldap" removed from the configuration instuctions, and for a selection of versions from 2.7.2 and back to at least 2.0.6, the build usually fails with the following:

Code: Select all
======= making ./liblber60.a
rm -f liblber60.a; echo cr liblber60.a ./decode.o ./encode.o ./io.o ./bprint.o; echo liblber60.a
cr liblber60.a ./decode.o ./encode.o ./io.o ./bprint.o
liblber60.a
/usr/tmp/comm-release/mozilla/dist/bin/nsinstall -R -m 444 ./liblber60.a /usr/tmp/comm-release/mozilla/dist/lib
/usr/tmp/comm-release/mozilla/dist/bin/nsinstall: cannot access ./liblber60.a: No such file or directory
make[6]: *** [export] Error 1
make[6]: Leaving directory `/usr/tmp/comm-release/ldap/sdks/c-sdk/ldap/libraries/liblber'
make[5]: *** [export] Error 2
make[5]: Leaving directory `/usr/tmp/comm-release/ldap/sdks/c-sdk/ldap/libraries'
make[4]: *** [export] Error 2
make[4]: Leaving directory `/usr/tmp/comm-release/ldap/sdks/c-sdk/ldap'
make[3]: *** [export] Error 2
make[3]: Leaving directory `/usr/tmp/comm-release/ldap/sdks/c-sdk'
make[2]: *** [tier_platform] Error 2
make[2]: Leaving directory `/usr/tmp/comm-release/mozilla'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/usr/tmp/comm-release/mozilla'
make: *** [default] Error 2


With some configurations, the build will fail with similar liblber60.so errors instead.

What other _unlisted_ dependencies might I need to check? perhaps a Perl or Python module?


Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 2 guests