MozillaZine

[FX] drumsticks: OSX Release (G5 optimised) - NO MORE

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
drumsticks
 
Posts: 607
Joined: April 14th, 2005, 4:32 am
Location: Australia

Post Posted May 5th, 2005, 9:41 pm

I'm using Fink 0.7.1 (binary installer) too... All other packages are built from source though. Will have to try again when I get home later. Tonight's build will be delayed as it's Friday and I'm going out!

mento
 
Posts: 180
Joined: April 23rd, 2005, 1:33 pm

Post Posted May 5th, 2005, 10:50 pm

drumsticks wrote:Cripes. I spoke too soon I think... I tried building with an empty object directory and it won't compile now (I was using a 'dirty' object directory before. I'm now getting
That output tells me that you're doing an SDK build and g++ isn't being given a complete list of C++ include directories. I bet you accidentally slipped back to an unpatched configure.in or haven't run autoconf to regenerate configure.

drumsticks
 
Posts: 607
Joined: April 14th, 2005, 4:32 am
Location: Australia

Post Posted May 6th, 2005, 5:24 am

20050506 Firefox
20050506 Thunderbird

These builds are still Panther made. I've managed to get Firefox compiling in Tiger, but without specifying any SDKs. Not so sure if those builds will run in Jaguar, so I'm providing this for now until it is possible to build with the 10.2.8SDK on Tiger.

drumsticks
 
Posts: 607
Joined: April 14th, 2005, 4:32 am
Location: Australia

Post Posted May 6th, 2005, 5:31 am

mento wrote:I bet you accidentally slipped back to an unpatched configure.in or haven't run autoconf to regenerate configure.


And you would have won the bet. I was trying too many things at once there and messed up the autoconf. Further, I had some problems building with specifying the 10.2.8SDK. Will try again tomorrow.

drumsticks
 
Posts: 607
Joined: April 14th, 2005, 4:32 am
Location: Australia

Post Posted May 7th, 2005, 2:35 am

20050507 Firefox (10.4 Tiger only)
20050507 Thunderbird (10.4 Tiger only)

These builds are Tiger built without specifying any SDKs, so it might or might not work in earlier versions.
Last edited by drumsticks on May 7th, 2005, 5:35 pm, edited 2 times in total.

|2uso

User avatar
 
Posts: 67
Joined: March 6th, 2004, 10:37 am
Location: Venezuela

Post Posted May 7th, 2005, 3:59 pm

I can't work with SDK 10.2.8 even with v8 path and IDL.h tweak :-(
Macintosh G5/1800 uniprocessor - 1Gb RAM - 320 Gb SATA soft raid strip mode
Mac OS X 10.4.3 - XCode 2.1 - GCC 4.0
Camino G5 optimized home made

drumsticks
 
Posts: 607
Joined: April 14th, 2005, 4:32 am
Location: Australia

Post Posted May 7th, 2005, 5:29 pm

|2uso wrote:I can't work with SDK 10.2.8 even with v8 path and IDL.h tweak :-(


Oops. My bad [again]. I didn't clear the object directory before building with 10.2.8SDK. I tried again with a clean object directory and it won't compile with 10.2.8 SDK. I'm using v9 of the patch now. Edited comment on yesterday's build to reflect that.

|2uso

User avatar
 
Posts: 67
Joined: March 6th, 2004, 10:37 am
Location: Venezuela

Post Posted May 7th, 2005, 10:59 pm

HELP!!!! :'(

This is my /sw/include/libIDL-1/libIDL/IDL.h file beggining

#ifndef __IDL_H
#define __IDL_H

#include <glib.h>

/* Try to find wchar_t support */
#include <stdlib.h>

#if 1 /* HAVE_WCHAR_H */
# include <wchar.h>*/
#endif
#if 0 /* HAVE_WCSTR_H */
# include <wcstr.h>
#endif

#ifdef __cplusplus
extern "C" {
#endif

#include <stdio.h>

What is the line(s) do I have to comment (and how) above in order to fix this error:

xpidl.c
In file included from /mozilla/xpcom/typelib/xpidl/xpidl.c:42:
/mozilla/xpcom/typelib/xpidl/xpidl.h:53:24: libIDL/IDL.h: No such file or directory
In file included from /mozilla/xpcom/typelib/xpidl/xpidl.c:42:
/mozilla/xpcom/typelib/xpidl/xpidl.h:132: error: parse error before "IDL_ns"
/mozilla/xpcom/typelib/xpidl/xpidl.h:132: warning: no semicolon at end of struct or union
/mozilla/xpcom/typelib/xpidl/xpidl.h:133: warning: type defaults to `int' in declaration of `tree'
/mozilla/xpcom/typelib/xpidl/xpidl.h:133: warning: data definition has no type or storage class
/mozilla/xpcom/typelib/xpidl/xpidl.h:137: error: parse error before '}' token
/mozilla/xpcom/typelib/xpidl/xpidl.h:151: error: parse error before "p"
/mozilla/xpcom/typelib/xpidl/xpidl.h:236: error: parse error before "find_underlying_type"
/mozilla/xpcom/typelib/xpidl/xpidl.h:236: error: parse error before "typedef_ident"
/mozilla/xpcom/typelib/xpidl/xpidl.h:236: warning: type defaults to `int' in declaration of `find_underlying_type'
/mozilla/xpcom/typelib/xpidl/xpidl.h:236: warning: data definition has no type or storage class
/mozilla/xpcom/typelib/xpidl/xpidl.h:243: error: parse error before "const_tree"
/mozilla/xpcom/typelib/xpidl/xpidl.h:249: error: parse error before "method_tree"
/mozilla/xpcom/typelib/xpidl/xpidl.h:255: error: parse error before "method_tree"
/mozilla/xpcom/typelib/xpidl/xpidl.h:261: error: parse error before "method_tree"
make[6]: *** [xpidl.o] Error 1
make[5]: *** [export] Error 2
make[4]: *** [export] Error 2
make[3]: *** [export] Error 2
make[2]: *** [tier_2] Error 2
make[1]: *** [default] Error 2
make: *** [build] Error 2

In an include file I have to use /* to comment/disable lines?
Excuse my noob-like ignorance and thanks in advance

Or IDL.h tweak is not the trouble in here? OMG I really don't know what I'm doing... eheheheh

Mac OS X 10.4 - SDK 10.2.8 - gcc 3.3 - patch v9 - autoconf 2.13 and a BIG headache :-P
Macintosh G5/1800 uniprocessor - 1Gb RAM - 320 Gb SATA soft raid strip mode
Mac OS X 10.4.3 - XCode 2.1 - GCC 4.0
Camino G5 optimized home made

mento
 
Posts: 180
Joined: April 23rd, 2005, 1:33 pm

Post Posted May 8th, 2005, 6:36 am

Code: Select all
#if 0 /* HAVE_WCHAR_H */ /* The 1 wsa changed to a 0 here */
# include <wchar.h>*/
#endif
#if 0 /* HAVE_WCSTR_H */
# include <wcstr.h>
#endif

mento
 
Posts: 180
Joined: April 23rd, 2005, 1:33 pm

Post Posted May 8th, 2005, 7:51 am

drumsticks wrote:Oops. My bad [again]. I didn't clear the object directory before building with 10.2.8SDK. I tried again with a clean object directory and it won't compile with 10.2.8 SDK. I'm using v9 of the patch now. Edited comment on yesterday's build to reflect that.
Drumsticks, it would be helpful if you could let me know where you're having trouble. I want to make sure the patch doesn't cause any problems. Thanks.

|2uso

User avatar
 
Posts: 67
Joined: March 6th, 2004, 10:37 am
Location: Venezuela

Post Posted May 8th, 2005, 9:10 am

Thank you mento, you are the man

Building...
Macintosh G5/1800 uniprocessor - 1Gb RAM - 320 Gb SATA soft raid strip mode
Mac OS X 10.4.3 - XCode 2.1 - GCC 4.0
Camino G5 optimized home made

drumsticks
 
Posts: 607
Joined: April 14th, 2005, 4:32 am
Location: Australia

Post Posted May 8th, 2005, 3:34 pm

mento, thanks for all your help and good intentions. You're a good man. Sorry for the silence, I have been busy this weekend. It was my birthday! Plus, I had two major photography projects on as well. Here's a low res sampler from one of them :) It's autumn in Australia!

<This photo hosted only temporarily and is gone now!>

Anyway, back to compiling. I must've not read bugzilla very thoroughly. It turns out that I was having the same problems as |2uso. I changed the IDL.h file and it compiled fine (fresh object directory) with the 10.2.8SDK on 10.4 Tiger. Am using that build right now. Thanks for all your help again.
Last edited by drumsticks on May 12th, 2005, 3:40 am, edited 1 time in total.

neilio
 
Posts: 235
Joined: November 16th, 2002, 8:42 am

Post Posted May 8th, 2005, 7:30 pm

interesting stuff - I've been away for a couple of weeks and haven't been attempting to build under Tiger yet - what exactly would I need to do to get Firefox building on 10.4?

Neil

drumsticks
 
Posts: 607
Joined: April 14th, 2005, 4:32 am
Location: Australia

Post Posted May 8th, 2005, 7:52 pm

Hey Neil! Haven't heard from you in a while. Here's my steps...

1. Install Tiger + XCode 2.0 (Obviously)

2. Install Fink. I used the old version 0.7.1 binary installer, then installed from source the necessary packages as outlined in http://www.mozilla.org/build/mac.html You will need to to run "sudo gcc_select 3.3" as the GCC4.0 that shipped with XCode 2.0 is broken.

3. Apply mento's patch from https://bugzilla.mozilla.org/show_bug.cgi?id=292530 You can safely skip the first file in the patch if you have not checked out for Camino.

4. Run autoconf 2.13 (*very* important - See Comment #59 in Bugzilla) in both the top level mozilla source directory and in the nsprpub directory as well. See Comment #56 in bugzilla.

5. If you're targeting SDK less then 10.3.9 exclusive, then you will need need to modify /sw/include/libIDL/libIDL/IDL.h as per mento's comment above on 24 April. Otherwise, you can skip this step. See Comment #64 in bugzilla. <b>Edit: This is no longer necessary in the latest patch. Undo your modification if you have made them.</b>

6. Compile as per normal...

You can also compile Thunderbird once everything is setup as per above. Should I continue building or are you happy to resume control of Firefox G5? I was going to spin another build in a few hours when I get home. I'll still continue to build Thunderbird G5 as no one else seems to be doing so.
Last edited by drumsticks on May 10th, 2005, 5:33 pm, edited 1 time in total.

|2uso

User avatar
 
Posts: 67
Joined: March 6th, 2004, 10:37 am
Location: Venezuela

Post Posted May 8th, 2005, 8:04 pm

Ok, drumsticks, you forgot that autoconf has to be v2.13 mandatory

Well, well, well... some good news: I build Camino with SDK 10.2.8 and patch v9 (mento's way) with this optimization flags: -O2 -funroll-loops -fstrict-aliasing -ffast-math -mcpu=G5 -mtune=G5 -mpowerpc64 -mpowerpc-gpopt -mpowerpc-gfxopt -faltivec (I'm posting right now with the resulting build). I think build Firefox with all this considerations will be a piece of cake.

Tomorrow morning I'll post about my FF SDK 10.2.8 build, but I think that all of us know the results ;-)

Once again --> THANK YOU VERY MUCH MENTO and thank you too drumsticks for share your experiences here

BTW, I have to change my signature :-D
Macintosh G5/1800 uniprocessor - 1Gb RAM - 320 Gb SATA soft raid strip mode
Mac OS X 10.4.3 - XCode 2.1 - GCC 4.0
Camino G5 optimized home made

Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 1 guest