MozillaZine

Light, a light firefox

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
DAC324
 
Posts: 180
Joined: October 19th, 2007, 1:54 am

Post Posted September 17th, 2015, 4:15 am

Bollerkopp wrote:Thank you very much for the german version. Works great so far. :-)

Where can the German version be found?

Update: Nevermind. I finally found it :)

Another update: Light hangs on http://www.networkworld.com/article/218 ... erfox.html ("Not Responding").
Used Light 40.0 64-bit from the 40test directory on Sourceforge.

It seems to be related to Flash. Facebook does not work as well.




Kind regards,
DAC324

nugar
 
Posts: 4
Joined: December 1st, 2005, 2:02 am

Post Posted September 17th, 2015, 3:06 pm

I've downloaded Firefox Lite build 40, I have an issue with it, in that it won't load up a https web page, always throws up an error message, I'm assuming something has been stripped out of it that refuses to allow https sites to load. This is the error message I get "Secure Connection Failed

An error occurred during a connection to forums.wildstar-online.com. Unknown code ___P 2

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem."

Is there a lite version that allows https sites to load. If no, then how do I get Lite to load https pages.

greyowl2
 
Posts: 74
Joined: December 30th, 2009, 8:04 pm
Location: Canada

Post Posted September 20th, 2015, 8:24 am

I tried to upgrade from Light 40 to 41 but it does not work.
I got a message: "This appication has failed to start because api-ms-win-crt-runtime-|1-1-0.dll was not found".
I am running Windows XP.
I reverted back to Light 40 which works.
Please investigate and advise me when a corrected version of 41 is available.

cstkingkey
 
Posts: 123
Joined: October 30th, 2013, 10:47 pm

Post Posted September 20th, 2015, 9:17 am

greyowl2 wrote:I tried to upgrade from Light 40 to 41 but it does not work.
I got a message: "This appication has failed to start because api-ms-win-crt-runtime-|1-1-0.dll was not found".
I am running Windows XP.
I reverted back to Light 40 which works.
Please investigate and advise me when a corrected version of 41 is available.


please install the vc2015 redist, which I have provided in the top download folder.

cstkingkey
 
Posts: 123
Joined: October 30th, 2013, 10:47 pm

Post Posted September 20th, 2015, 9:23 am

nugar wrote:I've downloaded Firefox Lite build 40, I have an issue with it, in that it won't load up a https web page, always throws up an error message, I'm assuming something has been stripped out of it that refuses to allow https sites to load. This is the error message I get "Secure Connection Failed

An error occurred during a connection to forums.wildstar-online.com. Unknown code ___P 2

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem."

Is there a lite version that allows https sites to load. If no, then how do I get Lite to load https pages.

This web site has bad ssl configure, which doesn't meet firefox's minimum requirement. To workaround this, set security.tls.version.fallback-limit to 1.

Gemini6
 
Posts: 7
Joined: March 24th, 2014, 10:45 am

Post Posted September 21st, 2015, 3:35 am

Hello, I am still using ver.28, but as some sites say it is not completely compatible and recommend me to update.
So, I tried 40, 38, 36, and 30, but "customize" feature does not seem to work in either of them. Is there a work around?

PS: I uninstalled ver. 28 completely, and installed ver. 40. Now the "customize" feature works. So, maybe the other versions work, too.

Thank you so much for this light browser!!
Last edited by Gemini6 on September 28th, 2015, 8:15 pm, edited 1 time in total.

greyowl2
 
Posts: 74
Joined: December 30th, 2009, 8:04 pm
Location: Canada

Post Posted September 22nd, 2015, 5:43 pm

cstkingkey wrote:
greyowl2 wrote:I tried to upgrade from Light 40 to 41 but it does not work.
I got a message: "This appication has failed to start because api-ms-win-crt-runtime-|1-1-0.dll was not found".
I am running Windows XP.
I reverted back to Light 40 which works.
Please investigate and advise me when a corrected version of 41 is available.


please install the vc2015 redist, which I have provided in the top download folder.


Thank you for the response.
I don't understand where to find the vc2015 redist.
Please help.

cstkingkey
 
Posts: 123
Joined: October 30th, 2013, 10:47 pm

Post Posted September 22nd, 2015, 6:05 pm

greyowl2 wrote:
cstkingkey wrote:
greyowl2 wrote:I tried to upgrade from Light 40 to 41 but it does not work.
I got a message: "This appication has failed to start because api-ms-win-crt-runtime-|1-1-0.dll was not found".
I am running Windows XP.
I reverted back to Light 40 which works.
Please investigate and advise me when a corrected version of 41 is available.


please install the vc2015 redist, which I have provided in the top download folder.


Thank you for the response.
I don't understand where to find the vc2015 redist.
Please help.

http://sourceforge.net/projects/lightfi ... e/download
http://sourceforge.net/projects/lightfi ... e/download

greyowl2
 
Posts: 74
Joined: December 30th, 2009, 8:04 pm
Location: Canada

Post Posted September 24th, 2015, 8:36 am

Thank you for the links.
Can I install it on top of Light 40.0?
Or, should I uninstall Light 40.0, and then do a clean install of vc2015 redist?

cstkingkey
 
Posts: 123
Joined: October 30th, 2013, 10:47 pm

Post Posted September 24th, 2015, 7:39 pm

greyowl2 wrote:Thank you for the links.
Can I install it on top of Light 40.0?
Or, should I uninstall Light 40.0, and then do a clean install of vc2015 redist?


It doesn't matter. Either way is ok.

greyowl2
 
Posts: 74
Joined: December 30th, 2009, 8:04 pm
Location: Canada

Post Posted September 25th, 2015, 10:05 am

cstkingkey wrote:
greyowl2 wrote:Thank you for the links.
Can I install it on top of Light 40.0?
Or, should I uninstall Light 40.0, and then do a clean install of vc2015 redist?


It doesn't matter. Either way is ok.


It works now.
Thank you for the help.
I notice a bit of a glitch. When I don't have the Menu Bar enabled and press the alt key, the menu bar does not respond.

cstkingkey
 
Posts: 123
Joined: October 30th, 2013, 10:47 pm

Post Posted September 25th, 2015, 2:57 pm

greyowl2 wrote:
cstkingkey wrote:
greyowl2 wrote:Thank you for the links.
Can I install it on top of Light 40.0?
Or, should I uninstall Light 40.0, and then do a clean install of vc2015 redist?


It doesn't matter. Either way is ok.


It works now.
Thank you for the help.
I notice a bit of a glitch. When I don't have the Menu Bar enabled and press the alt key, the menu bar does not respond.

can't confirm this.

Gemini6
 
Posts: 7
Joined: March 24th, 2014, 10:45 am

Post Posted October 6th, 2015, 8:27 pm

I am using ver.40, and I am globally happy with it. Thanks for this light browser.
However, I cam across a problem. I am in a hotel IBIS, and when I want to connect to a hotel wifi, and log in. Light displays the following message.

Quote
This Connection is Untrusted
You have asked Light to connect securely to duckduckgo.com, but we can't confirm that your connection is secure.
Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.
What Should I Do?
If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.
This site uses HTTP Strict Transport Security (HSTS) to specify that Light only connect to it securely. As a result, it is not possible to add an exception for this certificate.
Unquote

I tried Firefox 40, and Firefox does not have any problem, and I can log in.
So, I tried to copy "nssckbi.dll" from Firefox to Light and over-write it, but there is no "nssckbi.dll" in Light. I copied it anyway, but this did not solve the issue...

Can you please help me with this?

cstkingkey
 
Posts: 123
Joined: October 30th, 2013, 10:47 pm

Post Posted October 6th, 2015, 9:16 pm

Gemini6 wrote:I am using ver.40, and I am globally happy with it. Thanks for this light browser.
However, I cam across a problem. I am in a hotel IBIS, and when I want to connect to a hotel wifi, and log in. Light displays the following message.

Quote
This Connection is Untrusted
You have asked Light to connect securely to duckduckgo.com, but we can't confirm that your connection is secure.
Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.
What Should I Do?
If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.
This site uses HTTP Strict Transport Security (HSTS) to specify that Light only connect to it securely. As a result, it is not possible to add an exception for this certificate.
Unquote

I tried Firefox 40, and Firefox does not have any problem, and I can log in.
So, I tried to copy "nssckbi.dll" from Firefox to Light and over-write it, but there is no "nssckbi.dll" in Light. I copied it anyway, but this did not solve the issue...

Can you please help me with this?


If you want to add an exception, remove SiteSecurityServiceState.txt from your profile.
And if the nssckbi.dll is effective, there shall be more certificates in the certificate manager.

Gemini6
 
Posts: 7
Joined: March 24th, 2014, 10:45 am

Post Posted October 7th, 2015, 8:13 pm

cstkingkey wrote:
Gemini6 wrote:I am using ver.40, and I am globally happy with it. Thanks for this light browser.
However, I cam across a problem. I am in a hotel IBIS, and when I want to connect to a hotel wifi, and log in. Light displays the following message.

Quote
This Connection is Untrusted
You have asked Light to connect securely to duckduckgo.com, but we can't confirm that your connection is secure.
Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.
What Should I Do?
If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.
This site uses HTTP Strict Transport Security (HSTS) to specify that Light only connect to it securely. As a result, it is not possible to add an exception for this certificate.
Unquote

I tried Firefox 40, and Firefox does not have any problem, and I can log in.
So, I tried to copy "nssckbi.dll" from Firefox to Light and over-write it, but there is no "nssckbi.dll" in Light. I copied it anyway, but this did not solve the issue...

Can you please help me with this?


If you want to add an exception, remove SiteSecurityServiceState.txt from your profile.
And if the nssckbi.dll is effective, there shall be more certificates in the certificate manager.


Now, having copied nssckbi.dll, there seem to be more certificates in the certificate manager, and having removed SiteSecurityServiceState.txt from my profile, I see "I understand the risks" and I can add an exception.

So, everything seems to be the way I wanted. Thank you so much for your support.

Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 1 guest