MozillaZine

[FX/TB] MacOSX Builders Unite!

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted September 20th, 2005, 8:55 pm

A strange problem that happens often the past few days, while using the nightly trunk (Gecko 1.9a1) builds: complete lost focus whne closing a tab

Have a few tabs open. Close the first tab. The next (second) tab is now in front, but nothing in the window has focus ! There is no way to scroll through the page with the keyboard. Tabbing through links is impossible. The tab itself has no focus. But the app, the window is in the foreground.
Clicking anywhere in the page with the pointer restores the focus. Or cycling through the open tabs also restores the focus.

This doesn't happen if I close the last tab.

myzar74
 
Posts: 694
Joined: June 25th, 2004, 2:22 am

Post Posted September 22nd, 2005, 7:12 am

Any chance that some of you can compile a X86 build ? there's a pre beta 1 around

http://weblogs.mozillazine.org/josh/arc ... e_x86.html

a newer branch ver would be cool :)

ankh

User avatar
 
Posts: 503
Joined: November 8th, 2003, 6:09 pm

Post Posted September 24th, 2005, 2:12 pm

Go to the home page, then the Mailing List archive

http://mozdev.org/pipermail/greasemonkey/

In the archive, look for mention of and a link for an update, beta, hack, or something -- last time it failed for me I found a v.0.6.2 by doing that, and it's still working (OSX nightlies). There may well be something newer, I don't tend to look until something breaks.

The mailing list seems to be the only contact point, there's no email or home page I can find other than the one at Mozdev.

NOTE: I don't know what I'm talking about, just what I've stumbled across, someone should correct me fairly soon.

Lost User 166223
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted September 24th, 2005, 4:54 pm

furbism.com seems to be down...is there any site where the current builds made by elfurbe are mirrored?

Also, I don't see anywhere any information as to what version of OS X is needed. I tried running elfurbe's G3-optimized Trunk builds on my iBook with 10.2.8, but it doesn't work at all (is it possible for 10.2 support to be added in, then?).

drumsticks
 
Posts: 607
Joined: April 14th, 2005, 4:32 am
Location: Australia

Post Posted September 25th, 2005, 1:05 am

rampancy: IIRC elfurbe is building using GCC4 on 10.4, which currently can only build for 10.3 and above. It is possible to build using GCC3.3 to provide 10.2 support though. See what he says...

Old R.Marotta
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted September 25th, 2005, 3:39 am

Check Here, This version works on Firefox 1.5 Beta 1 - http://greaseblog.blogspot.com/

drseuss9311

User avatar
 
Posts: 61
Joined: May 28th, 2004, 6:06 pm
Location: ILM

Post Posted September 25th, 2005, 7:55 pm

<b>rmpmw:</b> thanks... i found it after i posted that (and bookmarked it), then forgot to check back here for a few days. Works fine... I've also got Tab Browser Preferences 1.2.8.4
I downloaded the Nightly Tester Tools but I've disabled it for now.
ABP : AiOS : Chatzilla : Customize Google : FireFTP : Flashblock : Greasemonkey : MrTech Toolkit : Coralize (not updated yet) : Context Search : Searchbar Autosizer :: iBookG4

Lost User 117706
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted September 26th, 2005, 8:14 am

why no new builds lately ?

elfurbe

User avatar
 
Posts: 447
Joined: May 24th, 2004, 9:48 am
Location: Tucson, AZ

Post Posted September 28th, 2005, 11:22 am

Builds will be sporadic for a while. I switched jobs and I no longer have a tower to do my building on. I'm still searching for a replacement, but until then, my builds all come off my Powerbook, and I don't like building on my Powerbook, as it heats it up quite a bit and it takes a long time. At best, you might see weekly installments, at worst, you might see nothing. I'm doing what I can. Glad to see someone even misses them. :)

cbparker
 
Posts: 4
Joined: March 7th, 2005, 7:59 am

Post Posted September 29th, 2005, 6:39 am

Your builds are definitely missed. Have you considered turning down the processor speed in energy saver? This should keep things from getting as hot. Another possibility is that you could install Esperance DV, which, it is my understanding, is a disk image that is held in ram. There is an option to move the xcode builds and intermediate files there, which should help with hard drive utilization.

It can be found here
http://www.mparrot.net/index.php?page=freewares&lang=en

or on versiontracker, like everything else.

LordBodak
 
Posts: 64
Joined: May 18th, 2003, 8:21 am
Location: Virginia Beach, VA USA

Post Posted September 29th, 2005, 3:25 pm

elfurbe, your builds are greatly missed!

drseuss9311

User avatar
 
Posts: 61
Joined: May 28th, 2004, 6:06 pm
Location: ILM

Post Posted October 10th, 2005, 3:49 pm

anyone here using elfurbe's 1.5beta1 have trouble getting the beta2 patch? or do you just get the new .dmg for beta2??

Yesterday I opened ffx and got the beta2 one time homepage but in about it still says beta1....

i also had downloaded the beta1 release from mozilla.org as a backup incase elfurbe's goes awry, so i cracked it open and got the beta2 one time homepage, and in about it said 1.6a1 still...

just wondering if i should fill out a bug i guess.
ABP : AiOS : Chatzilla : Customize Google : FireFTP : Flashblock : Greasemonkey : MrTech Toolkit : Coralize (not updated yet) : Context Search : Searchbar Autosizer :: iBookG4

Lost User 117706
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted November 2nd, 2005, 3:19 pm

rc1 for g4 anyone ?

elfurbe

User avatar
 
Posts: 447
Joined: May 24th, 2004, 9:48 am
Location: Tucson, AZ

Post Posted November 3rd, 2005, 7:50 pm

I built versions today, but they seem odd. I can't get any of the search plugins to work. No idea why. They're up on my site if you want them:
http://www.furbism.com/firefoxmac

drumsticks
 
Posts: 607
Joined: April 14th, 2005, 4:32 am
Location: Australia

Post Posted November 3rd, 2005, 9:21 pm

elfurbe: We're discussing the same problem in my thread and here in its own thread. I can't seem to track down a bugzilla bug. Perhaps we should file one?

Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 2 guests