MozillaZine

[FX] elfurbe: Nightly [Branch|Trunk/OSX] (G3/G4/G5/Intel)

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
elfurbe

User avatar
 
Posts: 447
Joined: May 24th, 2004, 9:48 am
Location: Tucson, AZ

Post Posted July 26th, 2010, 11:50 am

So I enabled the update packaging on the 3.6.8 stable build which was a mistake. It will now update you to the newest 3.6.x branch nightly build for your architecture rather than to the newest stable build for your architecture. I'm working on a fix there, but for the moment, you can go to about:config and empty the app.update.url.override variable which will keep you from updating.

My bad.

davheyde
 
Posts: 1
Joined: August 31st, 2010, 1:16 am

Post Posted August 31st, 2010, 1:34 am

Hi elfurbe, first of all, let me say thank you! I've been using your builds of Firefox on my G4 iMac for over a year now and can say they're by far the fastest browsers I can find for this old machine. However, I've read that Mozilla has dropped support for PowerPC on the newest betas of 4.0, and indeed your 4.0 builds will not run on my machine. Can you point me to some older builds of 4.0 that will work for me?

MacTed
 
Posts: 33
Joined: October 30th, 2006, 9:47 pm

Post Posted September 12th, 2010, 7:48 pm

Just in case you haven't noticed this, elfurbe... Builds seem to have died on Aug 29.

steviant
 
Posts: 5
Joined: April 25th, 2005, 11:01 pm

Post Posted September 13th, 2010, 12:19 am

The builds stopped on Aug 29 again... I doubt anyone's listening, but what have I go to lose?

elfurbe

User avatar
 
Posts: 447
Joined: May 24th, 2004, 9:48 am
Location: Tucson, AZ

Post Posted September 19th, 2010, 3:20 am

Yeah, I just noticed a day or two ago. We did a generator test at the office and it shut my G5 off. Such is life. Back in business now.

MacTed
 
Posts: 33
Joined: October 30th, 2006, 9:47 pm

Post Posted October 25th, 2010, 11:54 am

Stalled again, since the 16th...

And I'm curious about the lack of 4.x builds for Intel. Not that I'm currently needing them, just wondering what's up with their lack. :-)

Ted

DriftSK

User avatar
 
Posts: 1
Joined: November 2nd, 2010, 12:55 pm

Post Posted November 2nd, 2010, 1:09 pm

To whom it may concern: builds for PPC 7450 started working again somewhere in between 4.0b6 and 4.0b7, supposedly because developers fixed the (well known) issue that caused the crash on PPC. This means you CAN actually use 4.0b7 (which I am doing, as I'm typing this post right now :) )

On the other side, something went wrong AGAIN on September, 30th: all PPC builds from that day onwards are broken as they only show a blank frame with title bar and no content at all. I guess this is caused by some other nasty PPC-related glitch that didn't affect x86 builds... and I'm afraid this means we're out in the cold again because no official developer will patch this, as the Foundation officially dropped PPC support in the meantime.

The good news: binaries built on September, 29th are working fine... at least the 7450 package I'm running on my Mini G4. Too bad that fell a few days short the "unofficial" Beta 7 freeze. I'd have appreciated a somewhat stable release.

elfurbe

User avatar
 
Posts: 447
Joined: May 24th, 2004, 9:48 am
Location: Tucson, AZ

Post Posted November 10th, 2010, 1:30 pm

Sorry guys. Looks like my G5 was off again. I do not know why. I've turned it back on, should see new builds tomorrow.

MonkeyBoy
 
Posts: 2
Joined: November 27th, 2003, 6:23 pm

Post Posted November 11th, 2010, 12:06 pm

Thanks for restarting the build farm (well, basically :) ).

In it's absence though I got motivated and started building my own nightlies. Only problem is that I'm stymied putting together a .mozconfig that will allow a G4/G5 to create an optimized Intel binary under 10.5. All the official documentation seems to have been changed to assume I'll be running 10.6 if I'm building an Intel binary. Any chance you could post your Intel .mozconfig here elfurbe? Apologies if you've posted it before, I spent some time scanning the build threads but given the number of pages I might've missed it.

Thanks again for building/hosting these things, I've pointed tons of people to furbism over the years.

Edit: Oh, and the .mozconfig for 3.6 since the 4.0 is offlimits for PPC, at least for the time being, since this is just for fun I'm not interested in sucking down both 1.9.x and 2.0 branches.

Edit #2: Well hot damn, I hit upon the magic combination of error messages to plug into Google and found what I needed. Or at least it got me further than before, the stumbling block then was my own stupidity (stripped x86 from /Developer/SDK, ooops) but at least that was easy to resolve.

MacTed
 
Posts: 33
Joined: October 30th, 2006, 9:47 pm

Post Posted December 16th, 2010, 10:04 am

hola, elfurbe --

It seems your G5 may have a bad power supply ... or something. Maybe it's got a rogue periodic shutdown setting in Energy Saver? (no builds for a week again...)

Whizbang
 
Posts: 1
Joined: January 18th, 2011, 11:44 pm

Post Posted January 18th, 2011, 11:46 pm

Hey there elfurbe, thanks for these builds. It looks like your computer crashed again, though.

MacTed
 
Posts: 33
Joined: October 30th, 2006, 9:47 pm

Post Posted January 20th, 2011, 1:05 pm

I'm totally jonesing for an updated build! (two weeks since the last round...)

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted January 22nd, 2011, 10:26 am

MacTed wrote:I'm totally jonesing for an updated build! (two weeks since the last round...)

Try the TenFourFox Beta 9 builds for PPC (has a working nanojit for G3 and G4 Macs):
http://www.floodgap.com/software/tenfourfox/

Phil

yan.kun0567
 
Posts: 1
Joined: February 10th, 2011, 1:20 am

Post Posted February 10th, 2011, 1:24 am

Don't know if this is the right thread to ask, I will just give it a go. This morning I tried to install the G4 7450 optimized Version of 3.6.13 on my PowerMac G4 MDD Dual 1.25 Ghz (running 10.4.11) and it has run fine for about a minute but than crashed and couldn't be opened again. The system reported that the symbol NSURLHandler couldn't be found. Does anybody have a clue, what this could mean? I tried to visit this site:
http://www.f1total.com

floodo1
 
Posts: 5
Joined: May 24th, 2006, 9:34 pm

Post Posted February 12th, 2011, 1:11 pm

no new intel builds? last one is from nearly 2 weeks ago and for firefox4 is beta11pre...meanwhile firefox has released official beta 11 :(

Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 1 guest