MozillaZine

Having trouble building Firefox For Android

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
Abstract3000
 
Posts: 1
Joined: January 21st, 2016, 10:17 pm

Post Posted January 21st, 2016, 10:27 pm

Hello, So I am currently learning Open Source and starting with Firefox Android, I Am using VMware with Ubuntu 15, I followed this Tutorial: http://www.wou.edu/~zmiller12/
Everything was going great till the last part the build, and I am now encountering the following error in the terminal:

0:07.13 checking for YASM assembler... checking for yasm... no
0:07.13 checking for application to build... browser
0:07.13 checking if app-specific confvars.sh exists... /home/exodus/mercurial-3.7-rc/firefox/browser/confvars.sh
0:07.16 checking for pkg-config... /usr/bin/pkg-config
0:07.19 checking for gtk+-3.0 >= 3.4.0 gtk+-unix-print-3.0 glib-2.0 gobject-2.0 ... Package gtk+-3.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gtk+-3.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gtk+-3.0' found Package gtk+-unix-print-3.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gtk+-unix-print-3.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gtk+-unix-print-3.0' found Package glib-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `glib-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'glib-2.0' found Package gobject-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gobject-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gobject-2.0' found
0:07.19 configure: error: Library requirements (gtk+-3.0 >= 3.4.0 gtk+-unix-print-3.0 glib-2.0 gobject-2.0 ) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
0:07.19 ------ config.log ------
0:07.20 configure:15011: gcc -c -std=gnu99 -fgnu89-inline -fno-strict-aliasing -fno-math-errno -pthread conftest.c 1>&5
0:07.20 configure:15005:26: error: conflicting types for 'malloc_usable_size'
0:07.20 In file included from configure:15003:0:
0:07.20 /usr/include/malloc.h:129:15: note: previous declaration of 'malloc_usable_size' was here
0:07.20 extern size_t malloc_usable_size (void *__ptr) __THROW;
0:07.20 ^
0:07.20 configure: failed program was:
0:07.20 #line 15002 "configure"
0:07.20 #include "confdefs.h"
0:07.20 #include <malloc.h>
0:07.20 #include <stddef.h>
0:07.20 size_t malloc_usable_size(const void *ptr);

I am new to this so I have very little understanding as to what any of this means, the only deviation I made to the tutorial was I used Mercurial 3.7-rc instead of 3.6.3 as there were no linux Source versions available at the time of checking. Anybody know what this means and how I can go about getting it fixed so I can finish the build?
Thanks for your consideration.

DanRaisch
Moderator

User avatar
 
Posts: 119908
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 22nd, 2016, 6:16 am

Moving to Third Party/Unofficial Builds.

kbrosnan
 
Posts: 507
Joined: October 23rd, 2003, 8:32 pm

Post Posted April 26th, 2016, 5:19 pm


Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 1 guest