MozillaZine

Unofficial SeaMonkey 2.42 with DevTools (20160801)

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
isaacschemm
 
Posts: 232
Joined: January 20th, 2015, 12:29 pm

Post Posted March 7th, 2016, 11:15 am

Last updated August 1, 2016.

I've compiled an unofficial version of SeaMonkey 2.42 (based on Fx/TB 45 ESR) with the DevTools patch from 2.45 backported to it, for 32-bit Windows.

I also added the fix from bug 1204752, which allows this build (built with VS2015) to run on XP.

EXE installer
patches

Here's my .mozconfig:
Code: Select all
ac_add_options --enable-application=suite
ac_add_options --enable-optimize=-O2


You will need to install the Visual C++ 2015 redistributable package separately before this build will run.
Last edited by isaacschemm on August 2nd, 2016, 7:04 am, edited 7 times in total.

frg
 
Posts: 432
Joined: December 15th, 2015, 1:20 pm

Post Posted March 19th, 2016, 2:48 am

>> * I don't think this build works on Windows XP.

Put the patches for Bugzilla bugs 1204752 and 1229604 in your tree and the x86 version will work like a charm on XP and allows compiling with VS2015 Update 1. Already fixed in 2.43.

https://bugzilla.mozilla.org/show_bug.cgi?id=1204752
https://bugzilla.mozilla.org/show_bug.cgi?id=1229604

barbaz
 
Posts: 1677
Joined: October 1st, 2014, 3:25 pm

Post Posted March 19th, 2016, 10:52 am

Built successfully for Linux x86_64 (comm-release + the patch / mozilla-release @ FIREFOX_45_0_1_RELEASE). Thanks libertyernie! :D :D
*Always* check the changelogs BEFORE updating that important software!

isaacschemm
 
Posts: 232
Joined: January 20th, 2015, 12:29 pm

Post Posted March 20th, 2016, 12:35 pm

Thanks frg4711.

I updated the OP with a new build from today, using comm-esr45.

barbaz
 
Posts: 1677
Joined: October 1st, 2014, 3:25 pm

Post Posted April 27th, 2016, 6:53 pm

These patch set doesn't apply cleanly on top of current comm-esr45. Need to apply this patch first now
Code: Select all
diff --git a/suite/browser/browser-prefs.js b/suite/browser/browser-prefs.js
--- a/suite/browser/browser-prefs.js
+++ b/suite/browser/browser-prefs.js
@@ -971,14 +971,11 @@ pref("services.sync.prefs.sync.security.
 pref("services.sync.prefs.sync.security.warn_mixed_active_content", true);
 pref("services.sync.prefs.sync.security.warn_mixed_display_content", true);
 pref("services.sync.prefs.sync.security.warn_submit_insecure", true);
 pref("services.sync.prefs.sync.security.warn_viewing_mixed", true);
 pref("services.sync.prefs.sync.signon.rememberSignons", true);
 pref("services.sync.prefs.sync.spellchecker.dictionary", true);
 pref("services.sync.prefs.sync.xpinstall.whitelist.required", true);
 
-// Enable the DOM fullscreen API.
-pref("full-screen-api.enabled", true);
-
 // Disable cache v2 since migration has not been done, it is pending in bug 1021843.
 pref("browser.cache.use_new_backend",       0);
 pref("browser.cache.use_new_backend_temp",  false);

(note that this patch probably results in disables Full Screen API by default)
*Always* check the changelogs BEFORE updating that important software!

isaacschemm
 
Posts: 232
Joined: January 20th, 2015, 12:29 pm

Post Posted May 4th, 2016, 10:52 am

Thanks. I was able to update the patch so I didn't have to remove that preference.

isaacschemm
 
Posts: 232
Joined: January 20th, 2015, 12:29 pm

Post Posted June 8th, 2016, 7:16 am

I updated the build with the newest ESR 45 updates as of yesterday.

Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 1 guest