MozillaZine

Mozilla 1.1.19 [RetroZilla] ObjDir not working

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
rn10950
 
Posts: 18
Joined: December 9th, 2014, 6:48 am

Post Posted September 26th, 2017, 11:01 am

I am the lead developer of the RetroZilla browser, an updated Mozilla 1.1.19 for Windows NT and 9x systems. I had to take a year off due to personal/family reasons, and now I am able to return to the project. I am trying to get the suite to build, but the build system, for some reason, doesn't respect the OBJDIR flag in the mozconfig. The suite builds perfectly, but drops the output in the code tree instead of the OBJDIR I set. I tried many things, using both relative (to SRCDIR) paths, absolute filesystem paths (both /c/ and C:\) and playing around with different versions of mozilla-build. I had this working before, but for some reason it doesn't now.

here's my mozconfig:
Code: Select all
#
# RETROZILLA SUITE (SEAMONKEY).MOZCONFIG TEMPLATE
#

# Make Options
mk_add_options MOZ_MAKE_FLAGS="-j4"

# Set line below to your desired object directory

mk_add_options MOZ_OBJDIR=/c/projects/objdir-sm95-release

# Configure Options
ac_add_options --target=i586-pc-msvc
ac_add_options --enable-application=suite
ac_add_options --enable-optimize
ac_add_options --disable-debug
ac_add_options --disable-tests
ac_add_options --without-system-jpg
ac_add_options --without-system-zlib
ac_add_options --enable-extensions=default,tasks
ac_add_options --enable-crypto
ac_add_options --enable-svg
ac_add_options --enable-canvas


Do any of you old timers out there have any idea what's going on?

Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 1 guest