MozillaZine

Mozilla 1.7b Linux XFT+GTK build available

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
fedetxf
 
Posts: 821
Joined: March 22nd, 2003, 7:56 am
Location: Argentina

Post Posted April 1st, 2004, 6:42 am

I tested the original poster's build. It's just the same as the 1.6 RPM found in the mozilla ftp among the contributed builds. The GTK and XFT things either are not detectable or are already included in the rpm build.
1.7 seems faster on startup.

fjleal

User avatar
 
Posts: 471
Joined: August 19th, 2003, 2:21 pm

Post Posted April 1st, 2004, 8:46 am

fedetxf, I compiled my 1.7b build when there was no XFT version available on the Mozilla ftp site. I don't know if there's already a XFT contributed build by now - probably. But the difference between a XFT-enabled and a normal version is quite clear on the screen, the anti-aliased fonts are smoother than the normal ones, and if you go to "Preferences -> Appearance -> Fonts", you can read the XFT fonts names, rather different from the old X ones. But if you want to find out any build's configuration, you can simply enter "about:buildconfig" in the URL. My build shows:

«
Configure arguments:

--disable-tests --disable-debug --enable-optimize --without-system-nspr --without-system-zlib --without-system-jpeg --without-system-png --without-system-mng --enable-crypto --enable-xft --enable-default-toolkit=gtk2
»

The arguments list and instructions for building can be found at www.mozilla.org/build

fedetxf
 
Posts: 821
Joined: March 22nd, 2003, 7:56 am
Location: Argentina

Post Posted April 1st, 2004, 9:40 am

All I was saying is that your build is the same as the 1.6 rpr contributed build that was available when 1.6 was released. I was not contradicting you, just wanted to check if I was missing something by using the version I am using.

fjleal

User avatar
 
Posts: 471
Joined: August 19th, 2003, 2:21 pm

Post Posted April 1st, 2004, 11:50 am

My build was made from the 1.7b source in Moz FTP site. I don't know the 1.6 RPM contributed build, but if it is version 1.6, it's not the same.

Can you please consult the "Help -> About" function and post the second line of text (the one underneath the big blue "Mozilla" link, right side of the logotype) from the version you're using? Mine reads "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040320". I'm curious, now... ;)

fedetxf
 
Posts: 821
Joined: March 22nd, 2003, 7:56 am
Location: Argentina

Post Posted April 1st, 2004, 11:59 am

Your version is 1.7. I quote myself: "1.7 seems faster on startup."
I wanted to see if xft and gtk-anable builds are different from my 1.6 rpm build.
They are not. As for version number, yes yours is 1.7, mine is 1.6 and I installed your 1.7 to check xft and gtk and now I deleted because i'll wait for the 1.7 final rpm.
Keep the good work building mozilla's.

fjleal

User avatar
 
Posts: 471
Joined: August 19th, 2003, 2:21 pm

Post Posted April 1st, 2004, 4:19 pm

Thanks a lot! I'm glad it's been useful. Sorry if I messed up your posts a little, I shouldn't read Moz'zine late at night... ;)

As for the 1.7 increase in speed, Moz site reads:

www.mozilla.org wrote:When compared to Mozilla 1.6, Mozilla 1.7 Beta is 7% faster at startup, is 8% faster at window open time, has 9% faster pageloading times, and is 5% smaller in binary size.


...but, honestly, I couldn't notice the speed increase. Version 1.6 was already very fast. :)

Oh, there's one more nice feature in 1.7 GTK+XFT builds:

www.mozilla.org wrote:Support for smb:// URLs using the gnome-vfs library (only enabled in GTK2+XFT Linux builds).

sime

User avatar
 
Posts: 46
Joined: December 4th, 2002, 6:17 pm

Post Posted April 9th, 2004, 6:03 am

That GTK2 (i think) shortcut conflict bug is still around:

Ctrl+Shift+C in Mail/News to mark all messages in folder read does not work with GTK2 builds.

fjleal

User avatar
 
Posts: 471
Joined: August 19th, 2003, 2:21 pm

Post Posted April 9th, 2004, 9:34 am

Yes, looks like it doesn't really work. But the menu option "Message -> Mark -> All read" does. I never use that function, so I hadn't realized it wasn't working... Does this happen in GTK-enabled builds only?

sime

User avatar
 
Posts: 46
Joined: December 4th, 2002, 6:17 pm

Post Posted April 9th, 2004, 2:37 pm

i read on a similar forum someone building thunderbird .5 and ran into the same problem. I don't know much more than that.

joelee
 
Posts: 265
Joined: June 17th, 2003, 7:40 pm

Post Posted April 13th, 2004, 8:33 pm

Does anyone has problem with this build that the email does not remove from server after retrieve ? I check mail on other PC and found duplicated message. Since I completely removed it and the profile as well, and installed other build for testing, I can't simulate the problem again. If it is the my profile problem then I will reinstall it again, the font is really nice.

fjleal

User avatar
 
Posts: 471
Joined: August 19th, 2003, 2:21 pm

Post Posted April 14th, 2004, 12:54 am

It is probably your profile, or the "Leave messages on server" option turned on, on each account's properties screen, under "Server Settings".

joelee
 
Posts: 265
Joined: June 17th, 2003, 7:40 pm

Post Posted April 14th, 2004, 12:56 am

I guess is my profile problem then.

Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 1 guest