MozillaZine

Darkstar: Win32 2004-05-04 (O2-GAL6/7-SSE/2) Modern CPUs

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
sexycatsinhats
 
Posts: 120
Joined: April 11th, 2004, 11:51 pm

Post Posted April 26th, 2004, 1:37 am

First of all, I would like to thank: TierMann, Djeter, Silver, Lohvarn, Jayfromtaiwan, pryan, BlueFyre, Turn It Down, Mook, xebechene, and many others who helped make my builds possible and better than ever.

Built using MSVC++ .NET 2003. (Ex. O2/GAL7 is short for O2/GA/GL/G7)

My builds are using the new official Firefox artwork by Jon Hicks.

Optimized for Pentium 4, Newer Celerons, Athlon 64, and Althon FX only - O2/GAL7/SSE2
>> http://pryan.org/mozilla/firefox/Darkst ... 4_SSE2.exe (~5.6MB 7-z extractor)

Optimized for Athlon XP, Older Celerons and above - O2/GAL6/SSE
>> http://pryan.org/mozilla/firefox/Darkst ... 04_SSE.exe (~5.6MB 7-z extractor)

(Build Archive)

It will create a 'Firefox' folder upon extracting

Patches:
171082 - Do everything possible to minimize the build size
174764 - Add "Set as Bookmark Toolbar folder" to the bookmarks folder context menu
175629 - Loading links in background tabs should work for bookmarks
177507 - When Toolbar is in text mode the bookmarks toolbar loses the "spill over" chevron icon
178078 - Toolbar customization dialog doesn't always fit on screen
178079 - Window can be moved when toolbar customization dialog active; dialog doesn't move
178120 - Chevron does not dissapear even though you make room on the Bookmark Toolbar
185382 - Alt+Enter for opening URL in new tab doesn't work on WinME
203756 - Patch to enable URLBar autofill with "browser.urlbar.autoFill" property
204519 - Add Print option on main context menu (Like IE)
212904 - http://foo/bar/ default save name should be bar.html
217664 - Ability to use the same proxy for all protocols
226068 - Option "for the originating Web site only" loses selection if "Load Images" is not selected
233582 - OK button does not work after site is added to
235915 - RemovePage method is no longer part of nsIBrowserHistory interface
236586 - Change customization text to include item removal
237542 - Firefox should have a Tools > Mail submenu to match new toolbar button
237959 - Mail Integration Label should be below icon, not next to it
240655 - ConsoleBindings.xml may want to port over XPFE changes
241700 - alt+spacebar must be pressed twice to activate Windows control menu
241068 - Crash when trying to enter text in input field.
^Bold items above indicate critical bugs that were recently fixed.


My .mozconfig goes like this

Code: Select all
ac_add_options --disable-ldap

ac_add_options --disable-mailnews
ac_add_options --enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,
typeaheadfind,webservices,inspector
ac_add_options --enable-crypto
ac_add_options --disable-composer
ac_add_options --disable-profilesharing
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize="-O2 -GAL7 -arch:SSE2"
ac_add_options --enable-static
ac_add_options --disable-shared
ac_add_options --disable-installer


Added some optimization tweaks to the firefox.js file too for a 'speedy' effect
Code: Select all
pref("browser.enable_automatic_image_resizing", false);
user_pref("content.interrupt.parsing", true);
user_pref("content.max.tokenizing.time", 3000000);
user_pref("content.maxtextrun", 8191);
user_pref("content.notify.backoffcount", 5);
user_pref("content.notify.interval", 750000);
user_pref("content.notify.ontimer", true);
user_pref("content.switch.threshold", 750000);
user_pref("network.http.pipelining", true);
user_pref("network.http.proxy.pipelining", true);
user_pref("nglayout.initialpaint.delay", 750);

*Note: If you are not comfortable with the above settings, I would suggest you try djeter's builds as they are almost identical and have no customized .js file. If you like a different .js file and want to make firefox perform better for you, please read the Firefox Tuning Guide. Lastly, if you have your own .js file in your profile directory, it will override anything that goes in your Firefox folder (My builds extract it into the Firefox folder).

I changed my building schedule until I find out why I can't build branch correctly:
Sat. and Sunday - Reserved for custom builds and requests
Monday Through Friday - Trunk

Enjoy!

Need a custom build? Pm me with the details
Last edited by sexycatsinhats on May 4th, 2004, 1:35 am, edited 43 times in total.

askwar

User avatar
 
Posts: 45
Joined: April 25th, 2003, 12:29 am

Post Posted April 26th, 2004, 1:54 am

You are aware, that quite some servers have problems with pipelining? IMO these settings shoudln't be enabled in "public" builds.

Jeff_pony
Moderator

User avatar
 
Posts: 8790
Joined: January 5th, 2003, 12:38 pm
Location: (.uk)

Post Posted April 26th, 2004, 1:57 am

Well its not like there is not enough unofficial builds that don't have the above enabled. Its nice to have one with these defaults.
Please PM the mod team when you see a rule infraction
Life State:: McLovin it
Camino v2.1 (pre)

sexycatsinhats
 
Posts: 120
Joined: April 11th, 2004, 11:51 pm

Post Posted April 26th, 2004, 2:17 am

askwar wrote:You are aware, that quite some servers have problems with pipelining? IMO these settings shoudln't be enabled in "public" builds.

Yes, some servers but overall.. everyone seems to enjoy it being enabled. Unless I see serious problems, I will keep it this way.

dmbfan36_23
 
Posts: 108
Joined: September 8th, 2003, 11:40 am

Post Posted April 26th, 2004, 7:44 am

Why

user_pref("nglayout.initialpaint.delay", 750);

and not setting it to 0? The default is 250.. correct?

storm119

User avatar
 
Posts: 742
Joined: October 2nd, 2003, 7:13 am
Location: *Land Below The Wind*

Post Posted April 26th, 2004, 8:13 am

Yup...you might want to see this Firefox Tuning .....

:)

askwar

User avatar
 
Posts: 45
Joined: April 25th, 2003, 12:29 am

Post Posted April 26th, 2004, 10:13 am

Darkstar: Well your choice - I think it's bad to enable settings which causes people to be unable to connect to certain sites. And I dislike that feature, because people tend to forget that this setting might have an effect, since it is so "hidden".
For example, with pipelining enabled, try to go to https://banking.diba.de/, which is a german banking site. You won't be able to do anything, since you'll get an error message telling you, that the browser does not support 128bit encryption. However, if you disable pipelining, you won't get that error message. Here's a screenshot, showing off the error message which you'll get. And that screenshot shows the functioning site, without pipelining.

loadbang

User avatar
 
Posts: 874
Joined: November 3rd, 2003, 12:18 pm
Location: Birmingham, UK.

Post Posted April 26th, 2004, 11:14 am

Need to add

network.http.pipelinging.firstrequest=true

All web sites that do not support pipelining should work now.

SwampFan

User avatar
 
Posts: 178
Joined: February 25th, 2003, 9:40 am
Location: Atlanta, GA

Post Posted April 26th, 2004, 11:41 am

howesey wrote:Need to add

network.http.pipelinging.firstrequest=true

All web sites that do not support pipelining should work now.


I believe that should be:

Code: Select all
user_pref("network.http.pipelining.firstrequest", true);


But, from the Tuning thread:

network.http.pipelining.firstrequest


* Description: enable pipelining on first request to a server.
* Type: boolean
* Default: false
* Additional Info: since it doesn't seem to get picked up anywhere in the source, this preference doesn't seem to be used. First requests are obviously never pipelined.
* Recommendation: do not use this preference. While it probably doesn't hurt, it will have no effect either.


I believe this is correct - adding the first request pref doesn't make any difference at all. I tried the bank link mentioned above and with or without this pref, the site would not load.
Last edited by SwampFan on April 26th, 2004, 11:49 am, edited 2 times in total.

Xu

User avatar
 
Posts: 1256
Joined: March 12th, 2004, 4:00 am
Location: Salt Lake City, Ut

Post Posted April 26th, 2004, 11:41 am

Jeff_pony wrote:Well its not like there is not enough unofficial builds that don't have the above enabled. Its nice to have one with these defaults.
I agree. :-)

Lohvarn

User avatar
 
Posts: 332
Joined: January 30th, 2004, 9:43 pm
Location: Fort Worth, TX

Post Posted April 26th, 2004, 11:55 am

The site works fine for me.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040414 Firehawk/0.8.0+ (Lohvarn)

My builds have pipelining turned on by default.

loadbang

User avatar
 
Posts: 874
Joined: November 3rd, 2003, 12:18 pm
Location: Birmingham, UK.

Post Posted April 26th, 2004, 2:34 pm

I think he knows what I mean SwampFan. ;)

sexycatsinhats
 
Posts: 120
Joined: April 11th, 2004, 11:51 pm

Post Posted April 26th, 2004, 4:57 pm

Thanks for the feedback.

I will not remove my custom .js settings unless it is becoming a real problem for everyone. As I think its nice to have builds that are different from others. The settings I have right now were made reading several configs and I went with this one, because its fast for most people. Other than that, if you want a different default for the settings, please post what I should change.

Thanks again

Jesse

User avatar
 
Posts: 398
Joined: November 4th, 2002, 7:00 pm
Location: Mountain View, CA

Post Posted April 26th, 2004, 10:22 pm

I don't like builds that come with different default prefs because they remove my own prefs when my prefs are the SAME as the builder's. For example, if I had pipelining enabled and used this build, this build would clear the pipelining pref from my prefs.js because it's the same as its default. Then if I went to another build, pipelining would suddenly be disabled for me!

sexycatsinhats
 
Posts: 120
Joined: April 11th, 2004, 11:51 pm

Post Posted April 27th, 2004, 3:59 am

well, if you want to keep your default .js file the way it is, then back it up, because no matter whos build your using.. its always going to overwrite it. Now Jesse, is there anything that you suggest adding or changing to my .js file up there?

UPDATE: 20040427 for SSE+SSE2 is up - go grab those if you havent. I fixed all the icons so now its the fox and the globe everywhere, also a new about screen. Enjoy :)

Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 1 guest