MozillaZine

Switching of Reminders in Thunderbird/Lightning

For discussing the Mozilla Calendar, Sunbird and Lightning projects.
OmniCan
 
Posts: 13
Joined: February 9th, 2006, 9:27 pm

Post Posted January 5th, 2009, 9:34 pm

I have a problem with the reminder alarm set for an event in Thunderbird with Lightning.
Once the reminder alarms pop up at the specified time prior to the event, they just keep reappearing relentlessly. They cannot be dismissed or made to snooze. Even changing the event back to no reminder required, and saving the event does not work. Has anyone encountered this problem? Would appreciate a fix or a workaround.
Thanks

Dartman
Moderator

User avatar
 
Posts: 11977
Joined: February 9th, 2006, 9:43 pm

Post Posted January 5th, 2009, 9:37 pm

I'll move you to the Calendar forum.
Alcohol and Calculus don't mix. Never drink and derive.

ssitter

User avatar
 
Posts: 2495
Joined: October 19th, 2007, 12:24 am
Location: Germany

Post Posted January 6th, 2009, 4:00 am

What Lightning version and OS do you use? Where do you store your events? In a local calendar, an iCalendar (ics) file, CalDAV server, ... ?

OmniCan
 
Posts: 13
Joined: February 9th, 2006, 9:27 pm

Post Posted January 6th, 2009, 9:54 pm

Oops-I should have provided additonal information for a proper resolution to my query earlier:
a.I use Windows XP Professional, Thunderbird 2.0.0.9, Lightning 0.9. Events are stored on Google Calendar.
b. I have no problems in syncing new events whenever I make an update in Google Calendar(on the web) or on my computer in Thunderbird.
c.The problem is only with changing/syncing reminders. Even if I make the change in Google, the pop-up alarms on Thunderbird/Lightning do not stop.
Would appreciate any input to fix this. Thanks.

bvdbos

User avatar
 
Posts: 708
Joined: January 6th, 2005, 11:23 am
Location: Helmond, Netherlands

Post Posted January 6th, 2009, 11:38 pm

https://bugzilla.mozilla.org/show_bug.cgi?id=457890
you can install the latest version of gdata-provider, then it should be solved:
https://addons.mozilla.org/nl/thunderbird/addon/4631

ssitter

User avatar
 
Posts: 2495
Joined: October 19th, 2007, 12:24 am
Location: Germany

Post Posted January 7th, 2009, 1:11 pm

How do you access Google Calendar? Via the read-only iCalendar feed? Via the Provider for Google Calendar extension? Via the new CalDAV support in Google Calendar? Do you have the experimental cache feature enabled for that calendar?

OmniCan
 
Posts: 13
Joined: February 9th, 2006, 9:27 pm

Post Posted January 10th, 2009, 10:41 pm

I access Google Calendar via the Provider v 0.5.1 for Google Calendar Extension. Experimental cache is enabled. Is there a step I have missed? Thanks.

ssitter

User avatar
 
Posts: 2495
Joined: October 19th, 2007, 12:24 am
Location: Germany

Post Posted January 11th, 2009, 4:57 am

I have read in other posts in this forum that the experimental cache causes this issue. You could disable it and check if the issue still exists.

OmniCan
 
Posts: 13
Joined: February 9th, 2006, 9:27 pm

Post Posted January 13th, 2009, 10:56 pm

I reinstalled the latest version of gdata provider from the Mozilla Addons site, just for good order's sake.(https://addons.mozilla.org/nl/thunderbird/addon/4631).
And disabled the experimental cache. This does largely solve the problem-whenever the alarm pops up, I can now dismiss it, and the alarm thankfully disappears. So this does partly solve the problem. Thanks!
However I wonder why changing the event back to no reminder required, and saving the event does not result in a change in the reminder settings of the event. If I change the time/date of the event, the change does come through on the calendar. So , there still seems to be some kind of limitation in the reminder setting function of the calendar.

Return to Calendar


Who is online

Users browsing this forum: No registered users and 2 guests