MozillaZine

CalDAV calendar momentarily not available

For discussing the Mozilla Calendar, Sunbird and Lightning projects.
ChefChaudart

User avatar
 
Posts: 519
Joined: March 3rd, 2004, 12:43 pm
Location: Belgium

Post Posted January 24th, 2009, 1:56 am

Hello,

I wanted to add my daughter's Google agenda in lightning, and it's not available ... :(

... But it works for my wife's Google agenda !?

One thing, I was never asked to enter a password, is it normal ?

Any idea to get this calendar available ?

Cheers

XP MCE sp3
TB version 2.0.0.20pre (20090122)
lighntning 0.9


[edit] the error is the same if I put xxx@xxx.xxx in parameters [/edit]
Do not forget Liu Xiaobo

Euchre

User avatar
 
Posts: 2804
Joined: April 16th, 2006, 12:48 pm

Post Posted January 25th, 2009, 11:15 pm

If you just want read only access to your daughter's Google calendar, you should just get the .ics link (iCal format) and add it as a subscription. CalDav access allows you to edit the calendar, is that what you really wanted to do with your daughter's calendar?
Gecko
One Rendering Engine to rule them all.

ssitter

User avatar
 
Posts: 2439
Joined: October 19th, 2007, 12:24 am
Location: Germany

Post Posted January 26th, 2009, 11:10 am

Have you specified the correct calendar type and calendar address when creating the calendar? Maybe you could list the exact steps you did?

In addition I'd recommend to check Tools > Error Console for related error messages.

ChefChaudart

User avatar
 
Posts: 519
Joined: March 3rd, 2004, 12:43 pm
Location: Belgium

Post Posted January 27th, 2009, 10:34 am

I went to calendar,

"New Calendar", "On the Network", "CalDAV", Then I put "https://www.google.com/calendar/dav/xxx.xxx@gmail.com/events"

No error in console ...


And yes, I want to be able to edit this calendar.

But, what is not normal IMO, at the end of the process, TB didn't asked me to enter a user & a password. #-o
Do not forget Liu Xiaobo

ChefChaudart

User avatar
 
Posts: 519
Joined: March 3rd, 2004, 12:43 pm
Location: Belgium

Post Posted January 31st, 2009, 5:10 am

In options, password manager, for working Google agenda´s, I see an entry like that "www.google.com 443 (Google CalDAV), Username ..."

is it possible to edit manually the file containing the saved password to add missing entries ? I´m quite sure, that in this case, the other calendars will work :-"
Do not forget Liu Xiaobo

ssitter

User avatar
 
Posts: 2439
Joined: October 19th, 2007, 12:24 am
Location: Germany

Post Posted January 31st, 2009, 5:27 am

See discussion in Bug 475188. Sounds like the CalDAV standard specifies that only one authentication is used per CalDAV server, i.e. www.google.com in that case. Access to other calendars is controlled by the CalDAV server. Maybe it would be possible to subscribe the calendar in your Google Calendar and subscribe it from Sunbird via your account?

ChefChaudart

User avatar
 
Posts: 519
Joined: March 3rd, 2004, 12:43 pm
Location: Belgium

Post Posted January 31st, 2009, 10:35 am

In fact, I got already 2 CalDAV calendars working. Even if one is not displayed in password management :|

But you'r right, this is about bug 475188 =D>
Do not forget Liu Xiaobo

Joemama155
 
Posts: 1
Joined: August 6th, 2009, 12:31 pm

Post Posted August 6th, 2009, 12:36 pm

Ok i know this thread is kinda old but i was having the same issue and figured out a work around. if you need to connect to 2 google caldav accounts have one connect to

https://www.google.com/calendar/dav/ema ... com/events

and the other to

https://74.125.45.100/calendar/dav/emai ... com/events
you will get a cert error but just ignore it and your calendar will sync, if this ip should stop working for you just go to Start -> RUN -> type in CMD and hit enter at the prompt type in ping google.com and replace the ip above with the ip you see in the command prompt (Mac and Lunix users im not sure how you would do this sorry)

Return to Calendar


Who is online

Users browsing this forum: No registered users and 1 guest