MozillaZine

Lightning Accept/Decline buttons missing

For discussing the Mozilla Calendar, Sunbird and Lightning projects.
ben87
 
Posts: 5
Joined: July 12th, 2012, 5:51 am

Post Posted July 12th, 2012, 5:56 am

Hello,

I am using Thunderbird 13.0.1 with Lightning 1.5.2. Unfortunately the buttons Accept/Decline are not visible if someone sends me an invite with Outlook.

Hope someone can help me please?

ben87
 
Posts: 5
Joined: July 12th, 2012, 5:51 am

Post Posted July 18th, 2012, 11:09 pm

Anyone?

ben87
 
Posts: 5
Joined: July 12th, 2012, 5:51 am

Post Posted July 18th, 2012, 11:15 pm

I upgraded to version 14 and lighting version 1,6 but I still have this issue.

brenboy78
 
Posts: 32
Joined: August 9th, 2006, 4:54 am

Post Posted July 25th, 2012, 8:10 pm

I see exactly the same issue.

I'm using Windows 7, TB 14.0, Lightning 1.6 and the Exchange 2007/2010 Calendar and Tasks Provider 2.2.0 add-on.

I also saw this issue with TB 13.0 and Lightning 1.5.x

opto
 
Posts: 6
Joined: January 31st, 2010, 5:02 am

Post Posted August 5th, 2012, 1:31 am

not sure how Outlook formats the invitation email.

Anyway, I made our own software send invitations and in this process I noticed that lightning only shows the buttons if there is a LOCATION specified in the ical/itip email.
Maybe outlook doesn't send this field? Do you get buttons if the location is explicitly set in Outlook?

Lightnings behaviour seems to be not conform with the itip/imip invitation rfc.

Klaus

brenboy78
 
Posts: 32
Joined: August 9th, 2006, 4:54 am

Post Posted August 7th, 2012, 6:06 am

The developer of the Exchange 2007/2010 Calendar and Tasks Provider add-on informed me that in my case, the invite is first being tentatively accepted by my Exchange account. As such there are no Accept/Decline buttons because Lightning sees the invite as "Accepted". I can accept/deny this invite later using the "Invitations:<x>" link that appears in the Status bar at the bottom of Thunderbird.

drbrake
 
Posts: 5
Joined: June 15th, 2010, 8:35 am

Post Posted June 12th, 2013, 9:52 am

I have the same problem
received an invite which showed that the e-mail contained an invite but no buttons to accept, decline, add to calendar etc.
I am running windows 7 64 bit, thuderebird 17.0.6 and lightning 1.9.1

Any help appreciated

ssitter

User avatar
 
Posts: 2495
Joined: October 19th, 2007, 12:24 am
Location: Germany

Post Posted June 13th, 2013, 10:23 am

Lightning can only send invitations and invitations responses if an email account is configured for the calendar and if the calendar supports invitations. I suggest that you check the email settings in the calendars properties dialog that can be accessed if you double click the calendar entry in the left pane.

boutells
 
Posts: 153
Joined: March 8th, 2004, 5:18 am

Post Posted July 4th, 2013, 2:20 am

I continue to have this problem and it won't notify even when using the Save command first. I rely on this. Does anyone know when the bug is going to be fixed?

paulthenoob
 
Posts: 1
Joined: August 19th, 2013, 3:03 pm

Post Posted August 19th, 2013, 3:26 pm

I think I may have found a solution to the problem!!! :) It may not help everyone, but it worked for me after MONTHS of trying to fix this.

Briefly, my lightning was working just fine for years and years. I got the good old "accept/decline" buttons every time. Then, suddenly, they went away on my office pc but not my home pc. No idea why. Searched the boards, and nothing worked to fix the problem (I'm looking at you, everyone who suggested going to Menu, View, select "Display Attachments in Line").

Today, I found a post on these boards from someone who inadvertently tipped me off to the solution to my problem. He used Lightning with networked calendars and deleted his local calendars. When he did so, his accept/reject buttons went away. Creating a new local calendar fixed his problem. So, I went and looked at my calendars. All of my calendars are local, so this should not have been a problem. Still, it seemed to bear further investigation so I double clicked on one of my calendars to see what would happen. A box opened labeled "edit calendar". This is where you choose or change the calendar name, color, location and associated email. I noticed that I did not have an associated email selected (or rather, the option "none" was selected). So I clicked the drop down list button and selected my email address from the drop down list. PRESTO - I was immediately able to see the Accept/Reject buttons!!! HURRAY!!!!

I think I now know why I lost the buttons in the first place. A few months, I changed the login to my email account from an unsecure login to a secure login. I had some initial difficulty setting up the secure login, so I deleted the email account from Thunderbird and started from scratch. Once I had my email account reinstalled, it worked great. It was a few days later that I notice my Accept/Reject buttons had stopped working for calendar invites. I didn't make the connection at the time, but now I see that when I deleted the primary email account that all my calendars were associated with, I lost the ability to accept/reject meeting invites. Why this should be, I have no idea. But it is so.

SO, if you can't get the accept/reject buttons to appear on calendar invites you receive by email, go to your calendar(s) and double click on it. Check the dialogue box to see if your email is associated with the calendar. If "none" is shown, then select your email from the drop down list. I have several calendars, so I associated my email with all of them just to be sure it would work in all cases. Hopefully this solution will work for you too.

Man, I'm so excited I figured this out. What a rush - this has been bugging me for MONTHS!!!

Looking back, I see that SSITTER also suggested this solution as well. I found this independently, but it is the same thing he is saying with perhaps a little more color and detail.

juleshelmel
 
Posts: 1
Joined: March 18th, 2014, 12:56 am

Post Posted March 18th, 2014, 1:03 am

In addition to paulthenoob and SSITTER's solution I found that just refreshing this association email setting works.
I had the same problem with the missing 'Accept' 'Decline' buttons even though I had an associated email address in the calender properties.
I tried setting this to 'none' clicking OK and then changing it back to my email address and this worked! :D

Return to Calendar


Who is online

Users browsing this forum: No registered users and 3 guests

cron