MozillaZine

Incompatible Lightning version

For discussing the Mozilla Calendar, Sunbird and Lightning projects.
Londoner674
 
Posts: 4
Joined: July 20th, 2016, 1:57 am

Post Posted July 20th, 2016, 2:28 am

Hello, this looks like the most relevant thread. If not please advise, I have a serious problem.

I rebooted yesterday for a W10 upgrade. A queued update installed when I next ran Thunderbird, and then my PC locked rock solid, (no Ctrl-Alt-Del and eventually no mouse), requiring a reboot. Initially there was an error message about incompatible Lightning version 4.7 and sight of an unresponsive page to disable Lightning. Since then every time I open Thunderbird it doesn't respond, and the PC ends up locked and needing to reboot, but there's no longer any error message. Now it appears to open normally, if slowly, to the signin but by that time Windows Explorer has stopped and no mouse click anywhere has any effect.. I left it 'Checking mailserver capabilties...' last night and the PC had turned itself off by this morning.

As the error message no longer appears I can't be more specific, nor about the Thunderbird version, whatever has been rolled out most recently I guess, 45.?. I should add that I use the Portable Apps version of Thunderbird (and have for years), but very much doubt that's implicated. I don't use Lightning.

I tried to disable Lightning via ..\thunderbird.exe -safemode, but there's no option.

So, I can't open Thunderbird and have to go through a slow reboot cycle every time I try. Otherwise the PC is fine.
Can anyone tell me how to disable Lightning please.

DanRaisch
Moderator

User avatar
 
Posts: 118035
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 20th, 2016, 4:49 am

Rather than trying to disable Lightning in Mozilla Safe Mode, can you "Remove" that extension while in Safe Mode?

Londoner674
 
Posts: 4
Joined: July 20th, 2016, 1:57 am

Post Posted July 20th, 2016, 7:12 am

All addons are disabled in safemode, there's nothing I can find to even display extensions that would be loaded in normal mode.

DanRaisch
Moderator

User avatar
 
Posts: 118035
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 20th, 2016, 3:23 pm

The extensions are still present and can be removed in Safe Mode, they're just not enabled in Safe Mode. Have you tried menu path Tools->Addons->Extensions while Thunderbird is in Mozilla Safe Mode?

Londoner674
 
Posts: 4
Joined: July 20th, 2016, 1:57 am

Post Posted July 21st, 2016, 12:49 am

Yes I have. I've never run safemode before, so I don't know what should happen, but no extensions at all are listed.

I'd prefer to repair the existing installation if possible but I note that in safemode only some of the mail accounts are shown in both the main display and in the list under Account Settings, and none of the Local Folders are shown. The version is 2.0.0.16(20080708) which makes me very suspicious.

Do you reckon that indicates that the whole installation is broken and beyond repair? If so I may as well give up and revert to a backup or, as my Thunderbird is portable in theory I should be able to paste a new copy over the top of the broken one. I've been reluctant because I'd anticipate Thunderbird will immediately try to update itself and repeat the incompatibility. I'm also wondering if the evidence suggests that the profile is now useless?

I'm very grateful for your assistance.

DanRaisch
Moderator

User avatar
 
Posts: 118035
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 21st, 2016, 4:12 am

Is the Extension pane not displayed when you use menu path Tools->Addons->Extensions?

What version of Thunderbird Portable did you have running before the "queued update installed"? Version 2.0.0.16 was from October of last year and the current version (from the Portable Apps site) is 45.2.0 so perhaps something is borked in your installation.

Londoner674
 
Posts: 4
Joined: July 20th, 2016, 1:57 am

Post Posted July 21st, 2016, 8:26 am

The extensions pane is displayed; it's empty.

The version number and date 2.0.0.16(20080708) are reported by Thunderbird running in safemode, not by the Portable Apps wrapper which dates back years, probably to July 2008 as with the version number. It does it's job and doesn't get updated. (All it really does is keep configuration out of the Registry and adjust a few paths so that everything lives in a self-contained directory structure). Thunderbird updates normally, except this time :(

I've found an old clone on a USB stick which I've upgraded from 38.5.0 -> 45.2.0 and seems to work fine. In safemode it identifies as 45.2.0 and the extensions pane is populated, including with Lightning.

There are a few outdated account details and interface oddments that need attention but mail has synchronised properly. So I think I'll cut my losses, reconfigure by hand and write this down to bad luck.

Thanks again for trying.

DanRaisch
Moderator

User avatar
 
Posts: 118035
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 21st, 2016, 9:50 am

You're welcome, and good luck.

Return to Calendar


Who is online

Users browsing this forum: No registered users and 1 guest