MozillaZine

failed to build... /cygdrive/c???

Talk about Mozilla browsers for small devices such as PDAs and cellphones.
lgw
 
Posts: 2
Joined: May 13th, 2005, 8:25 pm

Post Posted May 16th, 2005, 6:49 pm

Hello all,

I am attempting to build Minimo from source (for the WINCE emulator at this point) on Win32. I have followed the build instructions (http://www.mozilla.org/projects/minimo/WinCE/build.html) as faithfully as possible. The only difference is that I have a previous install of eVC4 at a different path, though I modified setenv_emu_ppc.bat to reflect that.

It is failing on step "I" of the "Steps to Follow Short Form"
call make -f client.mk build_all

My presumptive guess at this point is that it is a pathing problem. The log file suggests the failure occurs on the line #include "confdefs.h". As that is an empty file, I can only conclude that it is not being found.

In the console output of the "call make -f client.mk build_all", there is an echo of "cd /cygdrive/c/builds/wince/mozilla/../emu_ppc"; apparantly an attempt to run from the directory where confdefs.h resides. If one enters that exact command into the Win32 cmd shell, however, it does not work. /cygdrive/c/builds/... doesn't exist - only c:/builds/...

I am not exactly familiar with the "/cygdrive/c/" semantic. Is that causing my problem? And if so, how do I resolve it?

Thanks for your help.

PS: Here are the config.log contents

configure:908: checking host system type
configure:929: checking target system type
configure:947: checking build system type
configure:1075: checking for host c compiler
configure:1081: checking for gcc
configure:1116: checking for host c++ compiler
configure:1122: checking for c++
configure:1171: checking for ranlib
configure:1206: checking for ar
configure:1241: checking whether the host c compiler (gcc ) works
configure:1250: gcc -c conftest.c 1>&5
configure:1265: checking whether the host c++ compiler (c++ ) works
configure:1274: c++ -c conftest.c 1>&5
configure:1294: checking for arm-wince-gcc
configure:1328: checking for gcc
configure:1441: checking whether the C compiler (arm-wince-gcc ) works
configure:1457: arm-wince-gcc -o conftest conftest.c 1>&5
cl.exe /I"c:/Program Files/Windows CE Tools/wce420/Pocket PC 2003/Include/Emulator/" /I"c:/builds/wince/mozilla/build/wince/shunt/include/" /FI"mozce_shunt.h" /D_i386_ /D_X86_ /Dx86 /D_WIN32_WCE=310 /DWIN32_PLATFORM_PSPC=310 /DUNDER_CE=310 /DWINCE /DDEPRECATE_SUPPORTED /F5000000 -o conftest conftest.c /link -STACK:0x5000000,1000000 -ENTRY:mainACRTStartup -SUBSYSTEM:WINDOWSCE -MACHINE:X86 \"-LIBPATH:"c:/Program Files/Windows CE Tools/wce420/Pocket PC 2003/Lib/Emulator/"\" \"-LIBPATH:"c:/builds/wince/mozilla/build/wince/shunt/build/emulatorRel/\" shunt.lib winsock.lib corelibc.lib coredll.lib
-----------------> 2 <----------------------



Signal 127
configure: failed program was:

#line 1452 "configure"
#include "confdefs.h"

main(){return(0);}

lgw
 
Posts: 2
Joined: May 13th, 2005, 8:25 pm

Post Posted May 16th, 2005, 8:41 pm

self-reply:
After experimenting with cygwin, I discovered that within the cygwin shell, /cygwin/c/ maps to the NTFS C:\. Forgive me if that was common knowledge...

Still get the error on make, though, and could use some advice.

Return to Mobile


Who is online

Users browsing this forum: No registered users and 1 guest