MozillaZine

Firefox address too impatient when removing address.

Talk about Mozilla browsers for small devices such as PDAs and cellphones.
wakanasakai
 
Posts: 75
Joined: May 21st, 2012, 2:48 pm

Post Posted September 28th, 2016, 8:25 am

Just so you know, I tried searching the forums first (in case this was already asked & solved), but found nothing. (Btw, how do you make the search feature return on topic names as result?)

Anyway, I've noticed for at least the past few (if not earlier) versions that when I have a really long address (EXAMPLE = http://images.google.com/imgres?imgurl= ... wEg&uact=8), if I want to trim it so that all that is left is the address that it SHOULD go to (because sometimes it tries to redirect AWAY from it instead), if I place the cursor at the end of the long address (WITHOUT "selecting" anything) & then hold the backspace key for 2 or more seconds (approximately), it super instantaneously deletes ALL of the address. I can avoid that by using the backspace key for 1 second presses, but that takes forever. Is there any "about:config" setting that I can change to make this "feature" take longer (perhaps 10 seconds) or disable it completely? Thanks.

JayhawksRock

User avatar
 
Posts: 10433
Joined: October 24th, 2010, 8:51 am

Post Posted September 28th, 2016, 8:53 am

Check about:config pref > browser.urlbar.trimURLs
"The trouble with quotes on the internet is you never know if they are genuine" ...Abraham Lincoln

LIMPET235
Moderator

User avatar
 
Posts: 38230
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted September 28th, 2016, 8:58 am

wakanasakai wrote...
(Btw, how do you make the search feature return on topic names as result?)

Have you tried using the "Advanced" option/link over there? ------------------------------------------->>>
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. (Always choose the "Custom" Install.)

billko
 
Posts: 281
Joined: September 30th, 2009, 9:24 pm

Post Posted September 28th, 2016, 11:58 am

Maybe something is causing keyboard input to be buffered, and when that something is gone, all the backspaces happen all at once? Maybe something like antivirus is monitoring keystrokes in the url bar and getting in the way of your repeated backspaces?

wakanasakai
 
Posts: 75
Joined: May 21st, 2012, 2:48 pm

Post Posted September 28th, 2016, 3:44 pm

I already had "browser.urlbar.trimURLs" set to false, but I know exactly what effect both settings for that have, so I know that that's not it. Actually, I now think that firefox may not be the cause of this problem, although I still think that some about:config setting could help. Tomorrow, I'll search inside about:config for search terms like "_ms", "delay", & "urlbar", & see what the internet can tell me about them.

Anyway, the problem seems mostly (if not completely) to be my new(ish) phone's fault. My phone that I was using before about 5 days ago was a Motorola E (1 core, 1 Ghz processor & GOOGLE keyboard), with which I rarely had this problem, despite using holding down the backspace key for MUCH longer than 2 seconds (depending on the length of the address that I would be back-spacing). My NEW phone is a Samsung galaxy amp prime (4 cores, 1.3 Ghz processor & SAMSUNG keyboard). I suspect that the processor's speed or the keyboard's behavior (or both) are the biggest cause of my problem. Tomorrow, I'll start checking out NON-samsung keyboards at google play store.

If anybody can think of any about:config settings that can help, I'll test those too. Thanks.

DanRaisch
Moderator

User avatar
 
Posts: 119430
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted September 28th, 2016, 5:59 pm

Since you are using Firefox on an Android phone, I'll move this to the Mobile forum.

kreemoweet
 
Posts: 727
Joined: December 30th, 2009, 11:25 pm

Post Posted September 29th, 2016, 9:36 am

When you hold a key down, then most OS's have an "autorepeat" setting that kicks in. In other words, it is not a Firefox thing, it's a Keyboard Settings thing in your Operating System.

wakanasakai
 
Posts: 75
Joined: May 21st, 2012, 2:48 pm

Post Posted September 30th, 2016, 8:23 am

After switching to google's android keyboard, the problem (even using the example link in the first post) is now fixed, so if anybody else ever has this problem, I recommend trying this solution first. However, I STILL suspect that there is an about:config setting(s) that could also help (read = I still suspect that samsung's keyboard is not the ONLY culprit), so I'll continue to investigate some about:config settings anyway. If nothing else, it an opportunity to learn more about those settings.

Anyway, I'll consider my problem to be solved.

billko
 
Posts: 281
Joined: September 30th, 2009, 9:24 pm

Post Posted September 30th, 2016, 8:57 am

wakanasakai wrote:After switching to google's android keyboard, the problem (even using the example link in the first post) is now fixed, so if anybody else ever has this problem, I recommend trying this solution first. However, I STILL suspect that there is an about:config setting(s) that could also help (read = I still suspect that samsung's keyboard is not the ONLY culprit), so I'll continue to investigate some about:config settings anyway. If nothing else, it an opportunity to learn more about those settings.

Anyway, I'll consider my problem to be solved.


Actually, I'm willing to wager that the keyboard WAS the only culprit. The Samsung keyboard probably handles key repeats in an unexpected way. It could be something as subtle as a combination of keyboard repeat being quicker with the Samsung keyboard plus an unoptimized keyboard read by FF combined to temporarily jam up the input buffer.

Return to Mobile


Who is online

Users browsing this forum: No registered users and 1 guest