MozillaZine


[Ext] OpenDownload² 4.2.0

Announce and Discuss the Latest Theme and Extension Releases.
Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted July 11th, 2010, 12:04 pm

Tuxman wrote:I haven't figured out how to access the OD service with the new interface yet, so it may take a while...
(Or could anyone help, cough?)

Err foo.getService() should still work. The only things that changed is how your component is registered. Once it's registered it should behave in the same way.

Phil

Tuxman
 
Posts: 645
Joined: August 23rd, 2004, 11:53 am

Post Posted July 11th, 2010, 12:10 pm

OK, so I failed. I basically followed the instructions here but still something seems to be missing. Geez, those API changes.

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted July 11th, 2010, 1:16 pm

Tuxman wrote:OK, so I failed. I basically followed the instructions here but still something seems to be missing. Geez, those API changes.

Did you add the registration lines to your chrome.manifest file? Let's discuss this over in the Extension Development forum.

Phi

Tuxman
 
Posts: 645
Joined: August 23rd, 2004, 11:53 am

Post Posted July 11th, 2010, 1:30 pm

Hmm, current "temporary" build is at deleted .. I actually added the components including their contract there.
Last edited by Tuxman on November 19th, 2013, 6:04 pm, edited 1 time in total.

Tuxman
 
Posts: 645
Joined: August 23rd, 2004, 11:53 am

Post Posted July 27th, 2010, 2:34 pm

Just wanted to let you know that the build posted above is fully compatible with Fx4 beta 2. I just had a chance to test it.
Now it'll need Fx3 and SeaMonkey compatibility, and I'm done. Yay.

ExK4
 
Posts: 1
Joined: July 30th, 2010, 4:59 pm

Post Posted July 30th, 2010, 5:06 pm

When I try running Firefox 4.0b2 OpenDownload (any version), I get an error message (see below). After clicking OK, OpenDownload and Firefox still function normally. It does work fine in 4.0b1, though. Just a heads up, but if you could fix this, it would be much appreciated.
(Never mind, 3.0 fixes this)
Image

Tuxman
 
Posts: 645
Joined: August 23rd, 2004, 11:53 am

Post Posted July 30th, 2010, 5:18 pm

Yep, 2.x is not intended to work with the new XPCOM stuff yet.
(While SM/Fx3 support in v3 can take a bit longer than I thought, something's wrecked there...)

IQCrashed
 
Posts: 1
Joined: August 12th, 2010, 5:13 pm

Post Posted August 12th, 2010, 5:49 pm

I thought I was losing my mind and I am anyway but I've been using this add on and have been perplexed as to it's behavior. Tux, I'm Sorry but I'm with Abe on this.

The software offers the boxes named "use default Win32 App" and "Do this automatically" all while the same software that offers them has no intention of obeying them. If security is truly the issue then run a virus scan for me. At least that might have a chance of finding the infection but just to ask me each and every time if I want to use the Win32 application and CALLING that somehow magically secure seems more than anything to be a false sense of security if anything at all.

It is absolutely no safer, because I do not know any more about the target just because the open process asked me a redudant question. Which I guess is the conclusion I draw fromt his thread. The process is no more secure and the user is in no way safer, it is more like it simply offends your sense or propriety.

Tuxman
 
Posts: 645
Joined: August 23rd, 2004, 11:53 am

Post Posted August 12th, 2010, 5:58 pm

I'd call it a rather ethical issue. My way of thinking: If the user double-clicks a malicious .exe file, it is his fault. If the user accidentally opened it because OD made the choice window disappear, it would (ethically) be my fault. So ...

Even if you wouldn't blame me, I would.

Tuxman
 
Posts: 645
Joined: August 23rd, 2004, 11:53 am

Post Posted August 23rd, 2010, 4:37 pm

For whoever might be interested:
I have just uploaded the (hopefully) last OD² preview build, replacing the old ones.

Successfully tested in Firefox 3.6.8 and 4.0 beta 2.
However, for some weird reason my SeaMonkey installation doesn't like it. Could be me indeed.

So I am about to finish work on this version during the following days. Anyone who wants to test it is invited. 8-)
(Like, if (and why) SeaMonkey support is broken for him, too. :? )
Last edited by Tuxman on November 19th, 2013, 6:05 pm, edited 1 time in total.

kostelo
 
Posts: 8
Joined: January 21st, 2007, 10:58 am

Post Posted September 3rd, 2010, 9:56 am

Just wanted to say thank you so much for making this excellent addon compatible with Fx 4 beta. I ve tested it with the latest beta 4 and works flawlessly. In my opinion this option should be integrated in Fx just like it is in iexplorer. Thanks again.

Tuxman
 
Posts: 645
Joined: August 23rd, 2004, 11:53 am

Post Posted September 3rd, 2010, 10:08 am

Great to know that anyone is still using it. :)
Thank you for the kind words...

Tuxman
 
Posts: 645
Joined: August 23rd, 2004, 11:53 am

Post Posted September 5th, 2010, 12:17 pm

J4I, SeaMonkey 2.1a doesn't work with it either (yet) ... :)

markdc
 
Posts: 3
Joined: September 16th, 2010, 6:20 pm

Post Posted September 16th, 2010, 6:23 pm

I just updated Firefox to version 3.6.10 and unfortunately the extension stopped working :( It is weird how it would work with 4.0 but not this version. Any updates on this Tuxman? Thanks a lot!

Tuxman
 
Posts: 645
Joined: August 23rd, 2004, 11:53 am

Post Posted September 16th, 2010, 6:27 pm

I'm still on 3.6.9 (waiting for a SSE2 .10 build), so, actually, I haven't even tried it yet.
Any hints in the error console?

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 3 guests