MozillaZine

[Ext] ImageShowHide 0.2.8.1 - simply turn on|off images

Announce and Discuss the Latest Theme and Extension Releases.
M_Lyons10
 
Posts: 220
Joined: November 4th, 2004, 4:37 pm

Post Posted December 30th, 2005, 4:46 pm

Hi, is version 0.1.7 compatable with Firefox 1.5? I have Firefox 1.5 and since upgrading, when I click the Image-Show-Hide button nothing happents. The button doesn't even change to the blocked images icon. Any help would be greatly appreciated, as I love this extension.

Thanks.
-Matt-

M_Lyons10
 
Posts: 220
Joined: November 4th, 2004, 4:37 pm

Post Posted January 7th, 2006, 8:37 pm

Um, is anyone else having this problem?

Mikki

User avatar
 
Posts: 81
Joined: July 14th, 2004, 11:27 pm
Location: Russia, Miass

Post Posted January 8th, 2006, 7:30 am

If the latest version doesn't work for you...

by Pastor, January 07, 2006 10:54am

...then close Firefox, go to your profile folder, find prefs.js - it's your browser settings. Open it in text editor and find the following strings: user_pref("imgsh.rldef", 1); user_pref("imgsh.rldyn", 0); user_pref("permissions.default.image", 0); (actual values may vary). Now delete them, save and close the file. Start FF and tune Image-Show-Hide anew. That's all, now it's working. P.S. In FF 1.5 internal values which were respondant for image politics were changed. So old and new version of the extension are totally incompatible. It's not needed to uninstall old version, all you need is simply delete old settings, new version will recreate its own.

M_Lyons10
 
Posts: 220
Joined: November 4th, 2004, 4:37 pm

Post Posted January 8th, 2006, 12:04 pm

Mikki wrote:If the latest version doesn't work for you...

by Pastor, January 07, 2006 10:54am

...then close Firefox, go to your profile folder, find prefs.js - it's your browser settings. Open it in text editor and find the following strings: user_pref("imgsh.rldef", 1); user_pref("imgsh.rldyn", 0); user_pref("permissions.default.image", 0); (actual values may vary). Now delete them, save and close the file. Start FF and tune Image-Show-Hide anew. That's all, now it's working. P.S. In FF 1.5 internal values which were respondant for image politics were changed. So old and new version of the extension are totally incompatible. It's not needed to uninstall old version, all you need is simply delete old settings, new version will recreate its own.


Hi and thanks for your response. I went into the prefs.js file and deleted the strings you had instructed me to and then reopened Firefox. Unfortunately, the extension still doesn't work. When I click on the toolbar button, nothing happens. I reopened the prefs.js file and those strings had been replaced with what appears to be the same strings. I just don't get it. After updating to Firefox 1.5 (I did an update, then a complete reinstall), I've had two extensions that don't work properly that seem to be working for others. This one, which does nothing, and the All-In-One Search Button, which only sporaticaly works... Do you or anyone else have any other ideas? I really like this extension and would love to have it working again.

Thanks Again,
-Matt-

M_Lyons10
 
Posts: 220
Joined: November 4th, 2004, 4:37 pm

Post Posted January 8th, 2006, 12:09 pm

Oh wait, now it's working. Huh, that's odd. Oh well, I'm just thrilled to have this working. Will a fix similar to this fix the issues I'm having with All-In-One Search?

Thanks Again,
-Matt-

christom
 
Posts: 1
Joined: January 14th, 2006, 11:16 pm

Post Posted January 14th, 2006, 11:46 pm

Pastor's advice worked for me - i.e. deleting the references to imgsh and permissions.default in prefs.js. I believe that the problem may be precipitated by the automatic search and install for new/valid extensions that firefox automatically does when upgraded. This can destroy the opportunity one has to un-install older versions before installing the new one, rsulting in a broken upgrade. One wonders what percentage of users had the difficulty...
Thanks Parson, christom
PS: My Windows machine has more than one "prefs.js" file, in different locations - a user needs to check that he really is changing the file in the appropriate firefox prefs.js. In my case it was the one in the "C:\Documents and Settings\MyName\Application Data\Mozilla\Firefox\Profiles\acbcefg.default\" folder

ul
 
Posts: 46
Joined: May 14th, 2005, 5:24 am

Post Posted March 12th, 2006, 10:17 am

Mikki,

Am impressed with the small size of this extension. Only 13K, compared to 86K for imglikeopera. (Though imagepref is smallest at 3K.)

Any chance you could add a ColorsShowHide option? (to disable page colors, makes it faster on dialup) In the code, all you would have to do is turn "browser.display.use_document_colors" on/off.

Mikki

User avatar
 
Posts: 81
Joined: July 14th, 2004, 11:27 pm
Location: Russia, Miass

Post Posted March 20th, 2006, 2:12 am

therube wrote:Hmm. How to install with Mozilla 1.72?

When I drop it onto Mozilla, it reports, "Install script not found".
I assume there should be an install.js file in the archive?


Only for FireFox 1.5!

Neff
 
Posts: 77
Joined: September 16th, 2004, 9:41 am

Post Posted April 13th, 2006, 1:02 am

Ever since I started using this extension I found that it doesn't work if the search/find toolbar is displayed. When the image-show-hide toolbar button is clicked it does nothing.

Is there any work around for this?

Shoog
 
Posts: 1
Joined: July 4th, 2006, 9:42 am

Post Posted July 5th, 2006, 1:57 am

I also noticed that occasionally, this extension would stop working. Just checked the code and worked out that it was caused by the Find toolbar, as Neff describes.

The imgsh_switchmg function in function.js, is checking if the find toolbar is hidden, before showing or hiding images. Not sure why.

grofaty
 
Posts: 15
Joined: August 7th, 2006, 10:17 pm

Post Posted October 22nd, 2006, 10:36 pm

Hi,
I love this extension. But I have one wish. Can you make posible to enable any other shortcut then Shift-Z. Because this setting is not compatible by Firefox functionality in menu Tools | Options | Advanced tab | General tab | Accessibility frame | "Begin finding when you begin typing" option.

The best option would be to make it posible end user can manualy select keyboard shortcut.

Thanks a lot,
Grofaty

dewey1973
 
Posts: 10
Joined: March 19th, 2005, 10:18 am

Post Posted October 31st, 2006, 3:55 pm

Please fix your icon as it makes the tool bar bigger.

Felipe1982

User avatar
 
Posts: 68
Joined: November 27th, 2005, 7:40 pm

Post Posted November 15th, 2006, 3:49 pm

My name is felipe and I love your show/hide image extension you made! Very handy tool.

I'm running FX 2.0 in windows xp and have installed the latest version of your extension. In fx preferences, i have added a few "allow/block" exceptions to the "load images automatically" sections like google.com-allow, doubleclick.net-block and some others (about 5 allow and 5 block, 10 total)

When I press the image for the extension you provided on the toolbar, it turns into a no-smoking sign (images are turned off) wonderful. When I click it, the button turns into a yellow square. Image are on, perfect! BUT when i click it again, it stays as a yellow square and images remain ON, they won't turn off. Going into tools > options > content, the "load images automatically" is turned OFF but firefox still shows IMAGES!!! (in all webpages, not just the ones with "allow" permissions). I put the image on the very right of the search tool (to the right of the magnifying glass icon)

To remedy this, I go to tools > options > content and turn "load image automatically" to ON, then > close. Then press the yellow square icon and it turns to a no-smoking sign and images are off. But the problem doesn't go away when I want to turn images ON then OFF again.

I have reproduced this problem 5 times. Is this a bug?

Felipe1982

User avatar
 
Posts: 68
Joined: November 27th, 2005, 7:40 pm

Post Posted November 15th, 2006, 4:01 pm

found the problem! "permissions.default.image" is set to default value "1" - load all images
2 is block all images
3 show only images from originating site (or prevent 3rd party images from loading)

This extension changes the above from "1" to "2", but then back to "0" which is an invalid value.

http://kb.mozillazine.org/Permissions.default.image

tlu

User avatar
 
Posts: 49
Joined: November 13th, 2005, 9:58 am

Post Posted November 29th, 2006, 7:25 am

Felipe1982 wrote:found the problem! "permissions.default.image" is set to default value "1" - load all images
2 is block all images
3 show only images from originating site (or prevent 3rd party images from loading)

This extension changes the above from "1" to "2", but then back to "0" which is an invalid value.

http://kb.mozillazine.org/Permissions.default.image

I have set "permissions.default.image" to "3" in order to block web-bugs because of privacy considerations, and the extension changes this value to "2" and back to "3" . But it would be great if the author added a possibility to change the value from "3" to "1" and back, so web-bugs are blocked by default but can be allowed for specific sites.

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 4 guests