MozillaZine

DragIt 3.2.1 [2013.07.04]

Announce and Discuss the Latest Theme and Extension Releases.
Dr.S.
 
Posts: 162
Joined: March 30th, 2009, 7:12 am

Post Posted March 19th, 2013, 10:34 am

giovannibgr wrote:I'm having an issue with composing mails in GMail - if I try to reorder words by drag and drop, DragIt takes over and gestures are triggered on the text I'm dragging. I don't know how exactly google have implemented this text area, but it surely does not behave correct - it I try the same thing in this compose text area, DragIt does not interfere at all. Sorry if this has already been reported, but mozillazine lacks thread search and I could not read through 26 pages...

So, a few suggestions/feature requests related to the above:
  • sometimes it IS useful to be able to use DragIt on text in input fields. Can this be made optional? Or by toggle shortcut (see next one)?
  • for various situations, it is useful to be able to bypass temporarily the gestures. There are extensions which have keyboard shortcut that toggles the gesture detection on/off, other use keyboard modifier (Alt/Ctrl/Shift) to do that. Both approaches have pros and cons, either of them would be very nice to have
  • finally, another extension (I really don't remember which), has the option to turn off its functionality on certain websites, exactly due to incompatibility caused by the site. Is it too difficult to add this one too?
[/list]
Thanks in advance for your reply! :)


Sorry for the late answer!

I followed your description and reproduced the behaviour. But I don't yet have a fix for it.

I like your idea of using a modifier key to temporarily disable the gesture detection. The next release will contain such a feature.

By the way, you can already combine gestures with ctrl/alt modifiers:
  • Open DragIt's preference dialog.
  • Open the 'Gesture' panel.
  • Press the column picker.
  • Activate 'ctrl-Action' or 'alt-Action'.
  • Assign a gesture.

brijazz
 
Posts: 7
Joined: October 4th, 2011, 4:29 am

Post Posted April 3rd, 2013, 8:31 am

brijazz wrote:I believe I've found a bug related to Private Browsing. I have DragIt set up so that dragging an image saves it. However, when I do a drag-to-save on an image in Private Browsing, that image's filename appears in History after I've *exited* Private Browsing. To duplicate:

1) enter Private
2) drag-and-save any image
3) exit Private
4) look in History... you'll see the name of the image you saved

Running DragIt 3.0.1 under FF 19.0.2


Is anyone else experiencing this? If someone could even check it out, I'd appreciate it, if only to verify that I'm not the only one with this problem. I feel that there's privacy at stake here, so it would be great to find out more about this.

giovannibgr
 
Posts: 4
Joined: March 6th, 2013, 3:14 am

Post Posted April 4th, 2013, 12:11 am

Dr.S. wrote:By the way, you can already combine gestures with ctrl/alt modifiers:
  • Open DragIt's preference dialog.
  • Open the 'Gesture' panel.
  • Press the column picker.
  • Activate 'ctrl-Action' or 'alt-Action'.
  • Assign a gesture.


Thank you for the answer!

I had already noticed the above - at first I thought that setting Ctrl/Alt action to Disabled/Do nothing would do the job and would allow me to drag text in GMail's textbox, but it didn't. Both the default "Do nothing" setting and "Disabled" prevent DragIt from performing an action, but DragIt still captures the drag (e.g. the blue mouse track is shown) and does not propagate it to the textbox itself, so I cannot rearrange words this way.

BTW, what is the difference betweent the two "actions" above?

3 and 20
 
Posts: 1
Joined: April 17th, 2013, 2:28 pm

Post Posted April 17th, 2013, 2:35 pm

There's a bug that's been bugging me for ages with this. Sometimes, when you start up Firefox there's all kinds of weird things that go on. If you use Firefox's search bar, or type a search term into a search box on a website, like google or a forum, then the "Settings" dialogue opens up, too. If you hit tab, then the settings dialogue will open up and your cursor won't move to the next box on the screen. If you hit CTRL and anything, then the settings dialogue will open up and whatever function the keystrokes you made were supposed to make happen doesn't happen. It also loses all functionality, so clicking on a link and dragging it upwards just opens the link in the current tab, rather than in a background tab.

There seems to be little rhyme or reason to why it does this, but it's fairly often. Maybe 1 time out of three starting up Firefox. If there are two windows being opened simultaneously, like loading up an old session, then maybe it'll work on one window but not the other. However, if you open a new window using CTRL-N, then that new window will always work.

It doesn't appear to be a clash with any other add-on, as the same thing happens with all other add-ons disabled.

giovannibgr
 
Posts: 4
Joined: March 6th, 2013, 3:14 am

Post Posted April 22nd, 2013, 12:26 am

3 and 20 wrote:There's a bug that's been bugging me for ages with this. Sometimes, when you start up Firefox there's all kinds of weird things that go on. If you use Firefox's search bar, or type a search term into a search box on a website, like google or a forum, then the "Settings" dialogue opens up, too. If you hit tab, then the settings dialogue will open up and your cursor won't move to the next box on the screen. If you hit CTRL and anything, then the settings dialogue will open up and whatever function the keystrokes you made were supposed to make happen doesn't happen. It also loses all functionality, so clicking on a link and dragging it upwards just opens the link in the current tab, rather than in a background tab.

There seems to be little rhyme or reason to why it does this, but it's fairly often. Maybe 1 time out of three starting up Firefox. If there are two windows being opened simultaneously, like loading up an old session, then maybe it'll work on one window but not the other. However, if you open a new window using CTRL-N, then that new window will always work.

It doesn't appear to be a clash with any other add-on, as the same thing happens with all other add-ons disabled.


I've had this issue too, twice. It's not so often for me as in your case, but it's surely annoying. Unfortunately, I haven't found a way to reproduce this on purpose, that's why I hadn't reported it yet.

Dr.S.
 
Posts: 162
Joined: March 30th, 2009, 7:12 am

Post Posted May 30th, 2013, 10:31 am

Update 3.1 released.
See Post #1 for further information,

brijazz
 
Posts: 7
Joined: October 4th, 2011, 4:29 am

Post Posted May 30th, 2013, 2:49 pm

Dr.S. wrote:
brijazz wrote:I believe I've found a bug related to Private Browsing. I have DragIt set up so that dragging an image saves it. However, when I do a drag-to-save on an image in Private Browsing, that image's filename appears in History after I've *exited* Private Browsing. To duplicate:

1) enter Private
2) drag-and-save any image
3) exit Private
4) look in History... you'll see the name of the image you saved

Running DragIt 3.0.1 under FF 19.0.2


I've reproduced it. A fix is on the way.


Any ETA on the fix? I've just installed 3.1 and am still seeing this behavior.

Dr.S.
 
Posts: 162
Joined: March 30th, 2009, 7:12 am

Post Posted June 13th, 2013, 10:31 am

brijazz wrote:
Dr.S. wrote:
brijazz wrote:I believe I've found a bug related to Private Browsing. I have DragIt set up so that dragging an image saves it. However, when I do a drag-to-save on an image in Private Browsing, that image's filename appears in History after I've *exited* Private Browsing. To duplicate:

1) enter Private
2) drag-and-save any image
3) exit Private
4) look in History... you'll see the name of the image you saved

Running DragIt 3.0.1 under FF 19.0.2


I've reproduced it. A fix is on the way.


Any ETA on the fix? I've just installed 3.1 and am still seeing this behavior.


Please give Version 3.2 a try.

Dr.S.
 
Posts: 162
Joined: March 30th, 2009, 7:12 am

Post Posted June 13th, 2013, 10:32 am

Update 3.2 released.
See Post #1 for further information.

brijazz
 
Posts: 7
Joined: October 4th, 2011, 4:29 am

Post Posted June 13th, 2013, 10:40 am

Dr.S. wrote:Please give Version 3.2 a try.


I'd love to try 3.2, but it doesn't seem to be compatible with FF 19. I don't really want to "upgrade" to FF 20 due to the weird implementation of private browsing. Oh well, thanks for taking a look at the bug nonetheless.

Dr.S.
 
Posts: 162
Joined: March 30th, 2009, 7:12 am

Post Posted June 13th, 2013, 10:57 am

brijazz wrote:
Dr.S. wrote:Please give Version 3.2 a try.


I'd love to try 3.2, but it doesn't seem to be compatible with FF 19. I don't really want to "upgrade" to FF 20 due to the weird implementation of private browsing. Oh well, thanks for taking a look at the bug nonetheless.


You are welcome! Please let me know if the bug is fixed after upgrading to Firefox 20+.

Spown
 
Posts: 6
Joined: March 31st, 2012, 4:15 pm

Post Posted June 24th, 2013, 11:12 am

After suffering for weeks from the constantly popping up settings screen I found ver 3.2... settings won't pop (thank you), but text dragging - the most useful feature, has vanished too. FF21, even installing dragit on a clean profile doesn't do a thing.

Spown
 
Posts: 6
Joined: March 31st, 2012, 4:15 pm

Post Posted June 25th, 2013, 9:27 pm

Spown wrote:After suffering for weeks from the constantly popping up settings screen I found ver 3.2... settings won't pop (thank you), but text dragging - the most useful feature, has vanished too. FF21, even installing dragit on a clean profile doesn't do a thing.

Chrome error:
this.m_Source.localName is null
error source line:
Filtered chrome url chrome://dragit/content/dnd/Target.js:146

DragIt
 
Posts: 7
Joined: February 4th, 2013, 12:54 pm

Post Posted June 27th, 2013, 3:35 am

DragIt 3.2, bug!
images in an external application don't open
You look at video in more detail: http://youtu.be/KeodBywWayQ

DragIt
 
Posts: 7
Joined: February 4th, 2013, 12:54 pm

Post Posted June 28th, 2013, 12:33 pm

Please fix: images in an external application don't open

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 4 guests