MozillaZine

[Ext] InfoLister [old 2004-2010 thread]

Announce and Discuss the Latest Theme and Extension Releases.
Peng

User avatar
 
Posts: 778
Joined: November 9th, 2004, 2:31 pm
Location: Central Florida

Post Posted February 21st, 2006, 2:32 pm

gemal wrote:It would be really nice if it was possible to list what updateURLs each extension had. Extensions that dont have an UpdateURL uses addons.mozilla.org which isn't up to date all the times. This way I could check my extension list for extensions that I want to go to their real homepage to check for updates for.


It looks like the InfoLister XML files contain the updateURLs.

Damn. Now I need to get back to work on that PHP script to interpret it and output it differently. PHP+XML is icky.
Hug Peng
(aka Matt Nordhoff)
Check out: Adblock Plus | FoxClocks | OpenBook

asqueella
 
Posts: 4019
Joined: November 16th, 2003, 3:05 am
Location: Russia, Moscow

Post Posted February 22nd, 2006, 6:38 pm

You can make a template or just use the XPI links one. If InfoLister fails to find an xpi link for an extension, it's very likely that the extension won't get auto-updated either. Similarly, if an extension's XPI is at *.mozilla.org, it most probably doesn't have a custom updateURL.

Peng

User avatar
 
Posts: 778
Joined: November 9th, 2004, 2:31 pm
Location: Central Florida

Post Posted February 22nd, 2006, 10:32 pm

I had completely missed that custom templates were still possible. Hmm.

Edit: Nah, I don't think I'll bother with one.
Hug Peng
(aka Matt Nordhoff)
Check out: Adblock Plus | FoxClocks | OpenBook

Peng

User avatar
 
Posts: 778
Joined: November 9th, 2004, 2:31 pm
Location: Central Florida

Post Posted May 21st, 2006, 10:45 pm

0.9e is putting "startup" and "quit" in the console (as in, bash shell where I start Firefox from, not the JavaScript/Error Console) whenever I start up and quit Firefox.

Edit: Also, you should increase the Thunderbird maxVersion to at least 2.0a1. It works fine for me.
Hug Peng
(aka Matt Nordhoff)
Check out: Adblock Plus | FoxClocks | OpenBook

asqueella
 
Posts: 4019
Joined: November 16th, 2003, 3:05 am
Location: Russia, Moscow

Post Posted May 24th, 2006, 2:05 pm

Ooops. An extra component got packaged into the XPI accidentally. You can delete test.js from extensions/{infolister uuid}/components/ to get rid of that.

Okay I can bump the maxVersion since it works for you. I didn't get a chance to tell that myself.

BTW, I didn't announce it here, 0.9e is the new version which shouldn't have any changes [that I remember of anyway] except for a few new locales (thanks to folks on babelzilla).

Peng

User avatar
 
Posts: 778
Joined: November 9th, 2004, 2:31 pm
Location: Central Florida

Post Posted May 24th, 2006, 3:43 pm

test.js? Heh. I won't bother to delete it. It's not a big problem, I just wanted to report it so it would be fixed in 0.9f or whatever. :)
Hug Peng
(aka Matt Nordhoff)
Check out: Adblock Plus | FoxClocks | OpenBook

mfenech
 
Posts: 89
Joined: November 20th, 2004, 5:51 am
Location: Texas

Post Posted July 13th, 2006, 9:36 am

Will there be an update to work with FF 2.0b anytime soon?

Peng

User avatar
 
Posts: 778
Joined: November 9th, 2004, 2:31 pm
Location: Central Florida

Post Posted July 13th, 2006, 1:42 pm

I have an InfoLister 0.9e XPI with maxVersions of 3.0a1 for Firefox and Thunderbird and that has that test.js file removed if anyone wants it: infolister-0.9e-notestjs-mv30a1.xpi
Last edited by Peng on July 14th, 2006, 3:03 pm, edited 2 times in total.
Hug Peng
(aka Matt Nordhoff)
Check out: Adblock Plus | FoxClocks | OpenBook

mfenech
 
Posts: 89
Joined: November 20th, 2004, 5:51 am
Location: Texas

Post Posted July 13th, 2006, 4:09 pm

That worked. Thanks, Peng.

asqueella
 
Posts: 4019
Joined: November 16th, 2003, 3:05 am
Location: Russia, Moscow

Post Posted July 16th, 2006, 8:22 am

I updated the version on the site and the update manifest. I haven't tested anything, so please tell me if the upgrade process / min/maxVersion bump worked for you.

Rymann

User avatar
 
Posts: 303
Joined: May 12th, 2004, 4:53 pm
Location: Portland, Oregon

Post Posted August 9th, 2006, 10:11 pm

Sorry, a rather simplistic question, but I can't figure it out. When I upload my extensions lists the CSS works fine. When I type about:info in the address bar, the CSS is not being used. Where does my CSS template need to be, what folder? I tried the chrome folder of my profile and a couple other places and nothing. I know this worked for previous versions.

Thanks for your help.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 [extensions]

0nslaught
 
Posts: 80
Joined: December 2nd, 2004, 1:24 pm

Post Posted August 19th, 2006, 7:28 pm

Peng wrote:I have an InfoLister 0.9e XPI with maxVersions of 3.0a1 for Firefox and Thunderbird and that has that test.js file removed if anyone wants it: infolister-0.9e-notestjs-mv30a1.xpi


Does it list which extensions you have disabled?

In the recent builds of Bon Echo, it lists all of my extensions as enabled, even though a few are disabled.

"Extensions (enabled: 29, disabled: 0):"

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060819 BonEcho/2.0b2

Old kmc
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted August 29th, 2006, 6:19 am

asqueella wrote:BTW, I didn't announce it here, 0.9e is the new version which shouldn't have any changes [that I remember of anyway] except for a few new locales (thanks to folks on babelzilla).


It seems that the zh-cn locale is not fully adapted, as there are only "Xml" and "Xml+xslt" in the drop down menu of output formats, maybe it's not been well localized ?

I've switched back to 0.9c eng version and all works alright.

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted August 31st, 2006, 3:01 am

Wahoo! I have modified InfoLister to work in SuiteRunner 1.5a:

My Information

Last updated: Thu, 31 Aug 2006 09:40:23 GMT
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060825 / SeaMonkey/1.5a

Extensions (enabled: 7, disabled: 0; total: 7)

Themes (2)
  • SeaMonkey Classic (default) [selected]
  • SeaMonkey Modern

Plugins
  • Adobe Acrobat
  • Java(TM) 2 Platform Standard Edition 5.0 Update 3
  • Microsoft® DRM
  • Mozilla Default Plug-in
  • OpenOffice.org Plug-in
  • QuickTime Plug-in 7.1
  • RealPlayer Version Plugin
  • RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit)
  • VLC multimedia plugin
  • Windows Media Player Plug-in Dynamic Link Library


Screenshot:

Image

Phil

snapbrowse

User avatar
 
Posts: 90
Joined: May 23rd, 2005, 4:38 am
Location: Europe

Post Posted September 21st, 2006, 9:26 am

0nslaught wrote:
Peng wrote:I have an InfoLister 0.9e XPI with maxVersions of 3.0a1 for Firefox and Thunderbird and that has that test.js file removed if anyone wants it: infolister-0.9e-notestjs-mv30a1.xpi


Does it list which extensions you have disabled?

In the recent builds of Bon Echo, it lists all of my extensions as enabled, even though a few are disabled.

"Extensions (enabled: 29, disabled: 0):"

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060819 BonEcho/2.0b2


I can confirm this on Linux 1.8 branch (FF2.0rc1). None are listed disabled.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060916 Firefox/2.0 (Swiftfox) ID:0000000000

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 4 guests