MozillaZine

[Ext] DblClicker & KillSpinners & FlashStopper & Add-on Tbb

Announce and Discuss the Latest Theme and Extension Releases.
delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted November 28th, 2017, 5:44 am

_
Last edited by delicacy1 on December 4th, 2017, 12:43 am, edited 2 times in total.

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 3rd, 2017, 3:26 pm

on dailymotion, i have no video, only sound.
Last edited by delicacy1 on December 4th, 2017, 12:43 am, edited 1 time in total.

Robert Ab
 
Posts: 10
Joined: November 19th, 2017, 12:55 am

Post Posted December 3rd, 2017, 7:44 pm

yochaim wrote:hi woza,

see viewtopic.php?p=14736506#p14736506, viewtopic.php?p=14773627#p14773627
and the related discussion...



Hi Yochaim,
Are you not planning to port FlashStopper to WE at all or you are waiting for missing APIs?
Thanks

Elhem Enohpi
 
Posts: 27
Joined: March 19th, 2016, 8:49 am

Post Posted December 8th, 2017, 8:52 am

Hi, I'm trying to stop autoplay videos on MacWorld.com. They're using Brightcove. Is it possible with FlashStopper? Or some other solution for Firefox/Waterfox 56 with e10s enabled?

I tried putting all these in "proactive blocking" list:
Code: Select all
https://www.macworld.com
https://brightcove.net
https://players.brightcove.net
https://brightcove.com


But they still keep playing... am I doing something wrong? Thanks for any help!

yochaim
 
Posts: 478
Joined: September 14th, 2009, 9:23 am

Post Posted December 8th, 2017, 9:58 am

the brightcove player in html5 is stopped with the normal handler the flash used to stop with pb.
on the sites you posted i get the html5 player and they do not autoplay.
ex for brightcove i have in my test list (wfm with thumbnail...)
https://www.techhive.com/article/295372 ... -free.html
https://www.pcworld.com/article/2685192 ... eries.html
so:
check that you've got latest fs (and latest handler...). check which player you're getting. add specific pages that autoplay for you...

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 10:30 am

I'm ignored "as usual".

yochaim
 
Posts: 478
Joined: September 14th, 2009, 9:23 am

Post Posted December 8th, 2017, 12:02 pm

delicacy,

see viewtopic.php?p=14767021#p14767021
you should be using https://addons.mozilla.org/firefox/down ... 0b1-fx.xpi (or even v2.5.1)
but with old ff and your problems with html5 formats not sure how well it will work for you...
p.s
you might try changing your useragent per site to get their latest player which is usually html5

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 12:05 pm

do i lose the userscripts you gave me if i update ?

yochaim
 
Posts: 478
Joined: September 14th, 2009, 9:23 am

Post Posted December 8th, 2017, 12:31 pm

nop, userhandler.js is never overwritten (only handler.js aka script in the editor)...

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 1:30 pm

"script in the editor" ? i don't think you've ever asked me to edit that part in the past, i can't remember, but i don't know why you would..
I'm gonna try 2.5.1.

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 1:47 pm

With 2.5.1, after changing minimum install version in rdf, i get this:

"SyntaxError: in strict mode code, functions may be declared only at top level or immediately within another function"

is it possible to update it so this doesn't occur or should i stay on 1.5.0b1 only ?

Elhem Enohpi
 
Posts: 27
Joined: March 19th, 2016, 8:49 am

Post Posted December 8th, 2017, 1:51 pm

yochaim wrote:the brightcove player in html5 is stopped with the normal handler the flash used to stop with pb.
on the sites you posted i get the html5 player and they do not autoplay.
ex for brightcove i have in my test list (wfm with thumbnail...)
https://www.techhive.com/article/295372 ... -free.html
https://www.pcworld.com/article/2685192 ... eries.html
so:
check that you've got latest fs (and latest handler...). check which player you're getting. add specific pages that autoplay for you...


The two examples you gave work ok for me, autoplay is stopped by FS. But on macworld.com, they're not, for example:
https://www.macworld.com/article/204270 ... ideos.html

I have FS 2.5.1. I'm not sure how to check which player I'm getting, but I have Flash set to "never activate" so I assume it's HTML5.

yochaim
 
Posts: 478
Joined: September 14th, 2009, 9:23 am

Post Posted December 8th, 2017, 2:27 pm

@Elhem Enohpi

to check which player use shift+right-click where you'll see either the html5 video (or fs play menuitem) or flash context... but if you disabled flash in this case its html5!
it stops for me on your link (ff55/ff56 fs2.5.1) and anyways html5 should always stop...
so check in your exceptions lists (allow, session, pb) that you don't have the site.
try new profile with new installed fs 2.5.1 (restart ff after install)
let me know the results...

@delicacy

that shouldn't happen but 1.5.0b1 is the same (handler wise) it's just not e10s.

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 2:41 pm

Well it does happen on ff44, it wouldn't happen on 1.5.0b1 ?

ps: i didnt uninstall previous flashstopper before updating to latest version, i didnt wanna lose any handlers

yochaim
 
Posts: 478
Joined: September 14th, 2009, 9:23 am

Post Posted December 8th, 2017, 3:07 pm

try 1.5.0b1 if it doesn't happen all is well.
but i'm guessing you'll hit the same issue.
if you do after install open the editor and remove "use strict"; from the userscript (and apply) if this doesn't help try removing it from the script too...

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 2 guests