MozillaZine

[Ext] DblClicker & KillSpinners & FlashStopper & Add-on Tbb

Announce and Discuss the Latest Theme and Extension Releases.
z00
 
Posts: 18
Joined: December 3rd, 2012, 4:06 am

Post Posted July 22nd, 2018, 2:18 pm

yochaim wrote:i think the problem is with addontbb last version...
try using v1.1.3 (from here https://addons.mozilla.org/en-US/firefo ... /versions/)
be sure to disable updates for the addon.

Unfortunately, that doesn't help - I still have the exact same problem.

yochaim
 
Posts: 499
Joined: September 14th, 2009, 9:23 am

Post Posted July 23rd, 2018, 10:21 am

what pm/addon toolbarbutton/flashstopper versions you use?
does the button reappear if you just disable & enable addon toolbarbutton?
try creating new addon toolbarbutton and restarting.
try it on a new profile.

let me know the results...

z00
 
Posts: 18
Joined: December 3rd, 2012, 4:06 am

Post Posted July 23rd, 2018, 11:20 am

yochaim wrote:what pm/addon toolbarbutton/flashstopper versions you use?

I am using version 1.1.4 of Add-on Toolbarbutton and version 1.4.5 of FlashStopper.

does the button reappear if you just disable & enable addon toolbarbutton?

No. However, I discovered that if I simply reinstall Tbb on top of the previous installation, the FlashStopper button immediately reappears.

try it on a new profile.

I did, and I got identical results.

yochaim
 
Posts: 499
Joined: September 14th, 2009, 9:23 am

Post Posted July 23rd, 2018, 11:55 am

you should be using Add-on Toolbarbutton version 1.1.3
do you have the latest pale moon?
from the addon manager page try disabling Add-on Toolbarbutton then re-enabling (this should work exactly as reinstalling...)
btw you can use the fs version 1.5.2 from here (http://www.byo.co.il/Download/newversions.zip) which is a bit more advanced.

z00
 
Posts: 18
Joined: December 3rd, 2012, 4:06 am

Post Posted July 23rd, 2018, 2:43 pm

yochaim wrote:you should be using Add-on Toolbarbutton version 1.1.3

It had the same behavior before, but I gave it another try. This time it got rid of the problem. I don't know why it's different now, although I'm also using the updated version of FlashStopper.

do you have the latest pale moon?

Yes.

from the addon manager page try disabling Add-on Toolbarbutton then re-enabling (this should work exactly as reinstalling...)

Before I fixed the problem, I verified that this indeed worked.

btw you can use the fs version 1.5.2 from here (http://www.byo.co.il/Download/newversions.zip) which is a bit more advanced.

Great - I've installed that one.

Thanks for all your help - I'm all set now.

Oomingmak
 
Posts: 176
Joined: July 10th, 2004, 7:46 pm
Location: UK

Post Posted August 18th, 2018, 10:46 am

Hi, I'm having a problem with Flashstopper on the Bitchute web site. I'm using latest Firefox ESR.

Flashstopper doesn't just stop the autoplay of Bitchute videos, it breaks video playback altogether. If I whitelist the Bitchute web site in Flashstopper then Bitchute videos do become playable, but they all auto-start without me having to press the 'play' button first (which is annoying and is the reason why I installed Flashstopper in the first place). Using media.autoplay.enabled setting in Firefox about:config is not an option because setting that to 'false' breaks Bitchute even worse (the entire video player disappears and you just get a plain white blank page).

On my other web browser (Chrome-based) I have an extension called Autoplay Stopper. It prevents Bitchute videos from autoplaying but without breaking playback entirely. When you land on a Bitchute video plage you can see the video peer-to-peer buffering working correctly, but the video won't actually start playing until you press the play button. It would be great if Flashstopper worked in the same way, because I can't use that chrome Autoplay Stopper extension on my legacy Firefox ESR browser.

Any work-arounds or other advice would be much appreciated. Thanks.

yochaim
 
Posts: 499
Joined: September 14th, 2009, 9:23 am

Post Posted August 19th, 2018, 9:46 am

hi Oomingmak,

it behaves the same for me. tested it with autoplaystopper on ff and it worked as it should...
the difference between aps & fs is in the way the add-ons hook to the video element, the handling code is pretty much the same.
anyways i couldn't make it work correctly in fs.
the context menu item works for both so you can start the video by using right-click > play on the middle play button or the controls.

z00
 
Posts: 18
Joined: December 3rd, 2012, 4:06 am

Post Posted August 23rd, 2018, 10:32 pm

I recently noticed that FlashStopper has stopped working on YouTube. As this applies both to the Pale Moon 28 version of FS (1.5.2) (my main browser) and the Firefox version on Firefox 52 ESR (2.6.4), it appears that YouTube has changed something yet again.

yochaim
 
Posts: 499
Joined: September 14th, 2009, 9:23 am

Post Posted August 23rd, 2018, 11:43 pm

do you mean that fs is working ok on other sites but when you open a youtube video in new tab it autoplays?
that is almost an impossibility, you might get the video paused instead of stopped.
anyways i didn't experienced any issues on pm 28 & ff60esr but youtube usually rollout changes gradually so maybe it's a coming...

z00
 
Posts: 18
Joined: December 3rd, 2012, 4:06 am

Post Posted August 24th, 2018, 2:06 am

yochaim wrote:do you mean that fs is working ok on other sites but when you open a youtube video in new tab it autoplays?

FS continues to work as always on sites such as CNN, Vimeo, and any others that I try. But if I load a YouTube video page, the video starts playing immediately, even if I set proactive blocking (which I haven't had to do for YouTube before).

anyways i didn't experienced any issues on pm 28 & ff60esr but youtube usually rollout changes gradually so maybe it's a coming...

Could be... I just noticed this problem within the last couple of days.

yochaim
 
Posts: 499
Joined: September 14th, 2009, 9:23 am

Post Posted August 24th, 2018, 2:23 am

again, it is strange since blocking the video tag autoplay happens without any relation to the specific site (btw currently i don't know of any site that is able to overrides this for fs or aps...) after that the youtube api (that can change) is used to reload the video cued...
be sure that you don't have proactive blocking (or allowing autoplay) for youtube & maybe try on a new profile with no other extensions.

z00
 
Posts: 18
Joined: December 3rd, 2012, 4:06 am

Post Posted August 24th, 2018, 6:44 am

My technical knowledge here is pretty slim, so I don't have any idea why this is happening only for YouTube. Normally, I run YouTube without proactive blocking, but I tried turning it on when YouTube started autoplaying; it had no effect, so I turned it off.

I notice that YouTube videos embedded on other Web pages never autoplay, regardless of the settings of FS; I assume you know this, but the fact that this is unchanged for me may be helpful to know.

I tried FS on a new profile and got the exact same results - FS doesn't work on YouTube, but does work on all my other video sources.

yochaim
 
Posts: 499
Joined: September 14th, 2009, 9:23 am

Post Posted August 24th, 2018, 10:20 am

can you try this https://addons.mozilla.org/en-US/firefo ... -no-buffer
it uses same method on yt (but stops every video)
do you know how to use the flashstopper script editor?

z00
 
Posts: 18
Joined: December 3rd, 2012, 4:06 am

Post Posted August 24th, 2018, 2:21 pm

yochaim wrote:can you try this https://addons.mozilla.org/en-US/firefo ... -no-buffer
it uses same method on yt (but stops every video)

Well, that did it.

do you know how to use the flashstopper script editor?

No, but I'm game to try.

yochaim
 
Posts: 499
Joined: September 14th, 2009, 9:23 am

Post Posted August 24th, 2018, 4:00 pm

if your happy with this solution that's ok.
if you want to try & fix your fs script let me know...

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest