MozillaZine

Silvermel and Charamel - Themes for Firefox and Thunderbird

Announce and Discuss the Latest Theme and Extension Releases.
Jarvis_99
 
Posts: 3
Joined: February 2nd, 2017, 9:14 pm

Post Posted February 4th, 2017, 11:58 am

Hi ShareBird, hope you had a great day :)
I today found that in the "new tab" of firefox, there is no facility to pin any new tiles, nor can I unpin any pinned tiles. However the Pin symbol appears below pinned tiles as usual.
So also the "Remove this site" button works as usual too. Hope I did not miss anything.

ShareBird

User avatar
 
Posts: 2740
Joined: December 8th, 2004, 7:09 am
Location: Berlin | Made in Brasil

Post Posted February 4th, 2017, 3:38 pm

Jarvis_99 wrote:Hi ShareBird, hope you had a great day :)
I today found that in the "new tab" of firefox, there is no facility to pin any new tiles, nor can I unpin any pinned tiles. However the Pin symbol appears below pinned tiles as usual.
So also the "Remove this site" button works as usual too. Hope I did not miss anything.

Hi Jarvis_99!! Thank you for reporting!
Hehe... I've found this issue three days ago. :-)
It will be fixed in the next version.
Cheers
Silvermel - A Theme for Firefox and Thunderbird
YATT - Yet Another Theme Tutorial
Don't give a man a fish. Teach him how to fish instead.

Willard McBain
 
Posts: 25
Joined: April 14th, 2015, 10:57 am

Post Posted February 17th, 2017, 12:33 pm

Hi, showing an update to Charamel and Silvermel in my extensions tab, but getting "There was an error downloading" when I click the "update now" button - both firefox and thunderbird. Don't know if this is strictly an AMO problem or related to how the new versions were uploaded, but thought I should mention it here.

ShareBird

User avatar
 
Posts: 2740
Joined: December 8th, 2004, 7:09 am
Location: Berlin | Made in Brasil

Post Posted February 18th, 2017, 5:11 am

Willard McBain wrote:Hi, showing an update to Charamel and Silvermel in my extensions tab, but getting "There was an error downloading" when I click the "update now" button - both firefox and thunderbird. Don't know if this is strictly an AMO problem or related to how the new versions were uploaded, but thought I should mention it here.

Thank you Willard!! Indeed I've noticed this for a couple days and already asked for help here:
https://discourse.mozilla-community.org ... emes/13601

Also sent an email and tried to contact people at IRC, but unfortunately no answers until now...
Silvermel - A Theme for Firefox and Thunderbird
YATT - Yet Another Theme Tutorial
Don't give a man a fish. Teach him how to fish instead.

whismerhill
 
Posts: 38
Joined: June 30th, 2005, 4:04 pm

Post Posted March 6th, 2017, 8:43 pm

ugh.... wtf is mozilla doing.....
so multi-package xpi is unsupported anymore...
and charamel/silvermel are bundled like this ...

between this & the drop of support for "old extensions" which means soonish there will be no more tab groups ... (from my information, should stop working at firefox 57

TechnoLurker
 
Posts: 51
Joined: November 9th, 2011, 3:43 pm

Post Posted March 8th, 2017, 1:52 pm

I've moved to Pale Moon. I don't use Silvermel in Firefox, but with a few tweaks it might work in Pale Moon since it can use Firefox extensions. Looks like the most recent version that will install correctly from Mozilla's add-ons site is 1.5.7.1-signed. I tried installing silvermel_bundle_2.0.0pre_r7177 and it kind of worked, but some of the text had overlays.

ShareBird

User avatar
 
Posts: 2740
Joined: December 8th, 2004, 7:09 am
Location: Berlin | Made in Brasil

Post Posted March 8th, 2017, 3:13 pm

TechnoLurker wrote:I've moved to Pale Moon. I don't use Silvermel in Firefox, but with a few tweaks it might work in Pale Moon since it can use Firefox extensions. Looks like the most recent version that will install correctly from Mozilla's add-ons site is 1.5.7.1-signed. I tried installing silvermel_bundle_2.0.0pre_r7177 and it kind of worked, but some of the text had overlays.

Is the AMO version not working on Pale Moon?
Silvermel - A Theme for Firefox and Thunderbird
YATT - Yet Another Theme Tutorial
Don't give a man a fish. Teach him how to fish instead.

TechnoLurker
 
Posts: 51
Joined: November 9th, 2011, 3:43 pm

Post Posted March 8th, 2017, 3:59 pm

Latest version on AMO says not available for Firefox 27.9. It will install if you tell it to do it anyway, but URLs are nearly unreadable with doubled text.

Also, toolbar isn't showing everything. Notice that uBlock Origin where I'm hovering is just off the right side of the screen.

Image

MilchFlasche
 
Posts: 36
Joined: July 14th, 2004, 7:32 pm
Location: Taiwan, an island country between East Asia and West Pacific

Post Posted March 12th, 2017, 1:19 pm

TechnoLurker wrote:Latest version on AMO says not available for Firefox 27.9. It will install if you tell it to do it anyway, but URLs are nearly unreadable with doubled text.

Also, toolbar isn't showing everything. Notice that uBlock Origin where I'm hovering is just off the right side of the screen.

Image


I'm also using Pale Moon. Please do try Pale Moon - Add-ons - Theme Compatibility Provider which may fix glitches of themes. (I have only tested it with Charamel 1.5.7, though. I'm going to try it with latest builds of ShareBird)
A whole new history is beginning...

MilchFlasche
 
Posts: 36
Joined: July 14th, 2004, 7:32 pm
Location: Taiwan, an island country between East Asia and West Pacific

Post Posted March 12th, 2017, 1:32 pm

ShareBird wrote:
TechnoLurker wrote:I've moved to Pale Moon. I don't use Silvermel in Firefox, but with a few tweaks it might work in Pale Moon since it can use Firefox extensions. Looks like the most recent version that will install correctly from Mozilla's add-ons site is 1.5.7.1-signed. I tried installing silvermel_bundle_2.0.0pre_r7177 and it kind of worked, but some of the text had overlays.

Is the AMO version not working on Pale Moon?

Dear ShareBird, first of all thanks to the great work for years. Charamel is my favorite Firefox theme, especially with Personas weared on top of it.

I have switched to Pale Moon for better performance than Firefox. And I have just tested the AMO build 2.0.1 on Pale Moon, with Pale Moon - Add-ons - Theme Compatibility Provider installed. But the result is not yet so normal: Image

1.6.1 & 1.5.7 looks fine. [Update] 1.6.1 on Pale Moon will still hide the bookmark icon in the Location Bar.
Last edited by MilchFlasche on March 12th, 2017, 11:53 pm, edited 1 time in total.
A whole new history is beginning...

ShareBird

User avatar
 
Posts: 2740
Joined: December 8th, 2004, 7:09 am
Location: Berlin | Made in Brasil

Post Posted March 12th, 2017, 2:26 pm

I really have no idea what the future of my themes will look like... For the next version of Firefox (52.0) they will not work anymore because Firefox will not support bundles (in my case the themes are bundled with SilvermelXT, an companion extension) anymore. For Firefox 58 they will not work anyway because XUL extensions will disappear.
Well, the last five years have been extremely difficult to maintain the themes. I have sacrificed all my free time available. Making them Pale Moon compatible will require a lot of efforts, I presume.
I do not believe that the future of my themes is very promising...
Silvermel - A Theme for Firefox and Thunderbird
YATT - Yet Another Theme Tutorial
Don't give a man a fish. Teach him how to fish instead.

Lootyhoof
 
Posts: 7
Joined: July 9th, 2016, 9:58 am
Location: United Kingdom

Post Posted March 12th, 2017, 3:54 pm

ShareBird wrote:Making them Pale Moon compatible will require a lot of efforts, I presume.

If you base on version 1.5.7 of your themes and work in changes listed here, it shouldn't be too difficult, I'd hope. Though please feel free to poke me if you need any further help, if this is something you'd like to do.

MilchFlasche
 
Posts: 36
Joined: July 14th, 2004, 7:32 pm
Location: Taiwan, an island country between East Asia and West Pacific

Post Posted March 13th, 2017, 12:04 am

ShareBird wrote:I really have no idea what the future of my themes will look like... For the next version of Firefox (52.0) they will not work anymore because Firefox will not support bundles (in my case the themes are bundled with SilvermelXT, an companion extension) anymore. For Firefox 58 they will not work anyway because XUL extensions will disappear.
Well, the last five years have been extremely difficult to maintain the themes. I have sacrificed all my free time available. Making them Pale Moon compatible will require a lot of efforts, I presume.
I do not believe that the future of my themes is very promising...

For me, I'm satisfied with 1.5.7 of Charamel, as long as Pale Moon does change drastically like Firefox... So I do not mean to ask support here.

But the end of XUL extensions is indeed a very bad news to all of us. I personally have abandoned Firefox.
A whole new history is beginning...

Willard McBain
 
Posts: 25
Joined: April 14th, 2015, 10:57 am

Post Posted March 13th, 2017, 9:18 am

ShareBird wrote:I do not believe that the future of my themes is very promising...


I'm certainly sad to hear that. Charamel and Silvermel are simply beautiful themes. No others come close. One of the reasons I've switched to the Firefox ESR version is to use them as long as possible.

Xaemyl
 
Posts: 15
Joined: August 9th, 2004, 6:35 pm

Post Posted April 5th, 2017, 12:03 pm

I just upgraded to thunderbird 52, and it sez silvermel is incompatible, but it still seems to be working (although it defaults to off now whenever I start up so I have to reenable it). :/

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 3 guests