MozillaZine

[Theme] Noia Fox

Announce and Discuss the Latest Theme and Extension Releases.
David.Vincent

User avatar
 
Posts: 213
Joined: June 17th, 2011, 10:11 pm

Post Posted June 19th, 2011, 2:15 am

Image

Theme :

Download : https://addons.mozilla.org/en-US/firefo ... /noia-fox/

Last version : 3.1.4 [2015.06.23]

Noia Fox Options

Download : https://addons.mozilla.org/en-US/firefo ... x-options/

Last version : 3.0.2 [2015.06.21]

Here is the support page of the theme and the options if you want to report a bug or make suggestions.

If you have trouble, here are some steps you can try before posting :

1. Install the latest Noia Fox theme version.

2. Install the latest Noia Fox options version.

3. Disable Noia Fox options.

4. If the bug comes from Noia Fox options, restore Noia Fox options default settings.


If you still have a problem, create a new profile (http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows) , install Noia Fox.
If you don't see the problem, it's most likely a conflict with another extension. Install your extensions one by one restarting in between until problem reappears. Post your problem and tell me the name of the add-on that causes the bug.

For all bugs, you must tell me :
- your OS (Windows, Mac, Linux).
- the Firefox/Thunderbird version.
- the Noia Fox version.
- the list of the add-ons installed.
and it is better to join a screen shot.

Pour les francophones, voici le lien du support en français :

http://forums.mozfr.org/viewtopic.php?f ... 46#p633146
Last edited by David.Vincent on June 23rd, 2015, 3:17 pm, edited 60 times in total.

Platon_
 
Posts: 3912
Joined: July 30th, 2009, 2:42 am

Post Posted June 19th, 2011, 5:33 am

Hi David,

Just a suggestion :) I don't see a link to this support page at AMO. Adding it would help to keep bug reports and help requests all at the same place, IMHO.

Great work with this Noia Fox theme.

David.Vincent

User avatar
 
Posts: 213
Joined: June 17th, 2011, 10:11 pm

Post Posted June 19th, 2011, 4:11 pm

Thank you.

The link to the support page is now added.

Retimus
 
Posts: 7
Joined: March 16th, 2004, 5:51 am

Post Posted June 20th, 2011, 9:07 am

Hi David,

After upgrade to version 1.3.3 my theme looks not so cool as before. I'm hiding Menu Bar, so window buttons now looks like this:
Image
If I show Menu Bar, then everything OK:
Image

Another bad thing: size of Navigation Toolbar. And it doesn't matter will I hide separators or not:
Image
It should be similar size to menu and tab bars I guess...

Thanks in advance

David.Vincent

User avatar
 
Posts: 213
Joined: June 17th, 2011, 10:11 pm

Post Posted June 20th, 2011, 11:28 am

Hi Retimus,

Caption butons :
Can you tell me wich OS you have in your computer (Windows 98, Windows XP, Windows 7, Mac, Linux, ....)?

Do you have the Hide caption titlebar add-on? Noia Fox doesn't work with this add-on (see in the AMO page how to remove it).

I have tested Noia Fox on Windows XP and Windows 7 with 5 different computers and all computers are displaying correctly the caption buttons.

Can you test a new profile with no add-on and see if there is always your problem. Thank you.

For the Navigation Toolbar :
The size is good. I have fixed this height because it is more beautiful (I am using large buttons). But I will see if it is possible to have two different heights (one for small buttons and one for large buttons)

Retimus
 
Posts: 7
Joined: March 16th, 2004, 5:51 am

Post Posted June 20th, 2011, 11:20 pm

Hi David,

I'm using Win 7 and I do not have Hide caption titlebar add-on.

Actually your hint with new profile helped. After I have created new profile, switched to it and then switched back to mine all start work perfectly. Thanks!

Looking forward to navigation toolbar resize for small icons :)

UPD: In that case, then window buttons return to normal, mouse buttons Back/Forward stops working. After Firefox restart, window buttons returns to semihidden (as on screenshots above) and mouse buttons Back/Forward start working again. :|

David.Vincent

User avatar
 
Posts: 213
Joined: June 17th, 2011, 10:11 pm

Post Posted June 21st, 2011, 8:14 am

Hi Retimus,

Can you test only the new profile a little time in order to see if the bug is still here.

Can you post the list of the add-ons you have installed. I will test them : perhaps there is one that is not compatible with Noia Fox.

An other solution : can you upgrade to Firefox 5 (there is a lot of bugs with Firefox 4). The final version is here : http://www.mozilla.com/en-US/firefox/fx/?ref=logo

twittPro
 
Posts: 2
Joined: June 21st, 2011, 9:34 am

Post Posted June 21st, 2011, 2:36 pm

Very cool theme, i used this to my Mozilla. Good job David

Retimus
 
Posts: 7
Joined: March 16th, 2004, 5:51 am

Post Posted June 21st, 2011, 11:56 pm

David.Vincent wrote:Hi Retimus,

Can you test only the new profile a little time in order to see if the bug is still here.

Can you post the list of the add-ons you have installed. I will test them : perhaps there is one that is not compatible with Noia Fox.

An other solution : can you upgrade to Firefox 5 (there is a lot of bugs with Firefox 4). The final version is here : http://www.mozilla.com/en-US/firefox/fx/?ref=logo

Hi David,

Actually problem with Back/Forward buttons was also on test profile, which is without any add-ons installed. I have solved it by updating Logitech drivers as was suggested by Google search :)

But problem with semihidden window button still remain on my main profile. I'll try to switch off my add-ons one by one and see which one is causing this problem, because on empty test profile buttons looks fine.

Will keep you updated

Retimus
 
Posts: 7
Joined: March 16th, 2004, 5:51 am

Post Posted June 25th, 2011, 7:15 am

Hi David,

Nothing helped actually. I'm too lazy to switch to new profile and then move settings from old one to new. So I tried to fight with my old profile

Even after updating to Noia Fox version 1.3.4 problem with window buttons stays... Funny thing: then I press F11 before going to full screen mode window buttons went to normal view.

Only changing compatibility to Windows XP in FF shortcut solved problem with this buttons.

Meanwhile I'll stay to this solution, hopefully you'll be able to suggest something more :)

Thanks in advance

David.Vincent

User avatar
 
Posts: 213
Joined: June 17th, 2011, 10:11 pm

Post Posted June 25th, 2011, 10:49 am

Hi Retimus,

Actualy I am working on an evolution of the windows buttons display. The buttons will be displayed with all modes (when menu is hidden) and I am changing some tab groups icons. The evolution is compatible with Hide caption titlebar add-on. Beta tested on Windows XP, Windows classic and Windows 7 on different computers and there is no graphic bugs.

Can you post the list of your add-ons. I will test them. I see in the snapshots you have posted that you haven't a normal display for the tabs (there are not square, not rounded -> what is this add-on?)

Edit : I think I have solved the problem. You have a classic Windows theme and Noia Fox didn't work correctly with this Windows theme. I have worked all the night for the correction of this bug. Your problem will be solved with the next version.

elfalot
 
Posts: 2
Joined: June 26th, 2011, 8:23 pm

Post Posted June 26th, 2011, 8:31 pm

Hi just installed FF5 and Noia Fox 1.3.4, and i have noticed that the close buttons on the tabs wont highlight the button or close the tab when clicked, if the cursor is over the right half of the circle,it only works on the left.

Retimus
 
Posts: 7
Joined: March 16th, 2004, 5:51 am

Post Posted June 27th, 2011, 1:17 am

@David
Hi again,

Yes, this is the thing I forgot to mentioned. I indeed using classic Windows theme. "Adjust for best performance" is the first thing I do on any PC I'm working with. Thanks for so quick understanding and support!

@elfalot
I'm using the same configuration you do and didn't noticed such problem. The thing is that tab close button will work only if black cross inside it is highlighted

elfalot
 
Posts: 2
Joined: June 26th, 2011, 8:23 pm

Post Posted June 28th, 2011, 6:03 am

@Retimus
Well that's the thing, for me it only highlights when hovering over the left half of the circle, hovering just outside the circle doesn't work (meaning its not off center)
Here is a pick with a rough outline of the area that works for me.
Image

Note: this applies to both button styles

Damn 1.3.5 gives me the same
Last edited by elfalot on June 30th, 2011, 5:53 am, edited 1 time in total.

David.Vincent

User avatar
 
Posts: 213
Joined: June 17th, 2011, 10:11 pm

Post Posted June 28th, 2011, 1:42 pm


Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 3 guests