MozillaZine

[Ext] GlassMyFox - GlassMyBird

Announce and Discuss the Latest Theme and Extension Releases.
Pizzapops

User avatar
 
Posts: 46
Joined: December 22nd, 2013, 6:56 pm
Location: Lake of the Ozarks, MO

Post Posted October 11th, 2014, 11:48 am

Ignore the previous post. After playing with all the setting, I found changing Preference windows.... to Glass v2 fixed it.
Windows 10 Pro I7/16mb - work laptop, Windows 10 I7/32mb 6TB - home desktop
Cyberfox 52-64, Waterfox 56, Firefox Nightly 62, Opera 12.18, Opera Dev, Vivaldi 1.16
About 46 extensions in the Fx branches. All are portable and run from a USB 3.0 SSD drive.

Brummelchen
 
Posts: 3658
Joined: March 19th, 2005, 10:51 am

Post Posted November 1st, 2014, 4:19 am

@pizzapops

same as me here? see picture
Image

this came up with Firefox 34 (actual 34b5)

this picture was taken in safe mode on win7/with glass. the curiosity is that if open a blank tab with my glass effect i dont have such background
Code: Select all
/* AGENT_SHEET */
@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

/*Removes Background-Color From Chrome */
#appcontent,
#appcontent > #content,
#appcontent > #content > tabbox > tabpanels {
  background-color: transparent !important;
}

/*Fixes Aero Border */
#main-window[stylish-url="about:blank"]:not([onclose^="PrintUtils"]):not([title^="Source Chart"]):not([title^="Super Start"]):not([chromehidden="menubar toolbar directories extrachrome "]) #appcontent {
  -moz-appearance: none !important;
}
#main-window:hover[stylish-url="about:blank"]:not([onclose^="PrintUtils"]):not([title^="Source Chart"]):not([chromehidden="menubar toolbar directories extrachrome "]) #appcontent {
  -moz-appearance: none !important;
}

/*For Transparency In Fullscreen*/
#main-window[inFullscreen="true"]{
  -moz-appearance: -moz-win-borderless-glass !important;
  background: none !important;
}

/*Sets Content Transparent*/
#main-window[stylish-url="about:blank"]:not([onclose^="PrintUtils"]):not([title^="Source Chart"]):not([title^="Super Start"]):not([chromehidden="menubar toolbar directories extrachrome "]) #content browser:not([src]){
   opacity: 0 !important;
}
#main-window:hover[stylish-url="about:blank"]:not([onclose^="PrintUtils"]):not([title^="Source Chart"]):not([chromehidden="menubar toolbar directories extrachrome "]) #content browser:not([src]){
   opacity: 0 !important;
}


even speed dial dont show it
http://speeddial.uworks.net/

Aris earlier told me that mozilla is trying out some annoying ::after and ::before styles but i didnt found yet any helpful in its omni.ja

Aris

User avatar
 
Posts: 3184
Joined: February 27th, 2011, 10:14 am

Post Posted November 1st, 2014, 9:17 am

You are not using the default AeroGlass Windows visual style, so thinga might be different for you. Compared to GMFs transparent about:blank/about:new:tab options, the code above does not make those about pages transparent for me anymore.

Brummelchen
 
Posts: 3658
Joined: March 19th, 2005, 10:51 am

Post Posted November 2nd, 2014, 10:05 am

no matter if my settings or the windows 7 default aero theme, see:

Image

the problem occurs with firefox v34 but not with v33 - thats my point.

beside, strange - a new tab is glossy with out my style - i never tried since several versions. CTR do not have such hidden settings!?

Aris

User avatar
 
Posts: 3184
Joined: February 27th, 2011, 10:14 am

Post Posted November 4th, 2014, 4:30 pm

Nope, there are no hidden settings to change windows or window borders in CTR or GMF.
I'm still not sure what exactly the "problem" is.
Is it the missing window border gradient on a transparent new tab page or is it the available window border gradient in general?

You can also PM me in German, if you like.

Brummelchen
 
Posts: 3658
Joined: March 19th, 2005, 10:51 am

Post Posted November 15th, 2014, 3:56 am

*fixed* with some later 34betas, thank you

lompyka
 
Posts: 1
Joined: December 11th, 2014, 1:20 am

Post Posted December 11th, 2014, 1:59 am

Hi Aris!

I use GlassMyFox with great satisfaction. But now I can't handle a bug.
I had to reset my firefox because it didn't start then I added the GlessMyFox again and try to set it to same as before.
I can't set the icons (home, back, download, add new tab, menu, etc...) to dark, they are all white and I can't change.
ImageImageImage
As I notice this problem is caused after I set the "Main window toolbar text" to "White text & black shadow v1 (GMF default)", btw this settings is good for me.
Image

My firefox version is 34.0.5
GMF version is 1.3.6
Please tell me the solution or update the GMF!

Thanks!

Lompy

Aris

User avatar
 
Posts: 3184
Joined: February 27th, 2011, 10:14 am

Post Posted December 11th, 2014, 4:20 am

Apparently you found a new Firefox feature or bug. A text color setting starts to affect button icons now on tabs toolbar and navigation toolbar for no reason.

This code switches default toolbar button icons to inverted ones, but it only happens with "#FFFFFF" (white).
Code: Select all
toolbar {
  color: #FFFFFF !important;
}


Try this GMF build:
Code: Select all
https://www.dropbox.com/s/dy9ehvx4ae34c9f/GlassMyFox_1.3.6v4.xpi?dl=0

lemonhands
 
Posts: 2
Joined: January 16th, 2015, 11:35 am

Post Posted January 16th, 2015, 11:39 am

Hey Aris, love GlassMyFox, it really looks great. Thanks a lot for all the work you put in. I was wondering if there was a way to make the drop down text on the URL bar white, maybe it's an option that I'm just not seeing? Here's an example, since I have a dark background it's pretty difficult to read.
Image

reduced size since it was breaking the forum format. Click on image to see it full sized --ln (mod)

Aris

User avatar
 
Posts: 3184
Joined: February 27th, 2011, 10:14 am

Post Posted January 16th, 2015, 7:18 pm

The dropdown-menu / popupmenu colors should also affect location bars popup.

Try this build: https://www.dropbox.com/s/oj01yydet1qru ... 3.xpi?dl=0

lemonhands
 
Posts: 2
Joined: January 16th, 2015, 11:35 am

Post Posted January 17th, 2015, 12:35 pm

Hey, it worked and it looks great. Thanks a lot, Aris.

usernameistoolong
 
Posts: 210
Joined: January 13th, 2009, 6:43 pm

Post Posted April 7th, 2015, 10:10 pm

Hi! I'm having a problem where the in an empty tab, which I have set to display about:blank, is not glassed. It shows a grey field that includes the address bar and search bar,

http://s21.postimg.org/vq4t8s8d3/blank_grey.jpg

What am I doing wrong?

usernameistoolong
 
Posts: 210
Joined: January 13th, 2009, 6:43 pm

Post Posted April 7th, 2015, 10:11 pm

Hi! I'm having a problem where in an empty tab, which I have set to display about:blank, is not glassed. It shows a grey field that includes the address bar and search bar,

Image

What am I doing wrong?

usernameistoolong
 
Posts: 210
Joined: January 13th, 2009, 6:43 pm

Post Posted April 7th, 2015, 10:17 pm

[sorry about this double post, it seemed not to take or something the first time I tried]
Last edited by usernameistoolong on April 8th, 2015, 9:08 am, edited 1 time in total.

Aris

User avatar
 
Posts: 3184
Joined: February 27th, 2011, 10:14 am

Post Posted April 8th, 2015, 4:54 am

Do you also have Stylish installed? It is essential for the transparent about:newtab and about:blank pages to work.

Also please test on a clean new Firefox profile without any other add-ons installed but GMF and Stylish.

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 3 guests