MozillaZine

[Ext] Simple Mail

Announce and Discuss the Latest Theme and Extension Releases.
WebVoyager
 
Posts: 160
Joined: November 20th, 2004, 4:58 am

Post Posted February 5th, 2013, 3:55 pm

I've always dreamed of combining the e-mail client with the browser, and therefore Simple Mail (SM) appears as an oasis.
But there are a few points which bother me. So if the developer is kind enough to clear these, I'd appreciate.

1- May SM become the default e-mail client ? By this I mean, may the system (Windows) recognize SM within Firefox as the e-mail client e.g. will mailto: from Windows open Firefox and SM ? I believe not ;

2- Is there any possibility of import/export of e-mails ? Especially if answer to (1) was yes, then I'd wish to import from Thunderbird (maybe even otherwise) ;

3- I've read it was possible to store the mailbox on a Flash drive. Is it possible to store it elsewhere than in the default SM folder ? The latter is of course in the user's profile, and my profile is on a RAM disk, so I'd like to move this mailbox elsewhere, but on my hard drive. Whatever, how to proceed ? I've seen in SM's Options/General an item for this issue, but unable to open a folder selection GUI ... ( past tense because I installed/removed yesterday, waiting to expose this comment).

Thanks.
I'm no longer here -- Cannot delete/close my profile -- Bye

TechnalXS

User avatar
 
Posts: 62
Joined: July 3rd, 2012, 11:10 am

Post Posted February 7th, 2013, 12:51 pm

1 - impossible, an add-on is not a standalone program
2 - yes - yes - simply open the files without extension (Inbox, Sent, Draft, Trash, etc ) under your Thunderbird profile's with the import function under SimpleMail
3 - yes you can choose were you want to store your mails (even on a flash drive)

regards
Regards,
TechnalXS

WebVoyager
 
Posts: 160
Joined: November 20th, 2004, 4:58 am

Post Posted February 7th, 2013, 1:13 pm

OK, TechnalXS, thanks for this information.
I'm no longer here -- Cannot delete/close my profile -- Bye

TechnalXS

User avatar
 
Posts: 62
Joined: July 3rd, 2012, 11:10 am

Post Posted February 26th, 2013, 4:34 am

V2.84.2
- FIXED : Bug with Spam management
- FIXED : Refeshing mail :
-1 : No automatic refresh and no refresh clicking on refresh button, refresh only by clicking on account name
0 : No automatic refresh but refresh when clicking on refresh button and on account name
+10, +20 : Automatic refresh, when clicking on refresh button and on account name
- ADDED : Now, you can't add two addresses with the same email in the address book
- FIXED : Attach multiples files don't work
- ADDED : Popup when you send a mail
- ADDED : After send return to the SimpleMail window if multiples tabs
- FIXED : Bug with acknowledgements
Regards,
TechnalXS

marias

User avatar
 
Posts: 42
Joined: May 2nd, 2005, 5:46 am

Post Posted February 28th, 2013, 9:04 am

I've problems sending mails, if the e-mail has a big attachment. Sending e-mails with attachments about 200 kb - this works. But if I want to send an e-mail with an attachment of 2 MB then Simplemail is sending and sending and sending ... until I click Cancel. Then Simplemail said "Connection failed".

Greetings, Maria
Greetings, Maria!

kizernis
 
Posts: 2
Joined: March 6th, 2013, 4:08 am

Post Posted March 6th, 2013, 4:31 am

Hello. First of all, thank you very much for a great addon!
My complaint is when i send messages in plain text mode, they end up being received with this text at the end:
<div id="Signature"><div id="Text"></div></div>
That is even if showing messages in text-only mode is unchecked.
Btw, the warning of messages being sent/shown in plain text mode is a little annoying. I like using the plain text mode and wouldn't want to see those red warnings all the time. Could you please make them disableable? (what a word, hehe)

TechnalXS

User avatar
 
Posts: 62
Joined: July 3rd, 2012, 11:10 am

Post Posted March 13th, 2013, 10:28 am

@marias and @kiernis :

this is fixed in the 2.84.3Beta1 version available in the beta canal on AMO

Regards
Regards,
TechnalXS

miltyp
 
Posts: 3
Joined: March 10th, 2013, 1:57 pm

Post Posted March 13th, 2013, 10:31 am

I installed simple mail 2.84.2 for Firefox Mac 19.0.2,
and then observed that the Firefox Email Link tool no longer functioned.
So, I uninstalled simple mail with the goal that this would correct the situation.
It did not, and the Email Link function does not work.

Two questions:

1. Does installation of simple mail 2.84.2 disable Firefox 19.0.2's Email Link function, and continue to do so
even after the simple mail software is uninstalled?

2. If yes, is there a solution or fix for this problem that you can recommend so that I may act
upon it to resolve the issue?

Thank you for taking the time to lend your expertise to my problem.

miltyp

TechnalXS

User avatar
 
Posts: 62
Joined: July 3rd, 2012, 11:10 am

Post Posted March 13th, 2013, 12:47 pm

Hi,

what do you mean by " Firefox Email Link tool" ?

TechnalXS
Regards,
TechnalXS

JayhawksRock

User avatar
 
Posts: 10433
Joined: October 24th, 2010, 8:51 am

Post Posted March 13th, 2013, 1:03 pm

TechnalXS wrote:Hi,

what do you mean by " Firefox Email Link tool" ?

TechnalXS

Guessing the poster means Menubar > File > Email Link... (Windows) Mac may be similar.
"The trouble with quotes on the internet is you never know if they are genuine" ...Abraham Lincoln

miltyp
 
Posts: 3
Joined: March 10th, 2013, 1:57 pm

Post Posted March 13th, 2013, 3:11 pm

Indeed, in Firefox's Mac version 19.0.2, as well as numerous prior Firefox Mac
versions, a click on 'File,' drops down a menu which contains the option "Email Link;"
if Firefox is opened to a web page, and the user chooses to click on the option
"Email Link," then the link for the web address of the web page that
Firefox is opened to, will immediately bring up iMac's new mail form with the
form populated with the address to the web page and the subject line filled in
with a description of the contents of the web page. Then all you need do is
add text if you so desire, an email address and then click send.

As it stands now, I have three choices:

1. Use Safari, which has an elegant alternative but yields a similar result; yet I have been
raised with Firefox, which is my preference; or,

2. Copy the web address off of Firefox's address bar, go to the Mac's
Mail client, open a new mail form, and paste the link into the body of the email
and type in a description for the link; or,

3. Hopefully obtain a solution on this site, if it turns out that simple mail
was the cause of the loss of use of the "Email Link," as described in my
original post.

I hope this explanation helps to understand what I was intending on
writing originally.

miltyp

TechnalXS

User avatar
 
Posts: 62
Joined: July 3rd, 2012, 11:10 am

Post Posted March 14th, 2013, 2:21 am

Ok here a workaround:

- open FF
- in the address bar type "about:config".
- in the search bar type "mailto".
- change the value of the line "network.protocol-handler.expose.mailto" by "true".
- change the value of the line "network.protocol-handler.external.mailto" by "true".
- Ensure "network.protocol-handler.expose-all" is set to "true".
- close FF
- open FF, this should work

Regards
TechnalXS
Regards,
TechnalXS

miltyp
 
Posts: 3
Joined: March 10th, 2013, 1:57 pm

Post Posted March 14th, 2013, 6:56 am

Great TechnalXS!!

To the extent applicable, the instructions worked perfectly.
The reason I write, "extent applicable," is as a result of the
fact that my lines of code did not include "network.protocol-handler.expose-all".
However, I followed all the other lines of instruction, and, as I say,
those worked like a charm as the "Email Link," now functions as it had.

Thank you so very much for gifting your expertise, time and sustained attention to
what otherwise could have been a longstanding pain and most likely a never ending
time waster!

Continued success in all your endeavors.

miltyp

jaysonobado
 
Posts: 3
Joined: April 10th, 2013, 2:20 am

Post Posted April 10th, 2013, 2:22 am

i need help configuring this extension in my mail server. Im having a connection failed error. What does this mean. is my login information incorrect or my mail server setting is incorrect?

TechnalXS

User avatar
 
Posts: 62
Joined: July 3rd, 2012, 11:10 am

Post Posted April 10th, 2013, 3:21 am

hi,

which mail server?
POP or IMAP ?

Regards
Regards,
TechnalXS

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 4 guests