MozillaZine

[Ext] Simple Mail

Announce and Discuss the Latest Theme and Extension Releases.
Casm
 
Posts: 1
Joined: April 16th, 2014, 2:58 am

Post Posted April 16th, 2014, 3:11 am

TechnalXS
Hello! Thanks for a great extension. But could you optimize the settings window to work with a screen resolution of 1366x768?
Preferences window does not fit on the screen vertically.

lprobi
 
Posts: 9
Joined: August 21st, 2013, 7:38 am

Post Posted June 5th, 2014, 5:51 am

TechnalXs,
any chance that you guys are implementing signing and encryption of messages by GnuPG in simplemail? Imho a major feature, maybe the most needed feature, of all...

charlie6
 
Posts: 19
Joined: August 29th, 2013, 12:27 am

Post Posted June 11th, 2014, 12:30 am

Hi Technalxs,

just to mention that:
in case of selection of more than one contact whom to send a mail, among the SMs adressbook, their respective mail adresses are separated only by a comma in the «To» field:
example: youradress@you.net,hisadress@him.net,theiradress@them.net
Then SimpleMail sends only to the first contact; the others are ignored.

To effectively send the mail to all of the contacts, i use to manualy add a blank space between the comma and the mail adress
example: youradress@you.net, hisadress@him.net, theiradress@them.net

This would be a nice to have in the next update :D

In relation to a previous post related to the «Abook» use in conjunction with FF ans SM, several selected adresses inside Abook are directed to SM with the blank space already present.

HTH
thanks in advance
Charlie

Akira Erebos
 
Posts: 1
Joined: June 13th, 2014, 1:02 pm

Post Posted June 13th, 2014, 1:20 pm

Hi. TechnalXS.

Many thanks for your work.

I don't know if it is bug or lack of feature, but here it is:

When I use search/filter bar inside SimpleMail, it always search only inside messages and Subject. Never in "From".
So when I want find every mail from John Doe, it show only these mails, where is John Doe signature, or if it's Reply mail (and line "From: John Doe" is inside).

Is this bug or you choose this on purpose?

DramanIN
 
Posts: 2
Joined: December 13th, 2013, 12:04 pm

Post Posted July 4th, 2014, 2:35 pm

I got no answers last time, still, let's try it again.

- FFox 30.0a2 (2014-04-25)
- Simple Mail 2.86.6
- 3xgmail, 1xyandex, 2xonet, 3xwp, 1xinteria mail accounts

Problems:
- When net becomes a bit laggy (d/loads in the background), SM freezes in constant "refresh" loop - icon blinks on and off, there's no way to cancel it, it still continues to refresh mailboxes. Restarting Firefox helps.
- Occasionally SM is re-downloading all messages from all accounts and marking them as "unread". I'm suspecting it loses connection with its local mail folder.
- Yandex doesn't seem to work - (imap.yandex.com/SSL/993 | smtp.yandex.com/SSL/465) - SM "sends" the message, copies it to local "sent" folder, but it never arrives the recipient and there's no indication of message being sent when I'm accessing Yandex via WebUI.

Please help.
In addition: Is there a way to add a button that does HARD STOP - one click that forces SM to abandon current job? Once SM falls into loop, Cancel doesn't seem to work at all.

THANKS!

TechnalXS

User avatar
 
Posts: 62
Joined: July 3rd, 2012, 11:10 am

Post Posted July 6th, 2014, 2:20 am

@charlie6 : sending with or without space after coma works for me ... as well with a ; with or without space, but i see you're under Linux so let me some time to do a test under Linux

@akira : you're right, there is a mistake, i'll try to correct it for the next version

@DramanIN :
first point : it also happens to me for time to time but I can not figure out why ... still searching
Second point : that's really weird ... is this happening with IMAP or POP accounts ?
Third point : tried with imap.yandex.ru/SSL/993 | smtp.yandex.ru/SSL/465 AND imap.yandex.com/SSL/993 | smtp.yandex.com/SSL/465 and it works.
"there's no indication of message being sent when I'm accessing Yandex via WebUI." : for instance SM synchronize only inbox folder on server
Normally, cancel button should stop current job ... so it seems i have to dig in the code ...

Thanks to all,
I'll try to do my best to fix it all
Regards,
TechnalXS

TechnalXS

User avatar
 
Posts: 62
Joined: July 3rd, 2012, 11:10 am

Post Posted July 10th, 2014, 9:24 am

There is a new avalaible version 2.86.7Beta1 of simple Mail

V2.86.7
WARNING : This version is not compatible with Firefox versions below 16
- FIXED : Progress Meter stay after sent
- FIXED : Compatibility with Firefox 31-32
- FIXED : The search is performed on the fields to, from, cc and bcc

Enjoy
Regards,
TechnalXS

charlie6
 
Posts: 19
Joined: August 29th, 2013, 12:27 am

Post Posted July 12th, 2014, 1:00 am

Hi TechnalXS,
many thanks for 2.86.7 ! .... which i could not install ...on FF 26.0

i have:
- deleted the folder /root/.mozilla/firefox/xxxxxxx.default/ ... .phpnet.us
- went to the download page and did "add to firefox"
-restart FF;
SM2.86.7 does not open when clicking on the «enveloppe» icon in upper-right FF's window;
going in FF Main menu /Tools/Adds-on, and ther clicking on preferences, SM does not display the
existing encoded account datas. Re-encoding the acout parameters does not work neither (not possible to validate).

So i've deleted 2.86.7; and reloaded 2.86.6 the same way: 2.86.6 retrieved all existing encoded accounts and mail datas without fail.

HTH

Charlie

TechnalXS

User avatar
 
Posts: 62
Joined: July 3rd, 2012, 11:10 am

Post Posted July 12th, 2014, 2:01 am

Sometimes you have to restart FF twice ...
Regards,
TechnalXS

charlie6
 
Posts: 19
Joined: August 29th, 2013, 12:27 am

Post Posted July 13th, 2014, 12:15 pm

Hi Technalxs,
thansk for replying !
no success after restarting FF26.0 several times... :(
so i decided:
-1.uninstall SM 2.86.6;
-2.to update to FF30.0;
-3.reinstall SM2.86.7
and then bingo! SM 2.86.7 installs OK
Maybe that FF26.0 was somewhat corrupted ...what i couldn't have suspected ..
Greetings
Charlie

kbs1
 
Posts: 10
Joined: April 8th, 2011, 2:31 am

Post Posted July 29th, 2014, 7:27 am

May I ask how you fixed firefox 31-32 compatibility issue? I presume it was the popup menus not working, for example when typing email addresses, clicking on a suggestion does nothing. Plugin "secure login 1.0.3" that I use has the same issue, and I presume every other plugin will have this issue in newest firefox, sadly this plugin is no longer developed, so I'll need to fix it by hand. Any pointers on what changed would be great.

Thanks! :)

TechnalXS

User avatar
 
Posts: 62
Joined: July 3rd, 2012, 11:10 am

Post Posted July 29th, 2014, 7:44 am

Regards,
TechnalXS

kbs1
 
Posts: 10
Joined: April 8th, 2011, 2:31 am

Post Posted July 29th, 2014, 7:47 am

It's working, but I need to know how you fixed it in terms of code, because I need to fix the "Secure Login 1.0.3" extension, if you'd be so kind.

TechnalXS

User avatar
 
Posts: 62
Joined: July 3rd, 2012, 11:10 am

Post Posted July 30th, 2014, 11:14 am

Regards,
TechnalXS

Xyster77
 
Posts: 3
Joined: July 30th, 2014, 12:14 pm

Post Posted July 30th, 2014, 12:57 pm

Hi, I'm having problems using this plugin from when my Firefox updated recently and when I needed to update the plugin because of it.
At the moment I'm using Firefox 31.0 and Simple Mail 2.86.7Beta1.

Before I was using I think Simple Mail 2.83.

Everything works, but sometimes very slowly.

I have two e-mail accounts:

1. Gmail account where I use IMAP to access e-mail in Simple Mail. On that account I have almost 2000 e-mails remotly on Gmail server. Refresh of that e-mail account in Simple Mail takes very long, like 15 minutes, and during that time Firefox responds slowly. I have a feeling that Simple Mail each time downloads all those e-mails to compare if it already has them locally downloaded. Before the update of Simple Mail plugin this refresh took also 1-2 seconds, and if new e-mails were present they were downloaded by Simple Mail

2. Gmail account where I use IMAP to access e-mail in Simple Mail. On that account I usually have only few e-mails, since I also connect periodically with my other mail client that pulls the e-mails locally and doesn't leave them remotly on Gmail server. Refresh on that e-mail account in Simple Mail happens very quickly, maybe 1-2 seconds.
If I get many mails, and I don't download them locally with another e-mail client so they are no longer on Gmail servers, refresh in Simple Mail will also take longer and longer as number of mail grows, although I already have downloaded all those e-mails with Simple Mail.
Then if I download locally with another e-mail client all those e-mails, so they are no longer present on Gmail server and I try to refresh in Simple Mail refresh will again be done in 1-2 seconds.


I have been using Simple Mail for years now, and have always been satisfied.
If new update didn't work for, I would just use old version until a new version that works for me was released.
However, now I can't work with older versions anymore, because in new Firefox in older Simple Mail plugin when I write e-mail I cannot select e-mail reciever in To or CC field, but I must write it which really isn't usable.

Could you please help me to fix this problem, since as things stand now plugin is unsable for me since I slows down Firefox when its refreshing.

Thank you for your help.

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest