MozillaZine

[Ext] Simple Mail

Announce and Discuss the Latest Theme and Extension Releases.
OxeStone
 
Posts: 8
Joined: February 19th, 2015, 4:38 pm

Post Posted February 19th, 2015, 6:56 pm

I've been using 2.86.7 for since its beta version. The issue started a few days ago. What do you get for filename when you click on the save icon?

OxeStone
 
Posts: 8
Joined: February 19th, 2015, 4:38 pm

Post Posted February 22nd, 2015, 8:11 pm

Turned out to be a problem with FF profile. I reinstalled FF and Simple Mail is working again.

wtstsgalor
 
Posts: 12
Joined: August 19th, 2013, 6:02 pm

Post Posted March 7th, 2015, 1:27 pm

Re-downloading didn't work for me. I can't send at all. When I press the send icon, absolutely nothing happens.

Prior to my re-download, the entire browser would go black after sending a random email. I'd have to close down and re-open to make it work.

What can I do?

wtstsgalor
 
Posts: 12
Joined: August 19th, 2013, 6:02 pm

Post Posted March 7th, 2015, 1:49 pm

I just tried "refreshing" firefox. Now I can't find simplemail at all. How do I open it? I can put an email icon on the taskbar, but that only opens a composing window. Where are my folders with important saved messages?

p65
 
Posts: 2
Joined: December 3rd, 2004, 2:09 pm

Post Posted April 6th, 2015, 6:32 am

On my IMAP server I'm using a self-signed certificate. Simple Mail refuses to accept it. Is there a way to get it to accept?

Xyster77
 
Posts: 3
Joined: July 30th, 2014, 12:14 pm

Post Posted April 12th, 2015, 3:57 am

Xyster77 wrote:Everything works, but sometimes very slowly.

I have two e-mail accounts:

1. Gmail account where I use IMAP to access e-mail in Simple Mail. On that account I have almost 2000 e-mails remotly on Gmail server. Refresh of that e-mail account in Simple Mail takes very long, like 15 minutes, and during that time Firefox responds slowly. I have a feeling that Simple Mail each time downloads all those e-mails to compare if it already has them locally downloaded. Before the update of Simple Mail plugin this refresh took also 1-2 seconds, and if new e-mails were present they were downloaded by Simple Mail

2. Gmail account where I use IMAP to access e-mail in Simple Mail. On that account I usually have only few e-mails, since I also connect periodically with my other mail client that pulls the e-mails locally and doesn't leave them remotly on Gmail server. Refresh on that e-mail account in Simple Mail happens very quickly, maybe 1-2 seconds.
If I get many mails, and I don't download them locally with another e-mail client so they are no longer on Gmail servers, refresh in Simple Mail will also take longer and longer as number of mail grows, although I already have downloaded all those e-mails with Simple Mail.
Then if I download locally with another e-mail client all those e-mails, so they are no longer present on Gmail server and I try to refresh in Simple Mail refresh will again be done in 1-2 seconds.



If TechnalXS is still working on this add-on, I found solution to this problem.
The solution was to modify overlay.js by removing the folowing piece of code from getMail function:

if (account.pop3.isImap) {
var messages = technalxs.simplemail.SimpleMailOverlay.storage.getAccountMessages(account.id);
var flag = "";
var folder = "inbox";
technalxs.simplemail.SimpleMailOverlay.SynchroMail(account, messages, folder, flag);
}

Now there's no more problem of long synchronization when a lot of e-mails are present on IMAP server.

2048bit
 
Posts: 1
Joined: May 29th, 2015, 11:31 am

Post Posted May 29th, 2015, 11:46 am

Есть проблема, большая папка "Входящие" (>7000 писем), когда она активная, SM жутко тормозит.
There is a problem, most Inbox (>7000 letters) when it's active, SM is really slow.
---
Как отфильтровать и переместить "прочитанные" письма?
How to filter and move the "read" letters?
---
Возможно в будущем добавить автогруппировку с автоматическим созданием директорий {From} {To} {DATE} ... ?
Maybe in the future add auto group auto create directories {From} {To} {DATE} ... ?

---

Спасибо! :)
Thanks! :)

БлагоѨрѣ

User avatar
 
Posts: 7
Joined: July 17th, 2012, 12:11 pm
Location: Свѣтаѧ Рɣсь

Post Posted June 21st, 2015, 11:13 am

В настройках Firefox на вкладке "Приложения" выставил, чтобы mail:to открывались с помощью Thunderbird, но при нажатии на ссылку открывается SimpleMail. Можно ли оставить работающим SimpleMail, но чтобы ссылки открывались Thunderbird-ом?
"Паситесь мирные Народы! Вас не разбудит чести клич. К чему стадам дары свободы? Их должно резать или стричь. Наследство их из Рода в Роды — Ярмо с гремушками, да бич." А.С. Пушкин

vlakipn
 
Posts: 1
Joined: July 30th, 2015, 4:43 am

Post Posted July 30th, 2015, 4:45 am

Great addon, i use it, but i got problems, cant send any mails.
Im reciving everything without problem, but when i try to send mail nothing happens....

marias

User avatar
 
Posts: 42
Joined: May 2nd, 2005, 5:46 am

Post Posted March 21st, 2016, 10:42 am

Hello,

there is a new version of SimpleMail which works now with for Firefox 45 (but it's a bit tricky to find - you have to open "See complete versions history").

Version 2.86.8.1
https://addons.mozilla.org/en-US/firefo ... /versions/
Greetings, Maria!

БлагоѨрѣ

User avatar
 
Posts: 7
Joined: July 17th, 2012, 12:11 pm
Location: Свѣтаѧ Рɣсь

Post Posted March 21st, 2016, 10:56 am

vlakipn wrote:Great addon, i use it, but i got problems, cant send any mails.
Im reciving everything without problem, but when i try to send mail nothing happens....

I have the problem very long, so i want to do what to do :) (comment above)
"Паситесь мирные Народы! Вас не разбудит чести клич. К чему стадам дары свободы? Их должно резать или стричь. Наследство их из Рода в Роды — Ярмо с гремушками, да бич." А.С. Пушкин

chiaroscuro123
 
Posts: 7
Joined: September 9th, 2012, 8:08 pm

Post Posted April 4th, 2016, 1:38 am

There is now a Fully Reviewed Version of Simple Mail on AMO

Simple Mail Version 2.87

To download please go here

https://addons.mozilla.org/en-GB/firefo ... mple-mail/

Many thanks

chiaroscuro123
 
Posts: 7
Joined: September 9th, 2012, 8:08 pm

Post Posted April 9th, 2016, 8:54 am

Simple Mail Version 2.88 Fully Reviewed on AMO

To download please go here

https://addons.mozilla.org/en-us/firefo ... mple-mail/

Many thanks

chiaroscuro123
 
Posts: 7
Joined: September 9th, 2012, 8:08 pm

Post Posted April 19th, 2016, 11:44 am

Simple Mail Version 2.89 Fully Reviewed on AMO

To download please go here

https://addons.mozilla.org/en-us/firefo ... mple-mail/

Many thanks

charlie6
 
Posts: 19
Joined: August 29th, 2013, 12:27 am

Post Posted May 8th, 2016, 11:06 pm

Hi,
@chiaroscuro123: many thanks for the latest updates !
here using SM2.90 on FF 44.0.2 with two mail accounts.

On SM2.90 as also on earlier versions, i get the "connection failed" message using the second mail account (i.e. ntymail.com).
here is the log:
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
09-05-16 07:40:03 Client: Start connection

09-05-16 07:40:14 ERROR: Simple Mail : [webmail.ntymail.com:465,SSL] : échec de la connexion
09-05-16 07:40:19 Client: Start connection
09-05-16 07:40:19 Server: 220 webmail.ntymail.com

09-05-16 07:40:19 Client: EHLO puppypc13726
09-05-16 07:40:19 Server: 250-webmail.ntymail.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN


I have checked that all accounts settings conforms to the mail client recommendations .

Re-trying to send it a second time succeeds !
Here is the log of the second trial:

09-05-16 07:40:19 Client: AUTH LOGIN
09-05-16 07:40:19 Server: 334 VXNlcm5hbWU6

09-05-16 07:40:19 Client: YmFyZXdpbGx5c3BybEBudHltYWlsLmNvbQ==
09-05-16 07:40:19 Server: 334 UGFzc3dvcmQ6

09-05-16 07:40:19 Client: Y2FtaWxsZTEx
09-05-16 07:40:19 Server: 235 2.7.0 Authentication successful

09-05-16 07:40:19 Client: MAIL FROM:<mymail@ntymail.com>
09-05-16 07:40:19 Server: 250 2.1.0 Ok

09-05-16 07:40:19 Client: RCPT TO:<mycontact@blablibla.be>
09-05-16 07:40:19 Server: 250 2.1.5 Ok

09-05-16 07:40:19 Client: DATA
09-05-16 07:40:19 Server: 354 End data with <CR><LF>.<CR><LF>

09-05-16 07:40:19 Client: Date: Mon, 09 May 2016 07:40:19 +0200 (CEST)
Disposition-Notification-To: =?UTF-8?B?QkFSw4kgV2lsbHkgU1BSTA==?= <mymaill@ntymail.com>
From: =?UTF-8?B?QkFSw4kgV2lsbHkgU1BSTA==?= <mymail@ntymail.com>
User-Agent: Simple Mail V2.90
MIME-Version: 1.0
Reply-To: <mymail@ntymail.com>
To: ...
Subject: =?UTF-8?B?RndkOiBkZW1hbmRlIGRlIHByaXggY291cGUgcGxhdCA0MHgxMCBhY2llciBsYW1pbsOpIMOgIGNoYXVk?=
Content-Type: multipart/related;
boundary=----------simplemail1462772419117
...
------------simplemail1462772419117
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit
------------simplemail1462772419117--

.
09-05-16 07:40:19 Server: 250 2.0.0 Ok: queued as A34666397B

09-05-16 07:40:19 Client: QUIT
09-05-16 07:40:19 Server: 221 2.0.0 Bye


What could be wrong.
This does not happens using the first mail account.

Many thanks for any answer

Charlie

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest