MozillaZine

HeaderTools ( for TB ) ver 0.6.0 available

Announce and Discuss the Latest Theme and Extension Releases.
Old Ausdilecce
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 1st, 2006, 3:18 pm

Lol,

Last I heard, kangaroos are herbivores ( sp ?) ...


Very busy here, just have time to say I am alive and still want to maintain my extensions... just too few hours in the day, im afraid...

Lee, HeaderTools is a hack ( as you obviously found ).. It simply adds/removes/modifies individual header lines in the raw mbox data for that message, then copies that data back into the correct TB folder's mbox file.

I attempt to add inserted headers at the *end* of the headers list, NOT the top of the particular message
I assume this is where they *should* reside as all non-standard headers (ones with a "X-" prefix ) I have seen from Notes or Outlook etc produced messages are at the end of the headers list. I, of course, could be wrong..

Now, there *definately* should NOT be a blank line before the existing headers and the inserted header... That is *certainly* a bug that needs to be sqidged.

The code that performs this trick relies on certain assumptions about where headers start and end... The code sometimes fluffs this part and produces a badly constructed message. I *badly* want to fix this but I need examples of messages that if fluffs on ( the bug(s) are message specific

If you want, you ( and others ) can forward to me *unmolested* messages so I can use them as test cases..
Send them to ht_comments AT supportware DOT net

Lost User 183203
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 1st, 2006, 6:55 pm

So, if not a 'roo, a dingo, perhaps? :-) Actually, they're pretty skittish, at least from my experience... Maybe one of your oh so friendly snakes?

Anyway, glad to see you're still alive and kicking!!

I would just like to second hopchop's idea. My previous comment about the date limit is moot, at least for me, as I did the procedure described by hopchop the long way, and since that was my POP account I could then use your extension to change back to the original date. For me, the extension has otherwise been working fine and I love it for that account, so mucho thanks!!!

However, (there's always an however, eh?), my other account is IMAP, and I do so miss the ability to change the subject line... I could do it again 'manually', but then the date and sender change as well, and for some of the messages, I'd like to keep them in order, if not have the actual send date displayed. So perhaps a headers-lite version like hopchop suggested -- I know that IMAP is more (too?) complicated otherwise...

I know you're busy and so appreciate the work you've done so far -- this really is a useful extension!!!

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted February 1st, 2006, 8:10 pm

howdy ausdilecce,

[1] sample not-yet-munged emails
i will have those sent to ya soon. [*grin*] do you prefer the files as zipped EML files or as standard attachments?

-edit
sent exported mbox fies with JUST the specific emails in them.
lee-

[2] another related glitch
i found a worse glitch with text files that have NO attachment. the x-tags line shows up in the body of the msg! [*grin*]

[3] added header location
- tbird uses the x-mozilla-status and places those at the top of the headers.
- bugzilla places them between the SUBJECT: and TO: lines.
- avg antivirus places them immediately after the FROM: line. i suspect that it is actually placing the header at the very end of the header block as it's normally the last header before the blank line that marks the divider between the header block and the body of a text only msg with no attachments.

there doesn't seem to BE any standard on x-headers! [*grin*]

seems the only real requirement is that the header block contain NO blank lines. that appears to be the signal that the body of the msg will be starting on the next line IF there is no "boundary=" to define mime content boundaries.

perhaps you could look for the last 'x-" and add the new header line just before or after it. as long as no new blank lines were added, it otta work. well, you already know that ... never mind! [*grin*]

take care,
lee

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted February 2nd, 2006, 1:16 am

howdy ausdilecce,

tried several ways to send the requested email to ya. even the comments link on your site. got this back ...
*****
Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<[headertools-comments-email-address]>:
66.129.115.192 failed after I sent the message.
Remote host said: 552 Mail from HELO smtp101.sbc.mail.mud.yahoo.com rejected : does not accept bounces. This violates RFC 821/2505/2821 http://www.rfc-ignorant.org/
*****

i masked the email address, as you can tell. [*grin*] i have NO earthly idea why it thinks a bounce is involved.

take care,
lee

Old Ausdilecce
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 2nd, 2006, 1:19 pm

Lee, sending you a PM

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted February 2nd, 2006, 7:44 pm

howdy ausdilecce,

got your pm to me & sent a test email to the address in it. it's the same - i _think_ as the one i have been getting "bounce not allowed" notices from, so what i sent is just a test with a respond request.

sent at 8.29p us/cst and it's 8.43p now. hasn't been rejected & returned to me yet ... [*grin*]

take care,
lee

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted February 2nd, 2006, 11:29 pm

howdy ausdilecce,

well, the test email hasn't been returned, so i guess it made it thru! [*grin*]

your sample EML files are on the way ... and thanks again for the time and effort.

take care,
lee

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted February 3rd, 2006, 1:48 am

howdy ausdilecce,

well, bloody damn ... got that msg again. using the email address copied via rt-clk from your pm to me, i sent a text-only test email asking for a response back if it got thru.

took a long time, but it's been returned. lookee ...
*****
Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<[headertools-comments-email-address]>:
66.129.115.192 failed after I sent the message.
Remote host said: 552 Mail from HELO smtp101.sbc.mail.mud.yahoo.com rejected : does not accept bounces. This violates RFC 821/2505/2821 http://www.rfc-ignorant.org/

--- Below this line is a copy of the message.
*****

it SEEMS like your email server is rejecting the emails form my server at "smtp101.sbc.mail.mud.yahoo.com" because yours doesn't accept bounces. why does it think my msg is a bounce? are you using one of the automated black hole lists?

take care,
lee

Old Ausdilecce
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 5th, 2006, 3:46 pm

Just FYI,

I had a ( very ) small window of free time and have looked at the code today..

It looks like the original code was a bit error prone ( a bit ? just a BIT ? lol )

I have re worked the code to allow for more consistant behavior and, I am happy to report, better IMAP support.

I will be uploading the new version (0.5.0 ) in about an hour..

I need all hands on deck to test right now since I dont have *any* free time over the next 6 days

Cheers

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted February 5th, 2006, 11:05 pm

howdy ausdilecce,

i surely understand "real life" taking precedence over unpaid fireox extension work ... [*grin*] will wait for the next version.

one SMALL suggestion that i know most ext authors dislike. would you please post your extension with a version number in the file name? yes, i realize it makes for more work on your end, so i understand why you may not do it. versioning the FILE helps reduce install fubars on the part of users like me.

take care,
lee

Old Ausdilecce
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 6th, 2006, 12:07 am

The extension is on the site now

www.supportware.net/mozilla/HeaderTools050.xpi

TobyK
 
Posts: 103
Joined: December 4th, 2004, 12:32 am

Post Posted February 6th, 2006, 1:00 am

Great! It works again without problems on my system! Thanks ausdilecce.

Lee_Dailey

User avatar
 
Posts: 14194
Joined: July 27th, 2004, 4:33 pm
Location: milky way galaxy, sol system, terra, north america, usa, tx, bedford

Post Posted February 6th, 2006, 1:10 am

howdy ausdilecce,

tested it. works just spiffy! thanks ...

i use both a plaintext msgs WITH an attachment and one without - both worked fine. also the two-step test - adding one value, closing & reopening htools and adding a 2nd value to the same header - and that worked properly, too.

very VERY nice! thanks!

when you get less busy, i will nag you about this ...
http://forums.mozillazine.org/viewtopic ... 47#2017747

hope all goes well with your work!

take care,
lee

Old Ausdilecce
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 6th, 2006, 1:28 pm

Just quickly..

Looked at your link and corresponding request... Looks doable...

Patience, my friend

zyzzyvas

User avatar
 
Posts: 16
Joined: February 3rd, 2006, 10:57 pm

Post Posted February 6th, 2006, 7:28 pm

I have just found your extension and have installed your latest version (0.5.0). Excellent work...you are tantalizingly close to perfection. The only quirks that really bother me are:

-For any message...modifying a message with a label/colour clears the label
-Also for IMAP messages...modifying a "replied" message clears the replied status

This is w/ TB 1.5.0.1 with some local folders, but primarily IMAP via a UW-IMAP server using mbox format.

Lee_Dailey's suggestion of a shortcut button on the toolbar is excellent...I want it!

*MY* wild suggestion? Why not allow us to edit the raw contents of the message? I migrated from Eudora where I could freely edit any message, which was great for adding longer notes about actions taken, highlighting sections (if it was HTML), making corrections to addresses or phone numbers in order emails, etc.

...since we're already hacking at the message, shouldn't we be able to edit its content?

Thanks, Kris

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 6 guests