MozillaZine

[Theme] Firefox 3 theme for SeaMonkey

Announce and Discuss the Latest Theme and Extension Releases.
jez

User avatar
 
Posts: 119
Joined: October 16th, 2003, 1:20 am

Post Posted April 15th, 2014, 7:43 am

This theme pretty much does what it says on the tin; styles SeaMonkey to look like Firefox 3.

Its AMO page is here: https://addons.mozilla.org/en-US/seamon ... r-seamonk/
And the homepage with a bit more detail: http://gooeysoftware.com/mozaddons/ff3sm/
== Jez ==

sothron
 
Posts: 19
Joined: April 30th, 2014, 9:14 am

Post Posted April 30th, 2014, 9:20 am

I am finally having to give up on Firefox after all the extensions and add ons that I had to make it look like FF3 are now no longer working thanks to FF 29.

I am enjoying this theme but I am having a problem that I can't figure out how to fix:

When I look at the seamonkey icon on the taskbar on the bottom of my screen instead of having one small preview window open for the seamonkey browser it instead gives me an extended preview that lists every single tab I have open. How can I shrink that to just one preview window? I alt tab quite often while gaming and I don't need every tab on seamonkey browser to be previewed on the taskbar.

jez

User avatar
 
Posts: 119
Joined: October 16th, 2003, 1:20 am

Post Posted April 30th, 2014, 10:53 am

sothron wrote:I am finally having to give up on Firefox after all the extensions and add ons that I had to make it look like FF3 are now no longer working thanks to FF 29.

I am enjoying this theme but I am having a problem that I can't figure out how to fix:

When I look at the seamonkey icon on the taskbar on the bottom of my screen instead of having one small preview window open for the seamonkey browser it instead gives me an extended preview that lists every single tab I have open. How can I shrink that to just one preview window? I alt tab quite often while gaming and I don't need every tab on seamonkey browser to be previewed on the taskbar.

I think I faced the exact same problem as you. Download my MonkeyFix extension, and go into its main options dialog. Go to the "Tab behaviour" section, and uncheck "Enable taskbar preview-per-tab". That should fix it.
== Jez ==

sothron
 
Posts: 19
Joined: April 30th, 2014, 9:14 am

Post Posted April 30th, 2014, 11:10 am

jez wrote:
sothron wrote:I am finally having to give up on Firefox after all the extensions and add ons that I had to make it look like FF3 are now no longer working thanks to FF 29.

I am enjoying this theme but I am having a problem that I can't figure out how to fix:

When I look at the seamonkey icon on the taskbar on the bottom of my screen instead of having one small preview window open for the seamonkey browser it instead gives me an extended preview that lists every single tab I have open. How can I shrink that to just one preview window? I alt tab quite often while gaming and I don't need every tab on seamonkey browser to be previewed on the taskbar.

I think I faced the exact same problem as you. Download my MonkeyFix extension, and go into its main options dialog. Go to the "Tab behaviour" section, and uncheck "Enable taskbar preview-per-tab". That should fix it.


That did the trick! Thanks so much.

Now if I can figure out how to get yahoo and norton toolbars to work on this browser...
Last edited by sothron on April 30th, 2014, 11:18 am, edited 1 time in total.

jez

User avatar
 
Posts: 119
Joined: October 16th, 2003, 1:20 am

Post Posted April 30th, 2014, 11:13 am

sothron wrote:When I open MonkeyFix and uncheck that option I can not get it to accept the change because I'm assuming there is an "Accept" or "Ok" toggle at the bottom but it is cut off on my resolution. Is there a way to uncheck the box and use a keyboard shortcut to get it to save the change?

If the "Enable taskbar preview-per-tab" checkbox is selected, tab-tab-enter should select and click the OK button.
== Jez ==

jay.slovak
 
Posts: 6
Joined: June 3rd, 2014, 12:21 pm

Post Posted June 3rd, 2014, 12:54 pm

First of all, I love this theme! It is the reason I switched from Firefox to SeaMonkey.

I am just having one issue with it on Windows 7 and Linux Mint 17. Every time I start the browser it will disregard my setting to show "Icons + Text" on toolbars and instead it shows the following on Windows:

Image

Notice that the setting is changed to "Icons" only and that the toolbar row is looking strange with some icons having the text below and some on the side. This can be temporarily fixed by selecting "Icons + text" again, but this lasts only until next start.

When I do the same on Linux, it just shows the Icons only (again after I changed it to show Icons and Text in previous session):

Image

Could this be fixed?

Thanks!

patrickjdempsey

User avatar
 
Posts: 23734
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted June 3rd, 2014, 1:12 pm

jay.slovak, I notice you are using SeaFox... this is probably a fault with my extension, would you mind posting over here:
viewtopic.php?f=19&t=2734625

Edit: nevermind... a closer read this does sound like a theme issue. I also see horizontal text on all non-menu toolbarbuttons.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

patrickjdempsey

User avatar
 
Posts: 23734
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted June 3rd, 2014, 1:43 pm

jez, in the Default Theme, this line in communicator/buttons.css makes the toolbarbuttons vertical:

Code: Select all
.toolbarbutton-1,
.toolbarbutton-1 > .toolbarbutton-menubutton-button {
  min-width: 47px;
  -moz-box-orient: vertical;
}


You have this instead:

Code: Select all
window:not([sizemode="fullscreen"]) toolbox[mode="full"] toolbar:not([labelalign="end"]) .toolbarbutton-1,
window:not([sizemode="fullscreen"]) toolbox[mode="full"] toolbar:not([labelalign="end"]) .toolbarbutton-1 > .toolbarbutton-menubutton-button {
  min-width: 57px;
  -moz-box-orient: vertical;
}


The problem appears to be related to the section " toolbox[mode="full"] " as there is currently a bug in SeaMonkey where the toolbox isn't properly updating the icons mode. If you remove the "toolbox" stuff and shift it to the "toolbar" it should work:

window:not([sizemode="fullscreen"]) toolbar:[mode="full"]not([labelalign="end"]) .toolbarbutton-1,

Likewise, it's possible that your issue on Linux is related to observing the toolbox[mode] instead of the toolbar[mode].
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

jez

User avatar
 
Posts: 119
Joined: October 16th, 2003, 1:20 am

Post Posted June 3rd, 2014, 2:26 pm

jay.slovak wrote:First of all, I love this theme! It is the reason I switched from Firefox to SeaMonkey.

I am just having one issue with it on Windows 7 and Linux Mint 17. Every time I start the browser it will disregard my setting to show "Icons + Text" on toolbars and instead it shows the following on Windows:

I can't seem to reproduce this bug. What version of SeaMonkey are you using?
== Jez ==

jay.slovak
 
Posts: 6
Joined: June 3rd, 2014, 12:21 pm

Post Posted June 3rd, 2014, 2:42 pm

Thanks, but this made my problem worse. Now it is showing the messed-up layout permanently, even after I change the layout to "Icons + Text". :(

Code: Select all
/* ::::: large toolbar buttons ::::: */

window:not([sizemode="fullscreen"]) toolbar:[mode="full"]not([labelalign="end"]) .toolbarbutton-1,
window:not([sizemode="fullscreen"]) toolbar:[mode="full"]not([labelalign="end"]) .toolbarbutton-1 > .toolbarbutton-menubutton-button {
  min-width: 57px;
  -moz-box-orient: vertical;
}

jay.slovak
 
Posts: 6
Joined: June 3rd, 2014, 12:21 pm

Post Posted June 3rd, 2014, 2:45 pm

jez wrote:
jay.slovak wrote:First of all, I love this theme! It is the reason I switched from Firefox to SeaMonkey.

I am just having one issue with it on Windows 7 and Linux Mint 17. Every time I start the browser it will disregard my setting to show "Icons + Text" on toolbars and instead it shows the following on Windows:

I can't seem to reproduce this bug. What version of SeaMonkey are you using?


SeaMonkey 2.26
Firefox 3 theme 1.2.2
Sea Fox 0.2.4
MonkeyFix 1.0.3

patrickjdempsey

User avatar
 
Posts: 23734
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted June 3rd, 2014, 3:01 pm

Opps! copy/paste error, I put the : in the wrong spot:

Code: Select all
window:not([sizemode="fullscreen"]) toolbar[mode="full"]:not([labelalign="end"]) .toolbarbutton-1,
window:not([sizemode="fullscreen"]) toolbar[mode="full"]:not([labelalign="end"]) .toolbarbutton-1 > .toolbarbutton-menubutton-button {
  min-width: 57px;
  -moz-box-orient: vertical;
}
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

jay.slovak
 
Posts: 6
Joined: June 3rd, 2014, 12:21 pm

Post Posted June 4th, 2014, 12:09 am

Awesome, now it is working as expected! Can you upstream this patch so that I won't have to fix this by hand every time there is an update?

BTW I have discovered that the Mint toolbar issue is not caused by your theme as it is also manifesting itself with the default one. I guess I will have to file a bug on Mint/SeaMonkey bug trackers.

Thanks!

jez

User avatar
 
Posts: 119
Joined: October 16th, 2003, 1:20 am

Post Posted June 4th, 2014, 12:48 am

Eh? I don't even understand what the 'patch' is.
== Jez ==

jay.slovak
 
Posts: 6
Joined: June 3rd, 2014, 12:21 pm

Post Posted June 4th, 2014, 1:32 am

jez wrote:Eh? I don't even understand what the 'patch' is.


I was asking if you could make the change Patrick has proposed in the xpi package that is distributed via Mozilla addons site.

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest