MozillaZine

[EXT] S3.Google Translator

Announce and Discuss the Latest Theme and Extension Releases.
pag77
 
Posts: 1259
Joined: December 26th, 2013, 10:46 pm

Post Posted May 4th, 2017, 9:25 am

Such error occurs when you make a translation of the full page
Click "forget the translation ebay" or in the settings click "clear history of translated sites"

verichip
 
Posts: 2
Joined: May 4th, 2017, 8:36 am

Post Posted May 4th, 2017, 2:56 pm

Thank you pag77, it works!

JOJ0
 
Posts: 75
Joined: November 13th, 2006, 11:33 pm

Post Posted May 5th, 2017, 11:21 pm

Pag77 any updates on webextension version. The addon got disabled in the latest nightlies.

pag77
 
Posts: 1259
Joined: December 26th, 2013, 10:46 pm

Post Posted May 7th, 2017, 1:34 am

JOJ0 wrote:Pag77 any updates on webextension version. The addon got disabled in the latest nightlies.


Image

Image

https://wiki.mozilla.org/Add-ons/ShimsNightly
This restriction is reversible. To do so go to about:config, look for the setting:
extensions.allow-non-mpc-extensions
...and set it to true.


Image

Image

Image

JOJ0
 
Posts: 75
Joined: November 13th, 2006, 11:33 pm

Post Posted May 7th, 2017, 3:50 am

thank you but i was looking for different information :)

pag77
 
Posts: 1259
Joined: December 26th, 2013, 10:46 pm

Post Posted May 7th, 2017, 9:04 am

The administration of the Mozilla allowed the authors not to suffer with multiprocessing, which would free up the time for porting add-ons to WebExtensions:
This means that developers who haven’t set this flag don’t have to worry about multiprocess compatibility and can focus on WebExtensions and the Firefox 57 deadline.

https://blog.mozilla.org/addons/2017/03/27/update-compatibility-milestones/

pag77
 
Posts: 1259
Joined: December 26th, 2013, 10:46 pm

Post Posted June 3rd, 2017, 1:57 am

version 5.32
https://addons.mozilla.org/addon/s3google-translator/

changes:
added:Migrating to WebExtensions: port your stored data
added: "Ctrl+Enter" combination for translating "text-from" in fly-window
updated: French locale (thanks Jack Black)
updated: Slovak locale (thanks J.P. alias Brahma)
fixed: minor bug fixes

SergeGardien
 
Posts: 49
Joined: November 21st, 2013, 4:22 pm

Post Posted July 4th, 2017, 12:38 pm

By reading the posts in this thread I understand that S3.Google Translator is capable of automatically translate a website in English without any input whatsoever from the user.
Still I haven't been able to achieve this.
I've just installed the addon and changed the settings in "Options" => "Translate" => I've selected "Automatic detection and translation (experimental, only for HTTP)" but nothing happens whenever I visit a non-English website.
Do you have any idea how I can obtain that?

[UPDATE-1] I've realized the auto-translation is quite random because it translate websites in Italian language even tough that's the only language I've deselected from the available languages list.
[UPDATE-2] The issue is partially caused by my use of the "No Script" addon which probably goes into conflict with S3.Google Translator. I've disabled No Script and the auto-translation is activated more often. Any advice in how to configure "No Script" to let it work peacefully with S3.Google Translator is very much appreciated. Here is a further post I've sent to the No Script official support forum: https://forums.informaction.com/viewtopic.php?f=7&t=23049

pag77
 
Posts: 1259
Joined: December 26th, 2013, 10:46 pm

Post Posted July 5th, 2017, 11:14 am

SergeGardien wrote:[UPDATE-2] The issue is partially caused by my use of the "No Script" addon which probably goes into conflict with S3.Google Translator. I've disabled No Script and the auto-translation is activated more often. Any advice in how to configure "No Script" to let it work peacefully with S3.Google Translator is very much appreciated.


add to NoScript-WhiteList: translate.google.com and translate.googleapis.com

SergeGardien
 
Posts: 49
Joined: November 21st, 2013, 4:22 pm

Post Posted July 5th, 2017, 2:35 pm

pag77 wrote:
SergeGardien wrote:[UPDATE-2] The issue is partially caused by my use of the "No Script" addon which probably goes into conflict with S3.Google Translator. I've disabled No Script and the auto-translation is activated more often. Any advice in how to configure "No Script" to let it work peacefully with S3.Google Translator is very much appreciated.


add to NoScript-WhiteList: translate.google.com and translate.googleapis.com


That was already done even before installing S3.Google Translator.
Still, thanks for telling.

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 2 guests