MozillaZine

[Support] - FEBE (et al.) alternate support thread

Announce and Discuss the Latest Theme and Extension Releases.
anon42
 
Posts: 277
Joined: December 1st, 2005, 12:07 am

Post Posted November 15th, 2016, 1:01 pm

Shadoefax wrote:There was a deprecation in Fx v48 XPCOM that made the update necessary. FEBE v8.9x will not work correctly in any pre-v49 Fx versions.

Huh? All the 8.9's for FF48x or just the ones starting with 8.9.3? At least now I know I can stop checking for updates. But that statement I quoted above confuses me as to whether I should even keep FEBE 8.9.2.

Anyway, thanks for the info.

Shadoefax

User avatar
 
Posts: 426
Joined: April 29th, 2005, 2:59 pm
Location: Glendale, AZ

Post Posted November 15th, 2016, 2:33 pm

Hmm ... I don't think I wrote that right (it was very early this morning and I was in a rush to get to work at my day-job).

For Fx 44 to Fx 48, use FEBE 8.9.2. For Fx 49 and higher, use FEBE 8.9.3.1. Don't use FEBE 8.9.3 for anything at all.
All my signatures are stolen from other people. Including this one.
Homepage

anon42
 
Posts: 277
Joined: December 1st, 2005, 12:07 am

Post Posted November 15th, 2016, 10:03 pm

Ah, ok. Just needed to make sure. Thanks.

avada
 
Posts: 1431
Joined: February 10th, 2008, 6:30 am
Location: Hungary

Post Posted November 16th, 2016, 2:34 am

Shadoefax wrote:Don't use FEBE 8.9.3 for anything at all.

If so, you could remove it from AMO, so that no-one would install it.

Shadoefax

User avatar
 
Posts: 426
Joined: April 29th, 2005, 2:59 pm
Location: Glendale, AZ

Post Posted November 16th, 2016, 2:24 pm

FEBE v8.9.3 has been removed from AMO.
All my signatures are stolen from other people. Including this one.
Homepage

unbeleevabull
 
Posts: 49
Joined: August 4th, 2014, 10:02 pm

Post Posted November 20th, 2016, 12:55 pm

I'm using an older version (8.3.1) in Waterfox 50, and it's working.

In the popup on hover in FEBE results page, any chance of adding min and max version #s? I know some extensions include min and max numbers for SM and TB, but I'd settle for just seeing FF ver.

P.S. border-width: 100% gives error (in console), but maybe that's already fixed

mapsonx
 
Posts: 5
Joined: April 13th, 2016, 1:45 pm

Post Posted November 25th, 2016, 4:29 pm

Sorry, should have read the faqs first. I think my questions werer answered. If not, I'll be back.

thx

Shadoefax

User avatar
 
Posts: 426
Joined: April 29th, 2005, 2:59 pm
Location: Glendale, AZ

Post Posted November 25th, 2016, 6:52 pm

unbeleevabull wrote:
In the popup on hover in FEBE results page, any chance of adding min and max version #s? I know some extensions include min and max numbers for SM and TB, but I'd settle for just seeing FF ver.


Good idea, but I will not be making any major changes to FEBE until Fx finally deprecates XUL and XPCOM. At that time, FEBE will work only with Fx clones (like Pale Moon, Waterfox, etc.) that still support XUL and XPCOM.

It looks like this deprecation will come to fruition by the end of 2017 and then only WebExtensions will be supported.
All my signatures are stolen from other people. Including this one.
Homepage

gordonfreeman
 
Posts: 2
Joined: December 4th, 2016, 9:48 am

Post Posted December 4th, 2016, 10:02 am

Hi Chuck,

As I cannot register on the official forums I am posting this support request here:
I am using Firefox 50.0.2 and FEBE 8.9.3.1 and when attempting to restore a full profile, the sliding message where I need to click OK to proceed after clicking on "start restore" only shows up after I close the window where I set up the restore (which does not do anything after setting the parameters and clicking on start restore). Any help would be appreciated as manually restoring by unzipping my profile backup and starting into that newly created profile from FEBE isn't working either (FF is starting as a blank profile).

Shadoefax

User avatar
 
Posts: 426
Joined: April 29th, 2005, 2:59 pm
Location: Glendale, AZ

Post Posted December 4th, 2016, 3:48 pm

What folder are you trying to manually restore into? It should be something like C:\Users\cbake\AppData\Roaming\Mozilla\Firefox\Profiles\7y8ys3cu.default
All my signatures are stolen from other people. Including this one.
Homepage

gordonfreeman
 
Posts: 2
Joined: December 4th, 2016, 9:48 am

Post Posted December 12th, 2016, 12:10 pm

I extracted it to:
C:\Users\USER\AppData\Roaming\Mozilla\Firefox\Profiles\febeprof.USER

I noticed one thing though:
On my original profile in a separate Firefox installation there was a corrupted extensions registry seemingly after the full profile+extensions backup which was done around the time of an automatic update to FF 50.0.2 (from 50.0.0). The extensions oddly did not all backup individually but the full profile backup seemed fine. I fixed the original profile which was asking to reinstall all my 30+ addons by deleting extensions.* files in the profile and manually extracting the profile data from my FEBE full profile backup (source of fix here https://support.mozilla.org/en-US/questions/1089955).

I therefore tried another manual extraction on the target restore profile and did the same fix procedure. Positive result: session data restore is working (tabs all there), problem though is it is still asking me to reinstall all my addons even with the earlier fix pre-applied.

I will try again with a fresh backup of my original fixed profile and report back.

Shadoefax

User avatar
 
Posts: 426
Joined: April 29th, 2005, 2:59 pm
Location: Glendale, AZ

Post Posted December 12th, 2016, 4:29 pm

Note that removing extensions.* (i.e., extensions.ini, extensions.json, extensions.log, extensions.rdf, extensions.sqlite only removes information about your installed extensions, not the extensions themselves. The actual add-ons are stored in the extensions subdirectory of your profile folder.
All my signatures are stolen from other people. Including this one.
Homepage

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest