MozillaZine

[Ext] uBlock Origin

Announce and Discuss the Latest Theme and Extension Releases.
gorhill
 
Posts: 161
Joined: February 10th, 2015, 8:00 am

Post Posted July 25th, 2017, 7:57 am

Brummelchen wrote:he wrote earlier the uBo currently is a hybrid. if you want it right now as a true WE the go to chrome store.

Yes, it's hybrid, and yet it's a true webext extension, no need to go to the Chrome store. As said in the documentation, the hybrid part is a thin layer of code used solely for the migration of data from legacy uBO, executed only once at first install. After this first install, uBO functions completely as a pure webext extension.

GHM113

User avatar
 
Posts: 697
Joined: December 16th, 2015, 3:59 am
Location: Moscow, Russia

Post Posted July 25th, 2017, 10:37 am

Brummelchen wrote:he wrote earlier the uBo currently is a hybrid. if you want it right now as a true WE the go to chrome store.

Thank you but I was talking about uMatrix :?: I know it is uBO thread but it is not worth creating a new thread for a single question.
gorhill wrote:Yes, it's hybrid, and yet it's a true webext extension, no need to go to the Chrome store. As said in the documentation, the hybrid part is a thin layer of code used solely for the migration of data from legacy uBO, executed only once at first install. After this first install, uBO functions completely as a pure webext extension.

That means latest uBO beta from AMO runs in a separate WebExtension process after data migration?
Sorry for my poor English.

Brummelchen
 
Posts: 4616
Joined: March 19th, 2005, 10:51 am

Post Posted July 25th, 2017, 3:10 pm

oh, sorry, this topic -> "[Ext] uBlock Origin", not uMatrix - please open a new case.
uM is also availabe as a webextension in chrome store so i think it may be available for firefox.
i dont use it since ages, to much administrative work beside uBlock without any advantage for me.
After this first install, uBO functions completely as a pure webext extension.

thank you i thought it was a needed layer around the webextension.

GµårÐïåñ

User avatar
 
Posts: 218
Joined: March 26th, 2008, 1:43 pm
Location: Area 51.2

Post Posted July 25th, 2017, 5:27 pm

Brummelchen wrote:oh, sorry, this topic -> "[Ext] uBlock Origin", not uMatrix - please open a new case.

That is not your call to make, if the developer wishes to admonish for posting here, that is his right, not yours. Especially that the user clearly explained his reasoning and acknowledged he knows it is not related to this thread; but why they posted anyway. No need to beat a dead horse.

So please keep your comments limited to helpful contributions and let the administration of the support thread stay with the developers; especially since you were clearly misinformed in your reply earlier.
Lï£ê ï§ å Lêmðñ åñÐ Ì Wåñ† M¥ Mðñê¥ ßå¢k

toolong
 
Posts: 913
Joined: December 24th, 2011, 10:29 am

Post Posted July 25th, 2017, 5:42 pm

Hot Dang!! A "urinating" contest!! :-)

Everyone please chill-out. Stuff happens. And most of us don't care until it gets really bad.

Brummelchen
 
Posts: 4616
Joined: March 19th, 2005, 10:51 am

Post Posted July 26th, 2017, 8:18 am

@Guardion - you may be right. ofc we speak here also in conjuction to uMatrix i never really saw a special question to it, however. as you can read my first answer to you i considered ublock and not umatrix.

the next - this is what i have in mind:
https://developer.mozilla.org/en-US/Add ... Extensions
legacy encapsules webetxtension

although raymond explained it here
https://github.com/gorhill/uBlock/wiki/ ... Extensions
i assumed a shared data or because communication path in picture.

i am not running uBlock as experimental webext. should have been the clue for me.

i do not worry not anything, my experience is that if one ask oftopic others will follow and a mix upped thread might not helpful, it was not my intention to force you to anything. sorry.

gorhill
 
Posts: 161
Joined: February 10th, 2015, 8:00 am

Post Posted July 26th, 2017, 9:30 am

GHM113 wrote:That means latest uBO beta from AMO runs in a separate WebExtension process after data migration?

I am pretty sure that is the case if you set "extensions.webextensions.remote" to "true" in about:config (I have not done this myself yet). A user submitted profiling results in which I could see uBO/webext was in a separate process.

ChewInternetExplorer

User avatar
 
Posts: 63
Joined: April 7th, 2011, 10:14 am

Post Posted July 26th, 2017, 11:11 pm

Am I the only one seeing this dysfunctional uBlock GUI on the latest 1.13.9b2?

    Image

GHM113

User avatar
 
Posts: 697
Joined: December 16th, 2015, 3:59 am
Location: Moscow, Russia

Post Posted July 27th, 2017, 1:32 am

ChewInternetExplorer wrote:Am I the only one seeing this dysfunctional uBlock GUI on the latest 1.13.9b2

WFM.
Sorry for my poor English.

ChewInternetExplorer

User avatar
 
Posts: 63
Joined: April 7th, 2011, 10:14 am

Post Posted July 27th, 2017, 1:45 am

Thanks for the confirmation — when I downgrade to the stable uBlock 1.13.8, it works fine . . . . . strange. :?

gorhill
 
Posts: 161
Joined: February 10th, 2015, 8:00 am

Post Posted July 27th, 2017, 5:00 am

ChewInternetExplorer wrote:Am I the only one seeing this dysfunctional uBlock GUI on the latest 1.13.9b2?

Your symptom (unpopulated popup panel) is the same as what was happening with issue 2824.

Did you uncheck "Accept cookies from sites"?

ChewInternetExplorer

User avatar
 
Posts: 63
Joined: April 7th, 2011, 10:14 am

Post Posted July 27th, 2017, 5:11 am

As a matter of fact, yes! :)

We just enforced a blanket cookie blocking policy, 48 hours ago (the connection between the two just didn't cross my mind.).

gorhill
 
Posts: 161
Joined: February 10th, 2015, 8:00 am

Post Posted July 27th, 2017, 5:59 am

ChewInternetExplorer wrote:As a matter of fact, yes! :)

Issue is fixed in 1.13.9b3, available now in dev channel on AMO.

ChewInternetExplorer

User avatar
 
Posts: 63
Joined: April 7th, 2011, 10:14 am

Post Posted July 27th, 2017, 6:17 am

Oh yes, confirmed — issue is resolved. Image

I'm back on the beta channel.

SSweeorgch
 
Posts: 31
Joined: December 4th, 2013, 9:13 pm

Post Posted July 27th, 2017, 9:06 pm

Using 1.13.9b3, latest Nightly, and gfx.webrender.enabled = true, the uBlock panel shows as a complete blank. Toggle to gfx.webrender.enabled = false and restart and it works as expected.

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest