MozillaZine

[Ext] Gmail Manager 0.6.4.1 - Manage multiple Gmail accounts

Announce and Discuss the Latest Theme and Extension Releases.
iHastr

User avatar
 
Posts: 34
Joined: March 8th, 2010, 6:42 am
Location: RU

Post Posted November 6th, 2010, 3:45 am

Hi!

I slightly modified the addon by Mook to support Firefox 4.
http://www.multiupload.com/MW8Q4Z1R12

As you know, in Firefox 4 no status bar :( But thanks to an addon Status-4-Evar, could make friends Firefox 4 and Gmail Manager 0.6.1 by Mook (account settings configured to show the icon in the addon-bar).

It works fine on Mozilla FireFox 4.0 Beta 7. Snippets are also working!

Image
Last edited by iHastr on November 12th, 2010, 7:07 am, edited 2 times in total.

brand404

User avatar
 
Posts: 63
Joined: April 25th, 2010, 5:03 am

Post Posted November 6th, 2010, 6:16 am

CAL-123 wrote:Works!! Gmail Notifier 'notifies' me of new mail...and then I can hover over Gmail Manager's Icon and see the snippits. No conflicts that I can see. Better than nothing!

:D


Very surprised it isnt working for you comletely. I've used Notifier and find it annoyingly useless which is why i've been waiting on a fix on GMM....so far i only need the mook update and nothing more... i never had Notifier running alongside GMM so maybe try disabling it and see if GMM works with the unread count.

Other things...make sure you are using "Standard" view mode (not basic HTML) and "Turn off Buzz". These two things i know cause issues with the mook GMM version.

Besides those i can defintiely say it is a setting in GMail itself that is causing the problem for you. It might also be a unique Labs add-on within Gmail that you enabled. I've tried Priority Mail and it works fine in mook's update. I am using the latest firefox (3.6.12) in Windows 7

brand404

User avatar
 
Posts: 63
Joined: April 25th, 2010, 5:03 am

Post Posted November 6th, 2010, 6:19 am

relish1 wrote:brand404- thanks for your mail

I installed Mook's version, now it takes few minutes to connect and still gets the count on 0 (though I have snippets).
On my other account it works great, but that's the same problem I had on 0.6.1.
Something probably on my gmail settings is doing all this troubles, and I can't figure out what...
Appreciate your help!


Read my response to CAL above. It definitely is some setting you have in GMail that is causing the problem. GMM-mook is definitely 100% operational. I tried a bunch of settings in GMail to find out what works/fails and only discovered that it must be in "Standard" display mode and "Turn off Buzz". Every other combo i tried worked fine. I did not try enabling all the plugins (via Labs) of GMail though so its also possible one of these enabled things is causing a conflict?

Cal.123

User avatar
 
Posts: 106
Joined: October 30th, 2007, 4:24 am

Post Posted November 6th, 2010, 6:47 am

brand404 wrote:
relish1 wrote:brand404- thanks for your mail

I installed Mook's version, now it takes few minutes to connect and still gets the count on 0 (though I have snippets).
On my other account it works great, but that's the same problem I had on 0.6.1.
Something probably on my gmail settings is doing all this troubles, and I can't figure out what...
Appreciate your help!


Read my response to CAL above. It definitely is some setting you have in GMail that is causing the problem. GMM-mook is definitely 100% operational. I tried a bunch of settings in GMail to find out what works/fails and only discovered that it must be in "Standard" display mode and "Turn off Buzz". Every other combo i tried worked fine. I did not try enabling all the plugins (via Labs) of GMail though so its also possible one of these enabled things is causing a conflict?

Thanks much for your info! I'll go into my Gmail settings and make sure they conform to your stated configs

Thanks!.

:)

brand404

User avatar
 
Posts: 63
Joined: April 25th, 2010, 5:03 am

Post Posted November 6th, 2010, 7:31 am

Cal.123 wrote:Thanks much for your info! I'll go into my Gmail settings and make sure they conform to your stated configs


Hey Cal! Yea let us know how things work out. If it was something that i didnt state then please share...in case someone else has the same problem

Cheers :D

CAL-123

User avatar
 
Posts: 7
Joined: October 31st, 2010, 10:38 am

Post Posted November 6th, 2010, 7:40 am

@ brand404 Checked everything and all seems to be configured the way you state. Even disabled all my add-ons except for Gmail Manager...no joy! Attempted safe mode...but as one has to re-boot...that just brings up all the extensions again and I don't wish to disable/ uninstall them by safemode and have to re-install. But disabling should do the same thing I would assume.

The *only* thing I do that may be different and possibly conflicting is I do have two Gmail accounts with one used as a 'dummy' account that forwards all to my main account address that I store all my 'goodies' in. :) Can't see any reason that would affect things as I've got both Gmail's boxes configured as you state using standard and Buzz disabled.

So back to using the two Gmail add-ons. They do work very well together so anyone else that can't get things working...try my method as it's better than nothing! <G>

brand404

User avatar
 
Posts: 63
Joined: April 25th, 2010, 5:03 am

Post Posted November 6th, 2010, 8:21 am

CAL-123 wrote:@ brand404 Checked everything and all seems to be configured the way you state. Even disabled all my add-ons except for Gmail Manager...no joy! Attempted safe mode...but as one has to re-boot...that just brings up all the extensions again and I don't wish to disable/ uninstall them by safemode and have to re-install. But disabling should do the same thing I would assume.
So back to using the two Gmail add-ons. They do work very well together so anyone else that can't get things working...try my method as it's better than nothing! <G>


@CAL-123 Hmmm...sorry about that CAL....yea your disabling the extensions is pretty much like not having them installed so ur fine.
Questions:

1) Try this: Make a New GMail Account right now and send some mail into it...Then set GMM-mook to check it. See if that works...This way we know that GMail is set to its defaults....if it doesnt work still then remove the other accounts in GMM for the time being and disable Notifier agian....and let me know if it works. Make sure to Turn off Buzz in the new Account.

2) Assuming #1 doesnt work: Now that we know Extensions arent the issue, how about the Plugins? On my side i have a ton of plugins enabled such as: Acrobat, Google Talk, Flash, Shockwave, RealPlayer, Unity Player, Silverlight, etc....Can you disable all of them via "-safe-mode" and see if this helps?

Cheers

TEA-Time

User avatar
 
Posts: 74
Joined: October 29th, 2007, 7:34 pm

Post Posted November 6th, 2010, 9:36 am

CAL-123 wrote:Got the same problem...erratic is the word. Sometimes it works, most of the time it doesn't. BUT it does give snippets if you 'hover' over the icon. Is there any conflicts in running Gmail Notifier along with this one? Anyway, I'm going to try that...at least Notifier 'notifies'!

If there are conflicts...I'll post back.

:-"

Hey CAL,

Quite a few pages back in this forum it was discovered that it was necessary to enter the e-mail address in lower case for things to work right. For me it made the both the count and notification sounds work. Might this be the problem you're seeing?

viewtopic.php?p=9338245#p9338245

FaeGiN
 
Posts: 38
Joined: June 29th, 2008, 8:49 am

Post Posted November 6th, 2010, 2:23 pm

Wow this is brilliant!
I really did think it was the end of the line for this when it started to not work so often as of maybe a couple of weeks or so ago.
I came by here but after reading so many problems etcv I decided not to even try the posted mook version at all.
Well I returned today and tried it.
THANK YOU THANK YOU THANK YOU!!!
I now have my favourite extension back working again and it's fine. Actually, seems to me to be more responsive than it ever was before. I like yours better mook ;)
Thanks again for keeping this going, there are a lot of fans thanking you I am sure mook.
Cheers to all who have been pitching in to get something sorted.

CAL-123

User avatar
 
Posts: 7
Joined: October 31st, 2010, 10:38 am

Post Posted November 6th, 2010, 5:28 pm

@ Brand404 @ TEA-time...Thanks to both! It was the lower case issue all the time. ](*,)
Somehow I put the email in with a cap to start the address! Duhh, they do call be stupid at times!! :mrgreen: ...after disabling, new profile, safe modes + all sorts of other crap...that's all it was.

Working fine now! Thanks TEA-time for jarring this old head of mine and also a big thanks to Brand404 for 'pushing' me to try it all!

TEA-Time

User avatar
 
Posts: 74
Joined: October 29th, 2007, 7:34 pm

Post Posted November 6th, 2010, 6:05 pm

Excellent! Glad I could help. :-)

49311
 
Posts: 35
Joined: April 25th, 2010, 7:15 pm

Post Posted November 7th, 2010, 5:20 am

Thanks mook and everyone else who helped with the fix :)

th.danzig
 
Posts: 2
Joined: November 6th, 2010, 7:36 am

Post Posted November 7th, 2010, 1:59 pm

Hi there!

I'm new to this forum, as I just installed Gmail Manager as a Firefox add-on. I was curious whether there is a pop-up notification in the active window that new mail has been received. As far as I can see (but correct me if I'm wrong) there is only a notification in the statusbar of Firefox. This means that when another non-Firefox window is active (i.e. the Firefox window is not displayed) I cannot see whether a new mail has been delivered. I have to skip to the Firefox window to see if the statusbar has changed.

The add-on Gmail Notifier has a pop-up window that is even visible when the Firefox window is not the top window. Does Gmail Manager has a feature like that?

Regards,
Thomas

samuelal
 
Posts: 22
Joined: November 7th, 2010, 6:58 pm

Post Posted November 7th, 2010, 7:11 pm

Hi!

I've been following CAL-123's problem closely along side TEA-Time & Brand404's advice.

Let me describe what's going on:
1. Runing FireFox v3.6.12.
2. Using mook's latest v0.6.1 build (0.6.1.0.1.20101101.mook).
3. Five (5) Gmail accounts are setup in Gmail Manager.
4. Gmail Buzz is disabled on all accounts.
5. Priority Inbox is disabled on all accounts.
6. All Gmail Labs plugins are disabled on all accounts.
7. All five accounts are written in lower-case letters, both in Gmail Manager and in Gmail (I never setup accounts with Capital letters).

The results are:
1. Four (4) of those accounts are working perfectly.
2. One (1) account is simply refusing to notify me when new mail arrives: Unread Emails counter's simply stuck at 0.
3. If however, I hover with my mouse pointer above the problematic account in my status bar - It'll display the correct snippets from all new, unread messages!

Any ideas what's going on here?

Many thanks to those who can help.


My best regards,
Samuel
//subscribed to this thread.

brand404

User avatar
 
Posts: 63
Joined: April 25th, 2010, 5:03 am

Post Posted November 8th, 2010, 1:30 am

th.danzig wrote:Hi there!

I'm new to this forum, as I just installed Gmail Manager as a Firefox add-on. I was curious whether there is a pop-up notification in the active window that new mail has been received. As far as I can see (but correct me if I'm wrong) there is only a notification in the statusbar of Firefox. This means that when another non-Firefox window is active (i.e. the Firefox window is not displayed) I cannot see whether a new mail has been delivered. I have to skip to the Firefox window to see if the statusbar has changed.


Hey Tom...

You can set the Display snippets when new mail is received. option checkbox under the Notifications Tab for an email account and this will pop up (rather, scroll up from the windows task bar) no matter which window has the focus. I've tried this before and it works like a charm -- actually just tried it again right now. Form me i prefer just sound (mine is a "wind chime" sfx: Listen Here) to notify when new mail arrives.

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 2 guests