MozillaZine


[Ext] Fission 0.8.9 [Sep 25]

Announce and Discuss the Latest Theme and Extension Releases.
rommels
 
Posts: 12
Joined: June 15th, 2005, 8:10 am

Post Posted February 2nd, 2006, 1:47 am

Hook me up with some of those snapshots, I think I know the problem you speak of but want to see if it is.
imageshack.us or e-mail romster at gmail

teknoprep
 
Posts: 11
Joined: February 1st, 2006, 7:06 pm

Post Posted February 2nd, 2006, 4:41 pm

here are the 2 pictures w/ Apollo and Firefox 1.5.0.1:

Image
(loading)

Image
(loaded)

thanks!

jammnrose
 
Posts: 4
Joined: February 2nd, 2006, 4:42 pm

Post Posted February 2nd, 2006, 4:51 pm

yo,
got my progressbar working and looking very cool.
Image
right click this image and save as->"progressmeter.gif" then drop it in your chrome directory and add this code to userChrome.css:
Code: Select all
#urlbar #statusbar-icon > .progress-bar {
   background: url("progressmeter.gif") repeat-x left center !important;
   background-color: transparent !important;
}

#urlbar[fission="fusion"] > #statusbar-icon > .progress-bar {
   background-color: #7FC4FF !important;
}


rounded url bar:
Code: Select all
#urlbar #statusbar-icon > .progress-bar {
   background: url("progressmeter.gif") repeat-x left center !important;
   background-color: transparent !important;
   margin: 5px -31px 3px !important;

}

#urlbar[fission="fusion"] > #statusbar-icon > .progress-bar {
   background-color: #7FC4FF !important;
}

restart FF
hope you like it....
PS does not go all the way to the end of url bar when loading....if somebody has code to make it reach the end it would be even better....

edit: added code for rounded url bar....doesnt look as good as it could...better than nothin though
Last edited by jammnrose on February 2nd, 2006, 6:37 pm, edited 2 times in total.

teknoprep
 
Posts: 11
Joined: February 1st, 2006, 7:06 pm

Post Posted February 2nd, 2006, 5:25 pm

jammnrose:

i tried that picture with mine, but it doesn't work...instead it just shows the old background (like my picture above). I made the correct userChrome (I have patched it before) and I saved the picture in the same directory. anything else you recommend?

rommels:

maybe if I try jammnrose's approach i can create a smaller image file, one that doesn't bleed over...like this picture:

Image
(my goal - edited with mspaint)

jammnrose
 
Posts: 4
Joined: February 2nd, 2006, 4:42 pm

Post Posted February 2nd, 2006, 5:58 pm

erm....try adding the code after the @namespace line...I have it as the first thing after that line..it might matter....
also make sure the image is in your profile's chrome directory and it has the correct name...
my userChrome.css looks likes this:
Code: Select all
/*
 * Edit this file and copy it as userChrome.css into your
 * profile-directory/chrome/
 */

/*
 * This file can be used to customize the look of Mozilla's user interface
 * You should consider using !important on rules which you want to
 * override default settings.
 */


/*
 * Do not remove the @namespace line -- it's required for correct functioning
 */
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */


#urlbar #statusbar-icon > .progress-bar {
   background: url("progressmeter.gif") repeat-x left center !important;
   background-color: transparent !important;
   margin-top: 1 !important;
}

#urlbar[fission="fusion"] > #statusbar-icon > .progress-bar {
   background-color: #7FC4FF !important;
}


/*
 * Some possible accessibility enhancements:
 */
/*
 * Make all the default font sizes 20 pt:
 *
 * * {
 *   font-size: 20pt !important
 * }
 */
/*
 * Make menu items in particular 15 pt instead of the default size:
 *
 * menupopup > * {
 *   font-size: 15pt !important
 * }
 */
/*
 * Give the Location (URL) Bar a fixed-width font
 *
 * #urlbar {
 *    font-family: monospace !important;
 * }
 */

/*
 * Eliminate the throbber and its annoying movement:
 *
 * #throbber-box {
 *   display: none !important;
 * }
 */

/*
 * For more examples see http://www.mozilla.org/unix/customizing.html
 */

anon42
 
Posts: 303
Joined: December 1st, 2005, 12:07 am

Post Posted February 3rd, 2006, 12:10 am

jammnrose wrote:yo,
got my progressbar working and looking very cool.
Image
right click this image and save as->"progressmeter.gif" then drop it in your chrome directory and add this code to userChrome.css:

...code snipped out...

restart FF
hope you like it....
PS does not go all the way to the end of url bar when loading....if somebody has code to make it reach the end it would be even better....

Heheh :D Neat. Thanks. But I am wondering why you made the gradient unsymmetric, i.e., the darker band is lower than the center. I'm nit picking I know. But IMO it would look better if it were symetric (I'm anal that way).
jammnrose wrote:edit: added code for rounded url bar....doesnt look as good as it could...better than nothin though

This completely fouled up my progress bar with a narrow blue band that started from the <b>outside</b> of the address bar on the left!

phishSCI

User avatar
 
Posts: 84
Joined: September 29th, 2004, 12:03 pm

Post Posted February 3rd, 2006, 1:35 pm

When I am using the icon style progess bar, my favicon in the url bar appears to be "squished". Does anyone know how to fix this or get rid of the favicon all together? Thanks.

jammnrose
 
Posts: 4
Joined: February 2nd, 2006, 4:42 pm

Post Posted February 3rd, 2006, 9:34 pm

anon42 wrote:
jammnrose wrote:edit: added code for rounded url bar....doesnt look as good as it could...better than nothin though

This completely fouled up my progress bar with a narrow blue band that started from the <b>outside</b> of the address bar on the left!


hrm....maybe because my rounded bar is coming from my style (saFire1.09)...not an extension maybe?? try playing with margins a bit....
when i had rounded bar it had a white block before the bar started......thats why i added margin....looked better than shit white....
personally i stick with the square progress bar...(safari compliant)

ukengb
 
Posts: 31
Joined: April 28th, 2004, 9:19 am
Location: UK

Post Posted February 4th, 2006, 6:40 am

Anyone know how to make Fission work with Brushed?

It all works as it should with the Default theme, but:-

the progress bar bleeds way outside the URL bar in SaferFox theme.

No progress bar at all in Brushed and the connection status doesn't work nicely with the existing URL.

I'm not too concerned about the SaferFox problem, but can we get fission to function in Brushed?
Ken G i l l e t t

_/_/_/_/_/_/_/_/

ukengb
 
Posts: 31
Joined: April 28th, 2004, 9:19 am
Location: UK

Post Posted February 4th, 2006, 6:51 am

I would dearly like to eliminate the status bar and so using Fission to display the Connection Status in the URL/Location bar sounds ideal, but I have some preferred modifications:-

Not display anything when it's just 'Done'. I have no need to know that and would rather regain the space it otherwise occupies in the URL bar.

Do Display the URL of any link being hovered over. This is usually displayed in the status bar, but it would be great if Fission could put this in the URL bar too. My actual preference is how Omniweb does it - the current location is replaced with the URL of the link during the hover, but reverts back to the current location when the mouse is not over any link.

Obviously these should be switchable as not every user would agree with my ideal setup.

Can fission currently do these (how?), or would it need to be an update?
Ken G i l l e t t

_/_/_/_/_/_/_/_/

old zeniko
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 4th, 2006, 2:21 pm

@thelimelight:
Code: Select all
#page-proxy-deck { width: 0px !important; }

@ukengb:
Code: Select all
#fission-status[value="Done"] { display: none !important; }

should take care of "Done". As for the link URL: until I've thought it over, install <a href="data:application/x-xpinstall;base64,UEsDBBQAAAAIAC2wRDTauxIGRwAAAGkAAAAPAAAAY2hyb21lLm1hbmlmZXN0RcxLCoAwDEXRcQrdSjN3N1oiFmICSf3tXgSjw3c5vKrSSTrw3NybCpScdCfj8YK6mK40IE6mh5Phi2OXc+MfxUOoLzwspxtQSwMEFAAAAAgAaLBENO/JArKrAQAAAAMAAAsAAABpbnN0YWxsLnJkZm2RwU7jMBCGzyDxDt5wWbRy7DihaSo3FVLVEyck9u4mk8YisSPbJaVo330TEwgIDrY84/+bGf/mm1PboGcwVmq1DqKQBpv86vLqkj9sd6thoeFe2fG0DmrnuhUhfd+HfRxqcyBRlmWEMsIYNmWF7Yty4oSVvQ7euC9Mq8+yaYQHGaUJgXakroOh4YXvtwVbGNk5qRUSe3106+Bo1GoCV1JZJ5oGt0LJCqzz4AWXZf4asSVd0MUes9uI4qQCirMUKpztbwVjICpI2D9OZOkRjynRQr6T1o7dft9L9XTDiU/668mTnIYpJ1Mww+U8ab6VtmvEi0W1HnR43FAzlENH01gkFXI1IFGWBqxFe2FCTj7jvl6tW+jEAR4f7vPJskqbY2vfXTtLBd65Zwm9050swq7uNm4dp5QlS04+V/AlCwPCaZOfQcknzckUz29wwhzA3XVdIwvhR+G/MEY7aaDSJ4Sxl377GZ+dbIdiSWNapbhgVOBkkYyOU8BRLGKRQZbGy2S2fYBaqf5OXkZhwskcfyjEaVYs/nAyJ6Z5yE8DcfLlOVP+R/FbbljD+T9QSwMEFAAAAAgA4rBENBXu3qPZAQAAXwQAAAwAAABsZmlzc2lvbi54dWyVVF1vmzAUfaZS/8OFh4pIHaSvC6Tq5xNSpy3VOlVV5IVL4sXYlm0g2dT/PgwUEq1s2gMGX5977jn2NdHlLmdQotJU8Ni7CKbe5fz05PQkcm8fbhbfPt2BqFcZ2bfRbgJ1FtextzFGfgzDqqqCXPykjJFAqHW4xX1OtEEVronBLaKsP80GFQZUB4KzfbArmFdTOpFeKSoNmL3E2CNSMroiphYT7j78ICVpl7155D7f3F4trp7rHCcr+Mpi4J5qKzyhfOtP7MovOzg0A9+tKE9FFTw9JtdKVBrV1yZgYTUOwhAqQg0U3FAGUqEkCu+F+mKIMoWElcglQ4O6wTsazYLmKArjHxQ9h4vpdDJrIQpNoXg7eR10rB8/J9dEdXXHoM0wIjlYLmWtLVlqNA8lKlsZYhhDH6Bmf6U9pnvbVJ81xr5PwIrtXNiYddBbaMP21EQGncVeZ0lYgRDH4BU8xYxyTL02e0h3RpJ6smY+69CvB0WPAODGYMWN0XeoFnTINryQafxPa+6RNTg763G9dbOxrd5s77/V/VHmXfMp2oYcxw5QW/y9runPtms9++pG+3SNQtL0rkRuEqoNclS+xwRJvXM46vyMMI0N0cvLPArbi1pf6Sgc/hi/AVBLAQIUABQAAAAIAC2wRDTauxIGRwAAAGkAAAAPAAAAAAAAAAAAICAAAAAAAABjaHJvbWUubWFuaWZlc3RQSwECFAAUAAAACABosEQ078kCsqsBAAAAAwAACwAAAAAAAAAAACAgAAB0AAAAaW5zdGFsbC5yZGZQSwECFAAUAAAACADisEQ0Fe7eo9kBAABfBAAADAAAAAAAAAAAACAgAABIAgAAbGZpc3Npb24ueHVsUEsFBgAAAAADAAMAsAAAAEsEAAAAAA==">Fission (Link)</a> (download before installing).

jammnrose
 
Posts: 4
Joined: February 2nd, 2006, 4:42 pm

Post Posted February 4th, 2006, 9:13 pm

ukengb......
i have used brushed. since then have found a better theme...
try this:
http://www.deviantart.com/view/19147285/

works with fission for me....(using my code)

Aristotle Pagaltzis
 
Posts: 5
Joined: February 5th, 2006, 4:45 am

Post Posted February 5th, 2006, 4:58 am

Hi,

I've been having an aggravating problem recently: the address bar of a newly opened window loses focus after a fraction of a second and I have to hit Ctrl-L before I can actually enter something. I only just got bothered enough to track down the culprit, and it turns out that Fission is it. When I disable Fission, this irritation disappears.

I checked whether it might be a conflict with other extensions, but this does not appear to be the case; installing Fission into a fresh profile exhibits the same problem.

This disrupts my browsing flow so badly that I had to disable Fission. Please fix it.

old zeniko
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 5th, 2006, 7:29 am

@ukengb: Today's update adds a new pref (extensions.fission.linkify) for what you wanted.

@Aristotle Pagaltzis: Thanks for the note. Today's update fixes this problem.

Branstrom

User avatar
 
Posts: 97
Joined: March 16th, 2004, 9:45 am
Location: Sweden

Post Posted February 5th, 2006, 10:13 am

Does it modify the innerHTML of this element or does it lay another element on top of it?

Image

I'd like to have it in another style (the text, of course, but if it's possible, the whole urlbar) when hovering a link.

I'd also like the "Done" to go away :) And if I'm totally going to get rid of the status bar, the icons there would have to be moved to the address bar... or maybe to the menubar, only visible on hover, or something.
Last edited by Branstrom on February 5th, 2006, 11:33 am, edited 2 times in total.

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 2 guests