MozillaZine

[Ext] Session Manager 0.4 to 0.4.3

Announce and Discuss the Latest Theme and Extension Releases.
Claycom
 
Posts: 1
Joined: May 10th, 2006, 12:39 pm

Post Posted May 10th, 2006, 12:43 pm

Is there a way to not even have a Session cache list instead of having to manually clear one?

old zeniko
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted May 10th, 2006, 1:06 pm

I'm not sure I understand the question. Setting the number of backup sessions to keep to 0 and disabling the session backup at shutdown will prevent any session to be automatically added to the session list. Should you mean something different, please elaborate.

Muescha
 
Posts: 53
Joined: February 17th, 2005, 9:18 am
Location: Germany

Post Posted May 11th, 2006, 12:26 am

zeniko wrote:Note however that this will only work for manually saved sessions. The easiest way of getting this globally would be to edit crashrecovery.js (in the extension's components subdirectory) and change the line....


can i use for this patch also the userchrome.js with "xxxobject.xxxfunction.toString().replace(" construct?

old zeniko
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted May 11th, 2006, 12:35 am

No.

dougeeebear

User avatar
 
Posts: 548
Joined: September 15th, 2005, 4:17 pm

Post Posted May 12th, 2006, 12:12 pm

zeniko,
In the TMP style context menu there is the option to "Load (Append To Current Session)".
If there are multiple tabs in the appended session, regardless of which tab is the focused tab, the left tab of the appended session always ends up as focused.

In other words, if the appended session has the third (or whatever) tab focused when opening normally from the session list, the first (left) tab of that session is always focused when appended.

Make sense? :)

Any ideas how I might rectify this?

old zeniko
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted May 12th, 2006, 12:52 pm

dougeeebear: Try the latest <a href="http://www.haslo.ch/zeniko/software/sessionmanager-dev.xpi">testing version</a> (0.4.1.6+) for a fix to this issue.

dougeeebear

User avatar
 
Posts: 548
Joined: September 15th, 2005, 4:17 pm

Post Posted May 12th, 2006, 1:38 pm

zeniko wrote:dougeeebear: Try the latest <a href="http://www.haslo.ch/zeniko/software/sessionmanager-dev.xpi">testing version</a> (0.4.1.6+) for a fix to this issue.

Thanks, zeniko... that fixed it.

dougeeebear

User avatar
 
Posts: 548
Joined: September 15th, 2005, 4:17 pm

Post Posted May 12th, 2006, 2:47 pm

zeniko,
Is it possible to add a pref to disable the crash warning page?
I would rather not see it.
I looked in about:config and didn't see anything pertaining to that.

old zeniko
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted May 12th, 2006, 3:32 pm

If you really don't want the crash warning page, just set the pref extensions.crashrecovery.crash_warning_uri to an empty string.

dougeeebear

User avatar
 
Posts: 548
Joined: September 15th, 2005, 4:17 pm

Post Posted May 12th, 2006, 3:43 pm

zeniko wrote:If you really don't want the crash warning page, just set the pref extensions.crashrecovery.crash_warning_uri to an empty string.

Once again, thanks.

ottawa
 
Posts: 3
Joined: May 17th, 2006, 2:37 am

Post Posted May 17th, 2006, 2:39 am

Each recovered tab wants me to key-in the password for the cryptography-module. This needs to be fixed.

old zeniko
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted May 17th, 2006, 3:44 am

ottawa wrote:Each recovered tab wants me to key-in the password for the cryptography-module. This needs to be fixed.

Please elaborate on what you're talking about and how to reproduce this behavior.

ottawa
 
Posts: 3
Joined: May 17th, 2006, 2:37 am

Post Posted May 17th, 2006, 11:01 pm

I start Firefox (1.5.0.3) with about 60 tabs that have to be opened from the last session (the day before). I am asked to key in the master-password of Firefox's password manager (and the password of the proxy I'm using) about 10 times, obviously the amount of tabs where a login-form is to be filled out (i.e. webmail). I'm using SessionManager 0.4.1.1 and TabMixPlus 0.3.0.5.

The only way to get around keying in 10 times is to start Firefox without loading the last session, keying in the master-password on any website that needs a password only one time and then load the session of the day before manually.

Petula
 
Posts: 8
Joined: May 17th, 2006, 11:23 pm

Post Posted May 17th, 2006, 11:33 pm

First i got the "The file is not a valid installation package."
Next, as per your directions, i went to the homepage for the SessionManager extension, and tried to install it from there. Firefox prevented your site from installing it, to protect my computer.

Peng

User avatar
 
Posts: 778
Joined: November 9th, 2004, 2:31 pm
Location: Central Florida

Post Posted May 17th, 2006, 11:40 pm

Petula wrote:Firefox prevented your site from installing it, to protect my computer.


Of course it did. There's a button to add the website to the whitelist.
Hug Peng
(aka Matt Nordhoff)
Check out: Adblock Plus | FoxClocks | OpenBook

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 2 guests