MozillaZine

[Ext] ThunderBrowse 3.3.5 for Thunderbird

Announce and Discuss the Latest Theme and Extension Releases.
bluezinnia
 
Posts: 2
Joined: December 24th, 2008, 2:48 pm

Post Posted December 28th, 2008, 7:42 pm

>Cookies are enabled by installing CS Lite into Thunderbird

Okay, thanks very much. So now: where do I find CS Lite, please?

netMASA

User avatar
 
Posts: 617
Joined: July 26th, 2006, 3:21 pm
Location: On the internet

Post Posted December 29th, 2008, 3:01 am

Check out ThunderBrowse, the browser for Thunderbird. Donate to ThunderBrowse!

SA Jack
 
Posts: 13
Joined: June 21st, 2008, 4:40 pm

Post Posted December 30th, 2008, 8:15 pm

Thunderbird just updated to 2.0.0.19. The restart disabled KeyConfig, however, I found the update that just came out today. I uninstalled the disabled KeyConfig and installed the new version. However, when I changed the TBrowse forward and back keys from Alt+Right Arrow to Ctrl+Right Arrow to accommodate my Logitech mouse buttons, I'm not getting any response.

Are you aware of any changes in 2.0.0.19 that would possibly cause this problem?

Thanks, and Happy New Year. -SA Jack

netMASA

User avatar
 
Posts: 617
Joined: July 26th, 2006, 3:21 pm
Location: On the internet

Post Posted December 31st, 2008, 1:25 am

SA Jack wrote:Thunderbird just updated to 2.0.0.19. The restart disabled KeyConfig, however, I found the update that just came out today. I uninstalled the disabled KeyConfig and installed the new version. However, when I changed the TBrowse forward and back keys from Alt+Right Arrow to Ctrl+Right Arrow to accommodate my Logitech mouse buttons, I'm not getting any response.

Are you aware of any changes in 2.0.0.19 that would possibly cause this problem?

Thanks, and Happy New Year. -SA Jack


My personal install has yet to update (though, yes I heard about the release). I would say that it seems keyconfig just isn't fully supported (which I'm surprised because I never heard anything that would change keys in Thunderbird).

But looking through the buglist, I have a feeling that you need to:

Reset the keys for ThunderBrowse.
Restart Thunderbird.
Change the keys for ThunderBrowse
Restart


and see if that works for you.
Check out ThunderBrowse, the browser for Thunderbird. Donate to ThunderBrowse!

citizen_kane
 
Posts: 3
Joined: January 3rd, 2009, 8:54 am

Post Posted January 3rd, 2009, 9:02 am

Hey man, thanks for a great add-on.

I have a problem, mainly with javascript. I checked the box "enable javascript?" on the add-on, but when visiting the site "https://fronter.com/hil", the site says "Warning: Javascript is turned off..."

I noticed you recommended installing CS Lite earlier, and have made sure the site's cookies are not blocked. I can access the site, but it's javascript-features are left out.

Have I done anything wrong, or are https-sites difficult to access with your extension.

Thanks.

netMASA

User avatar
 
Posts: 617
Joined: July 26th, 2006, 3:21 pm
Location: On the internet

Post Posted January 3rd, 2009, 11:10 am

citizen_kane wrote:Hey man, thanks for a great add-on.

I have a problem, mainly with javascript. I checked the box "enable javascript?" on the add-on, but when visiting the site "https://fronter.com/hil", the site says "Warning: Javascript is turned off..."

I noticed you recommended installing CS Lite earlier, and have made sure the site's cookies are not blocked. I can access the site, but it's javascript-features are left out.

Have I done anything wrong, or are https-sites difficult to access with your extension.

Thanks.


It depends on which version of Thunderbird you are using. The recent betas of Thunderbird disable all Javascript.

If you aren't using a recent beta, try refreshing the page again or opening it in another tab. If it still doesn't work, then it could be that javascript isn't actually allowed on (like you closed the settings window instead of saving the options).

If it still doesn't work, the website might be checking for a specific browser string.

When I went to the site, it didn't say anything about javascript being off for me, so I would try the above things and see what works. It's probably a one time glitch or something.
Check out ThunderBrowse, the browser for Thunderbird. Donate to ThunderBrowse!

citizen_kane
 
Posts: 3
Joined: January 3rd, 2009, 8:54 am

Post Posted January 3rd, 2009, 12:25 pm

Thanks for your response.

I use Thunderbird 2.0.0.19.

I am absolutely positive I have checked the javascript box.

I tried again, something weird happened.

- First, I tried logging in, entered the site as usually without javascript-features.
- Logging out sends me to a blank page, so I typed the adress again.
- Logging in this time sent me to firefox, with the log-in-form as it is when I enter the site in Firefox.
- Closing firefox and trying again made me enter the site WITH javascript, but with a pop-up saying "To use FIM you will need minimum Java plugin version 1.5". The FIM seems to be the top menu, who disappears whenever I navigate away from the homepage, making the site useless.

Logging out works once the site is entered properly (with the pop-up though), but logging in again sends me through the whole routine again. Turing javascript OFF does absolutely nothing.

Some progress have been made, but I cannot seem to use the site's javascript-features properly.

Thanks again for a great feature, and for your quick response.

netMASA

User avatar
 
Posts: 617
Joined: July 26th, 2006, 3:21 pm
Location: On the internet

Post Posted January 3rd, 2009, 12:53 pm

citizen_kane wrote:Thanks for your response.

I tried again, something weird happened.

- First, I tried logging in, entered the site as usually without javascript-features.
- Logging out sends me to a blank page, so I typed the adress again.
- Logging in this time sent me to firefox, with the log-in-form as it is when I enter the site in Firefox.
- Closing firefox and trying again made me enter the site WITH javascript, but with a pop-up saying "To use FIM you will need minimum Java plugin version 1.5". The FIM seems to be the top menu, who disappears whenever I navigate away from the homepage, making the site useless.

Logging out works once the site is entered properly (with the pop-up though), but logging in again sends me through the whole routine again. Turing javascript OFF does absolutely nothing.

Some progress have been made, but I cannot seem to use the site's javascript-features properly.

Thanks again for a great feature, and for your quick response.


I had a look at the page source. What happens is that the login form submits itself several times (many many times [a silly thing]).

When you click the Submit button:
It submits natively
The onSubmit runs a function (that ends up submitting it again)
The onClick on the submit button submits again

From the looks of it, it seems like the requests are conflicting with each other. This is one of the cases where poor website design affects usability.

You might notice that the webpage will launch in Firefox and will load in ThunderBrowse as well. It's like bug 67, where simultaneous requests cause Thunderbird to try to resolve the requests (which leads to Firefox being opened).

There is a workaround, but toggling it can be a bit of a hassle and breaks stuff (but it disables Thunderbird from resolving).

By setting network.protocol-handler.external-default to false, all requests will be ignored by Thunderbird. Nothing will launch firefox. The problem is, that this affects every extension (so you might get some broken ones). If you want to Visit in Browser, you will have to set the path to your browser.

A fix for bug 67 is supposed to be just toggling the pref, but I'm still trying to see if there is an easier way to block Thunderbird from doing this.
Check out ThunderBrowse, the browser for Thunderbird. Donate to ThunderBrowse!

citizen_kane
 
Posts: 3
Joined: January 3rd, 2009, 8:54 am

Post Posted January 3rd, 2009, 1:06 pm

OK. I didn't understand a whole lot of what you just said.

But as log as you know about the problem, and know how to fix it, I will leave it to you to decide whether you should spend time on fixing a problem caused by others, or not. I know the site is quite old-school, but it's my university's form of communication, so I need to visit it regurlarly.

If you can find a way to fix it, I would be delighted, but totally understand if not.

Thanks.

Regards from Norway.

netMASA

User avatar
 
Posts: 617
Joined: July 26th, 2006, 3:21 pm
Location: On the internet

Post Posted January 19th, 2009, 4:12 pm

Heads up if you are trying to use ThunderBrowse on TB3.0b2pre, it won't work. Head over to the ThunderBlog for a link to a patch.

http://www.thunderbrowse.com/thunderblo ... tb30b2pre/

Note: Patch hides ThunderBrowse context menu entries. A better fix will appear in 3.2.3 (which will probably get bumped version numbers to 3.5). I changed a few things, now it patches correctly.
Check out ThunderBrowse, the browser for Thunderbird. Donate to ThunderBrowse!

netMASA

User avatar
 
Posts: 617
Joined: July 26th, 2006, 3:21 pm
Location: On the internet

Post Posted January 23rd, 2009, 4:49 pm

ThunderBrowse 3.2.3 beta 1 available for testing.

Find it here:
http://www.thunderbrowse.com/thunderblo ... 23-beta-1/
Check out ThunderBrowse, the browser for Thunderbird. Donate to ThunderBrowse!

djb369
 
Posts: 2
Joined: February 3rd, 2009, 3:56 am

Post Posted February 3rd, 2009, 4:32 am

Cookies not enabled using Thunderbrowse 3.2.2.1

I have read all the various posts and installed CSLite, ensured that global settings are enabled for cookies. I have tried uninstalling and re-installing both CSLite and Thunderbrowse with re-boots between to ensure that there were not caching problems. I am trying to access Hotmail from Thunderbrowse and even set up Live.com as an exception in CSLite always allowed.

However, Thunderbrowse always displays "Cookies must be allowed". Please help.

Thanks, djb369

netMASA

User avatar
 
Posts: 617
Joined: July 26th, 2006, 3:21 pm
Location: On the internet

Post Posted February 3rd, 2009, 5:53 pm

djb369 wrote:Cookies not enabled using Thunderbrowse 3.2.2.1

I have read all the various posts and installed CSLite, ensured that global settings are enabled for cookies. I have tried uninstalling and re-installing both CSLite and Thunderbrowse with re-boots between to ensure that there were not caching problems. I am trying to access Hotmail from Thunderbrowse and even set up Live.com as an exception in CSLite always allowed.

However, Thunderbrowse always displays "Cookies must be allowed". Please help.

Thanks, djb369


Here's the reason:
If a cookie is sent via https, CS Lite tends not to be able to read it as Thunderbird has this odd habit of removing cookie headers from https data. This means most https sites cannot be logged in to. However, this is not always the case. Sometimes it will work, sometimes it will not.

Ron (creator of CS Lite) stated that he asked on #maildev but no one was able to help him out.
Check out ThunderBrowse, the browser for Thunderbird. Donate to ThunderBrowse!

djb369
 
Posts: 2
Joined: February 3rd, 2009, 3:56 am

Post Posted February 5th, 2009, 2:15 am

Thanks netMasa,

netMASA

User avatar
 
Posts: 617
Joined: July 26th, 2006, 3:21 pm
Location: On the internet

Post Posted February 14th, 2009, 3:55 pm

3.2.3 has been uploaded to AMO
Check out ThunderBrowse, the browser for Thunderbird. Donate to ThunderBrowse!

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 3 guests

cron