MozillaZine

[Update for 1.0 PR] Super Drag and Go

Announce and Discuss the Latest Theme and Extension Releases.
Nforcr14

User avatar
 
Posts: 88
Joined: October 14th, 2003, 2:44 am
Location: Manila, Philippines

Post Posted June 24th, 2004, 2:09 am

Not working for me too.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040823 Firefox/0.9.1+ (MOOX M2)

Rowne Mastaile

User avatar
 
Posts: 1434
Joined: December 21st, 2003, 3:05 pm
Location: Housed in a swirling neosma of scintillating thought and turgid ideas.

Post Posted June 24th, 2004, 2:31 am

Just out of curiousity, could the people it isn't working for post their UAs? I can't help but wonder if there's been a bugfix checked in in a latest nightly that's stopped this from working, somehow.

IdoMcFly
 
Posts: 382
Joined: November 3rd, 2003, 1:06 am

Post Posted June 24th, 2004, 2:36 am

I'm using the milestone 0.9
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Last edited by IdoMcFly on June 24th, 2004, 3:57 am, edited 1 time in total.

Sariyan
 
Posts: 142
Joined: September 12th, 2003, 2:53 pm

Post Posted June 24th, 2004, 3:11 am

hmmm... it doesn't work for me.

"20040614 Firefox/0.9"

jedipi
 
Posts: 5
Joined: June 24th, 2004, 1:01 am

Post Posted June 24th, 2004, 4:16 am

Same here...
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

I have disabled all the other extension already. But it still does not work.

Rowne Mastaile

User avatar
 
Posts: 1434
Joined: December 21st, 2003, 3:05 pm
Location: Housed in a swirling neosma of scintillating thought and turgid ideas.

Post Posted June 24th, 2004, 4:26 am

The part that surprises me about this extension though is that I actually renamed my Mozilla (Application Data) to Mozilla.tmp, renamed my Firefox to Firefox.tmp, unzipped the Tinderbox into a new Firefox and installed the extension from scratch and it still didn't seem to work.

It's odd that it works for some people though. So it must be something going on here... though I can't figure out what for the life of me, I'll keep digging.

NetOne
 
Posts: 209
Joined: March 15th, 2004, 3:50 am

Post Posted June 24th, 2004, 4:36 am

I found one thing really strange: after install this extension, I can delete the corresponding .jar file from the extensions directory in my profile when firefox is running. But the .jar files for other extensions can't be deleted when firefox is running. But I can still see the extension info in extension manager.

IdoMcFly
 
Posts: 382
Joined: November 3rd, 2003, 1:06 am

Post Posted June 24th, 2004, 4:38 am

NetOne wrote:I found one thing really strange: after install this extension, I can delete the corresponding .jar file from the extensions directory in my profile when firefox is running. But the .jar files for other extensions can't be deleted when firefox is running. But I can still see the extension info in extension manager.
so the extension is not really plugged in ?

NetOne
 
Posts: 209
Joined: March 15th, 2004, 3:50 am

Post Posted June 24th, 2004, 4:45 am

Ido wrote:so the extension is not really plugged in ?


That's what confused me. If the extension is not installed properly, why it's listed in the extension manager and the "about" dialog can get shown correctly?

IdoMcFly
 
Posts: 382
Joined: November 3rd, 2003, 1:06 am

Post Posted June 24th, 2004, 4:46 am

NetOne wrote:
Ido wrote:so the extension is not really plugged in ?


That's what confused me. If the extension is not installed properly, why it's listed in the extension manager and the "about" dialog can get shown correctly?
so maybe not fully plugged in ?

Rowne Mastaile

User avatar
 
Posts: 1434
Joined: December 21st, 2003, 3:05 pm
Location: Housed in a swirling neosma of scintillating thought and turgid ideas.

Post Posted June 24th, 2004, 5:04 am

Sounds like the jar filename has just been typo'd summere, then if that's the case. That's what usually causes things like this to happen.

Nonetheless, very well spotted NetOne! Wish I'd thought of that.

IdoMcFly
 
Posts: 382
Joined: November 3rd, 2003, 1:06 am

Post Posted June 24th, 2004, 5:21 am

Roan Foofitush wrote:Sounds like the jar filename has just been typo'd summere, then if that's the case. That's what usually causes things like this to happen.

Nonetheless, very well spotted NetOne! Wish I'd thought of that.
what do you mean ? I've check the install.rdf and all seems ok inside (I'm not a specialist though)

NetOne
 
Posts: 209
Joined: March 15th, 2004, 3:50 am

Post Posted June 24th, 2004, 5:26 am

I've also checked the install.rdf and find nothing.

MonkeeSage

User avatar
 
Posts: 1011
Joined: December 20th, 2002, 8:15 pm

Post Posted June 24th, 2004, 5:49 am

Parser error in contents.rdf (in superdrag.jar):

Code: Select all
chrome:displayName="SuperDrag&Go 0.1.1"
-----------------------------^


XML (of which RDF is a dialect) thinks that the '&' is the start of a named entity ('Go'), but since there is no semi-colon, it throws an error.

The extension installs properly (and works nicely) if this is changed to:

Code: Select all
chrome:displayName="SuperDrag&Go 0.1.1"


Upack the xpi, unpack the jar, change the contents.rdf file, repack the jar, repack the xpi, uninstall the currently install version, restart FF, install the newly packed version, restart FF -- everything is happy now. :)


Shelumi`El
Jordan

S.D.G
"[M]en are usually satisfied with bad argument only when their convictions rest on other grounds." --John Oman

NetOne
 
Posts: 209
Joined: March 15th, 2004, 3:50 am

Post Posted June 24th, 2004, 6:03 am

Thanks MonkeeSage! Now it work well for me!

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 6 guests