MozillaZine

Hardware Acceleration activating G-Sync

Discussion of bugs in Seamonkey
Ralph_Hanau
 
Posts: 4
Joined: December 5th, 2018, 6:19 am

Post Posted December 5th, 2018, 10:21 am

Well I got a new Windows 10 PC (Nvidia 1080) and G.-Sync Monitor.
I noticed using SeaMonkey (lates Build) a choppy mouse movement.
In all other browsers like Firefox ore Edge its normal.

I treed different setup, but after i disabled hardware acceleration in SeaMonkey it got smooth.

As wanted to know if G-Sync is active in 3D application (its normal not active on regular desktop) I enabled G-sync logo in the Nvidia setup.
I had an idea that I wanted to check if mouse gets normal with hardware acceleration on in SeaMonkey so I activated it again.

Surprise!!!

Starting the browser the G-Sync logo appeared.
So if hardware acceleration is on it activates G-Sync on desktop level and this gives a choppy mouse.
Deactivation G-Sync ore deactivating hardware acceleration in SeamMonkey and its normal again.

Please check this issue.

frg
 
Posts: 657
Joined: December 15th, 2015, 1:20 pm

Post Posted December 6th, 2018, 1:12 am

Not familiar with Gsync but you might want to check your Nivida control panel and define an exception if that is possible. Might have one for Firefox already.

Ralph_Hanau
 
Posts: 4
Joined: December 5th, 2018, 6:19 am

Post Posted December 6th, 2018, 5:02 am

No there is no way to do this. G-Sync is not designed to run in 2D applications.
So somwhere Seamonky is activating iot.

frg
 
Posts: 657
Joined: December 15th, 2015, 1:20 pm

Post Posted December 6th, 2018, 11:21 am

> So somwhere Seamonky is activating iot.

Yes because it uses hardware acceleration. There is probably custom default Firefox profile active which disables it for Firefox. You need to create one for SeaMonkey.

https://forums.geforce.com/default/topi ... -browser-/

Ralph_Hanau
 
Posts: 4
Joined: December 5th, 2018, 6:19 am

Post Posted Yesterday, 10:32 am

In Firefox hardware acceleration is activated and it works.

Hardware acceleration means using NVIDA CUDA but G-Sync is an additional CPU set only for syncing GPU with monitor
I have a set of applications using NVIDA hardware and not activating G-Sync.

frg
 
Posts: 657
Joined: December 15th, 2015, 1:20 pm

Post Posted Today, 9:32 am

You need to disable this for SeaMonkey. There is probably an existing Firefox setting you can copy. I don't have the hardware to test it.
Check Nvidia Control Panel -> 3D Settings -> Manage 3D settings -> Program Settings.

Return to SeaMonkey Bugs


Who is online

Users browsing this forum: No registered users and 1 guest