MozillaZine

Udemy video course material will not play. (Windows)

Discussion of bugs in Seamonkey
lem3
 
Posts: 25
Joined: May 15th, 2015, 10:29 am

Post Posted February 18th, 2019, 5:49 pm

Udemy courses that worked correctly in whatever version of SeaMonkey I was using 8 (or so) months ago now fail to play. Each lesson of a course begins with a 5-7 second video prelude specific to that course. This runs correctly, but when the actual course content begins the screen goes black, the Status line is "waiting for page-events-ustats.udemy.com".
Debug actions include:
  1. Clear cache
  2. Disable AV
  3. Start SeaMonkey with default profile
  4. Start SeaMonkey in Safe mode
  5. Change useragent to Firefox with User Agent Switcher
  6. Change useragent to Firefox through general.useragent.override.udemy.com in about:config
  7. Toggled media.autoplay.enabled (I had set it to False)
  8. Disabled uBlock

When the screen blanks the following appears in the Error Console:
Code: Select all
Timestamp: 2/18/2019 6:36:49 PM
Error: XML Parsing Error: no root element found
Location: https://www.udemy.com/api-2.0/users/me/subscribed-courses/22461/lectures/108790/progress-logs
Line Number 1, Column 1:
Source File: https://www.udemy.com/api-2.0/users/me/subscribed-courses/22461/lectures/108790/progress-logs
Line: 1


OK, there's an error in the code (maybe?). The videos used to play in SeaMonkey and still do in current Firefox and Chrome: I don't expect to get much sympathy from Udemy support. Anything else I should try or just use FF or Chrome?
Last edited by lem3 on February 20th, 2019, 12:16 pm, edited 1 time in total.

ElTxolo

User avatar
 
Posts: 2432
Joined: July 30th, 2007, 9:35 am
Location: Localhost

Post Posted February 19th, 2019, 7:55 am

....The videos used to play in SeaMonkey and still do in current Firefox and Chrome: I don't expect to get much sympathy from Udemy support. Anything else I should try or just use FF or Chrome?

How to Ask Questions The Smart Way - How to Report Bugs Effectively ;)
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20180711 SeaMonkey/2.49.4
Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20170619 SeaMonkey/2.51

therube

User avatar
 
Posts: 19428
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 19th, 2019, 5:24 pm

No indication (in the other thread) that anyone tried 2.53.
Might try that (in a new, clean Profile).

Could even be something as mundane as a useragent.
Might try spoofing that to a plain FF UA.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

lem3
 
Posts: 25
Joined: May 15th, 2015, 10:29 am

Post Posted February 19th, 2019, 9:48 pm

therube wrote:Could even be something as mundane as a useragent.
Might try spoofing that to a plain FF UA.

That was Steps 5 and 6...

Return to SeaMonkey Bugs


Who is online

Users browsing this forum: No registered users and 1 guest