MozillaZine

Password Manager

Discussion about Seamonkey builds
iFix
 
Posts: 136
Joined: December 24th, 2006, 3:10 am
Location: Mudgee NSW

Post Posted June 16th, 2011, 1:25 am

Hi all,

Today I was helping a staff member use V2.0.14 where I showed the stored passwords on that workstation for the browsing that SeaMonkey had been allowed to save.

In my test bed V2.1 UK version here I can't see any passwords using the Manager, even after the Master Password is provided, what is happening in this area, is it broken on my systems? :?
iFix.
'the farmer in the great heartland, corporate greed and chemicals are killin' the land' {Neil Young - greendale 2003}

therube

User avatar
 
Posts: 17822
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 16th, 2011, 10:14 am

Appears I have one password saved (for this site no less) & it looks to be working.

Though ... I think I have issues with Form Data (not displaying on a domain basis - unless I'm not understanding how it's supposed to work?).

And on my computer at home, about:data displays no domains, no entries at all. Not sure why at this point.

As a test, create a new Profile, add a password & see if it is saved & can subsequently retrieved. (http://mail.yahoo.com/ works as a site to try, even if you enter bogus data, you'll still be prompted to save.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

iFix
 
Posts: 136
Joined: December 24th, 2006, 3:10 am
Location: Mudgee NSW

Post Posted August 12th, 2011, 2:21 am

therube wrote:AppearsAs a test, create a new Profile, add a password & see if it is saved & can subsequently retrieved. (http://mail.yahoo.com/ works as a site to try, even if you enter bogus data, you'll still be prompted to save.)


Thanks TR yes it works with a new profile and the data manager shows my credentials - that is progress.

Sorry for the delay in replying, I have been busily distracted by all these jobs.
iFix.
'the farmer in the great heartland, corporate greed and chemicals are killin' the land' {Neil Young - greendale 2003}

therube

User avatar
 
Posts: 17822
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted August 12th, 2011, 11:14 am

> And on my computer at home, about:data displays no domains, no entries at all. Not sure why at this point.

This was a bug, since fixed, where Data Manager was barfing when it encountered IPv6 domain names (among other problems).
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

iFix
 
Posts: 136
Joined: December 24th, 2006, 3:10 am
Location: Mudgee NSW

Post Posted August 13th, 2011, 8:34 pm

therube wrote:This was a bug, since fixed, where Data Manager was barfing when it encountered IPv6 domain names (among other problems).


Yes, nice to see! :)
iFix.
'the farmer in the great heartland, corporate greed and chemicals are killin' the land' {Neil Young - greendale 2003}

iFix
 
Posts: 136
Joined: December 24th, 2006, 3:10 am
Location: Mudgee NSW

Post Posted September 16th, 2011, 5:32 pm

Hi all,

Just noticing that their is a quirk in the Data Manager.

Two locations (separate workstations) and the latest SM release don't reveal passwords for a volunteer portal used for staff.

The credentials are saved as the fields pre fill, however no matches of any part of the url are responded to by the Data Manager, by design to use part of any other saved url works.

All other portals, secure, Government, commercial sites work as expected and their passwords can be viewed.

Not that it is relevant but it is a Government site --> https://www.myrfs.nsw.gov.au
iFix.
'the farmer in the great heartland, corporate greed and chemicals are killin' the land' {Neil Young - greendale 2003}

iFix
 
Posts: 136
Joined: December 24th, 2006, 3:10 am
Location: Mudgee NSW

Post Posted August 15th, 2012, 2:20 am

Hi all, still getting this, any ideas why some SSL site credentials cannot be viewed in Data Manager?

iFix wrote:Hi all,

Just noticing that their is a quirk in the Data Manager.

Two locations (separate workstations) and the latest SM release don't reveal passwords for a volunteer portal used for staff.

The credentials are saved as the fields pre fill, however no matches of any part of the url are responded to by the Data Manager, by design to use part of any other saved url works.

All other portals, secure, Government, commercial sites work as expected and their passwords can be viewed.

Not that it is relevant but it is a Government site --> https://www.myrfs.nsw.gov.au
iFix.
'the farmer in the great heartland, corporate greed and chemicals are killin' the land' {Neil Young - greendale 2003}

therube

User avatar
 
Posts: 17822
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted August 15th, 2012, 1:25 pm

See if one of the Nirsoft Password Recovery Utilities can see it?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

iFix
 
Posts: 136
Joined: December 24th, 2006, 3:10 am
Location: Mudgee NSW

Post Posted September 12th, 2012, 9:13 pm

therube wrote:See if one of the Nirsoft Password Recovery Utilities can see it?


Hi rube,

Actually the recovery utilities do find the data.

However, we all learn as we go along and I have just noticed that the domain uses a sub domain for the member portal // myrfs.nsw.gov.au and if this is entered the data does not emerge in the data manager.

However, if I just use the string "gov" or "nsw" for example it finds all matches, whilst entering the sub domain "myrfs" does not.

Armed with this I can use the data manager in a totally new way!
iFix.
'the farmer in the great heartland, corporate greed and chemicals are killin' the land' {Neil Young - greendale 2003}

Return to SeaMonkey Builds


Who is online

Users browsing this forum: No registered users and 2 guests