MozillaZine

Data loss with SM 2.10

Discussion about Seamonkey builds
Dan Kies
 
Posts: 125
Joined: November 9th, 2002, 12:14 am
Location: Subjunctive {Sydney, NYC, Chicago, Paris} Indicative {Hell}

Post Posted February 23rd, 2012, 6:47 am

Hello everyone,

Has anyone else been having a problem with SM mail in the trunk nightlies lately (by which I mean the last 6+ weeks)?

Here is what I am seeing on a WinXP SP3 machine with the SM trunk builds:

1. Corruption of mail within a mail folder. The sort of corruption in which the body of new mail is mixed with the body of old mail in the same folder.
2. Repairing the index (.msf) file causes several unread emails to disappear completely -- even if I read the "raw" source file in my profile.

Andy Boze

User avatar
 
Posts: 2755
Joined: June 30th, 2005, 9:53 pm
Location: South Bend, IN

Post Posted February 23rd, 2012, 7:59 am

No problems here. I'm updating the trunk nightlies pretty much every day on two Win7 machines and I haven't noticed any problems such as you describe. The only issue I have had is that SM will stop responding, very rarely, maybe a couple times a week, usually when I'm deleting an e-mail from my IMAP inbox. I just kill the process and restart.
But then again, I may be wrong.

therube

User avatar
 
Posts: 18186
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 23rd, 2012, 7:27 pm

In case it is your HDD.

Backup.
Check you HDD for errors (CHKDSK).
Run manufacturer's diagnostic.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Dan Kies
 
Posts: 125
Joined: November 9th, 2002, 12:14 am
Location: Subjunctive {Sydney, NYC, Chicago, Paris} Indicative {Hell}

Post Posted February 26th, 2012, 8:00 pm

Andy, therube,

Thanks for the replies. Your thoughts were helpful.

Tonight I stumbled upon a clue to this problem, I think. I have moved back to SM 2.7.2. While going through a few mail folders where I knew I had some missing mail, on a whim, I decided to repair the index (.msf) file on mail folders. Behold! Some lost mail was restored. (When I tried the repair function earlier, as reported above, I was in the trunk nightlies.)

Not all the missing mail is restored, but this gives me a clue. I suspect now that either my profile is corrupted (I have not tested the trunk with a fresh profile yet) or the repair .msf utility is broken on the trunk. Perhaps both. Perhaps it's something more/other.

Do you have any other ideas of what might have caused this? Do you have any ideas of bug reports on the repair .msf file? My bugzilla skills are weak.

I'd like to track this down, but I definitely do not have enough solid, reproducible information for a bug report.

Dan Kies
 
Posts: 125
Joined: November 9th, 2002, 12:14 am
Location: Subjunctive {Sydney, NYC, Chicago, Paris} Indicative {Hell}

Post Posted March 7th, 2012, 9:30 pm


Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted April 29th, 2012, 10:59 am

We will be pushing out SeaMonkey 2.9.1 to fix several MailNews bugs. Let us know if this version fixes your problems.

Phil

RDaneel
 
Posts: 438
Joined: January 19th, 2004, 2:43 pm
Location: Seattle, WA

Post Posted May 10th, 2012, 10:35 pm

I was one of the [many] posters in Bug 730947 - and I found things actually got fixed by the final beta of 2.9 (but b1 and b2 were definitely still bad), and the 2.9 release itself.

Just sayin'. :)

Return to SeaMonkey Builds


Who is online

Users browsing this forum: No registered users and 1 guest