MozillaZine

[SOLVED] Beta update WinXP: "update could not be installed"

Discussion about Seamonkey builds
colfer

User avatar
 
Posts: 643
Joined: December 4th, 2002, 9:34 am
Location: Bear

Post Posted July 3rd, 2012, 5:26 am

Anybody else having problems with Seamonkey beta updates? The last two have failed for me with this message: "The update could not be installed. Please be sure there are no other copies of Seamonkey running on your computer". Persists after a WinXP logout/login, and with a new profile, plugins disabled, etc. No crash report except a timestamp. Not the fastest PC here, maybe it is a timing issue.
Last edited by colfer on July 7th, 2012, 9:18 am, edited 1 time in total.

otikohc (chokito)

User avatar
 
Posts: 14
Joined: June 27th, 2012, 8:23 am
Location: Switzerland

Post Posted July 3rd, 2012, 12:01 pm

I have installed 2.11b4 with no problems. First deinstall in control panel, then install new version.
HP EliteBook mit Win 7 Pro x64 und Kubuntu 12.04 LTS x86_64

colfer

User avatar
 
Posts: 643
Joined: December 4th, 2002, 9:34 am
Location: Bear

Post Posted July 4th, 2012, 6:27 am

Thanks, I did a pave-over full-install, maybe should have uninstalled as this is the second beta that has bit me. Hope it is not a real deployment bug. I see nothing specifically in Bugzilla.

therube

User avatar
 
Posts: 19046
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 4th, 2012, 3:00 pm

(Aurora it looks like you're on.)

There have been odd times in the past when for whatever reason .mar wouldn't fly & it would have to re-download itself.

Sometimes on a restart you may get a message like that (or similar), but a second attempt (restart) almost always installs successfully.

(I usually get an update in one Profile, quit, then start a different Profile [one without extensive "history"] to actually affect the update, check again for any new updates, then quit that, then restart the original.)

And I assume you know that after you quit, after the SeaMonkey UI has disappeared, it may take some time (depending on how much memory it had amassed) before seamonkey.exe actually exists (as a Process) from memory. So if you were to open a different (or even the same) Profile during that time, the update would fail, because "another instance of seamonkey was in fact running.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

colfer

User avatar
 
Posts: 643
Joined: December 4th, 2002, 9:34 am
Location: Bear

Post Posted July 4th, 2012, 3:45 pm

Thanks, I'm running SM beta and FF Aurora. Yep, I even logged off and back on. Will see what happens tomorrow or the next day when SM beta 5 comes out. Maybe I will get set with a fresh profile and clean install before then.

colfer

User avatar
 
Posts: 643
Joined: December 4th, 2002, 9:34 am
Location: Bear

Post Posted July 7th, 2012, 9:17 am

Beta update failed again, so I uninstalled, wiped out everything related to Seamonkey and Mozilla in c:\Documents and Settings\, then installed the previous beta and... SOLVED, the beta update succeeded. Wonder if it was the stuff in Local Settings, the non-profile stuff.

Return to SeaMonkey Builds


Who is online

Users browsing this forum: No registered users and 1 guest