MozillaZine

SeaMonkey 2.35γ 20150722 Win32 builds ready for testing

Discussion about Seamonkey builds
Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted July 22nd, 2015, 2:47 pm

http://seamonkey.callek.net/contrib/

ZIP archive:
seamonkey-2.35.en-US.win32-20150722.txt
seamonkey-2.35.en-US.win32-20150722.zip

Installer:
seamonkey-2.35.en-US.win32.installer-20150722.txt
seamonkey-2.35.en-US.win32.installer-20150722.exe

(The .txt files contain the file hashes)

These builds are close to release and contain all the patches from:

* Bug 1177041 - (SM2.35-Uplift) Bugs / Patches to be uplifted to comm-release for SeaMonkey 2.35
* Bug 1185824 - (SM2.35-mozilla-esr38-Uplift) Bugs / Patches to be uplifted to mozilla-esr38 relbranch for SeaMonkey 2.35

Please take these out for a test drive and let us know of any problems you encounter.

Phil

-- Philip Chee <philip@aleytys.pc.my>, <philip.chee@gmail.com> http://flashblock.mozdev.org/ http://xsidebar.mozdev.org Guard us from the she-wolf and the wolf, and guard us from the thief, oh Night, and so be good for us to pass.

LuvKomputrs

User avatar
 
Posts: 492
Joined: June 9th, 2010, 8:15 am

Post Posted July 22nd, 2015, 4:52 pm

Working very well for me so far. :)
Looks like we're getting very close to to a release! =D>

TPR75
 
Posts: 589
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted July 23rd, 2015, 7:57 am

Philip Chee wrote:Please take these out for a test drive and let us know of any problems you encounter.


I've installed this SeaMonkey 2.35 "pre-Beta" in separate folder and set it to run old test profile:
Code: Select all
"C:\Program Files (x86)\SeaMonkeyBeta\seamonkey.exe" -P "test" -no-remote


"Test" profile was made in previous version on SeaMonkey (2.33.1 or older) and it run correct with 2.33.1, but not with 2.35 "pre-Beta":

Image

Address bar is locked (can't type there anything), some functions in menu don't work (e.g. add bookmark) and Add-On Manager is crippled (see: above picture).

So I've made completely new and clean profile ("test2") using present version 2.33.1 and it works correct under 2.35 "pre-Beta". I think it's something with add-ons (maybe AdBlock Plus). I'll test it later.

therube

User avatar
 
Posts: 17539
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 23rd, 2015, 11:19 am

(FWIW, that particular line 174,5 is unchanged from SeaMonkey 2.33.1.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

TPR75
 
Posts: 589
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted July 23rd, 2015, 1:42 pm

therube wrote:(FWIW, that particular line 174,5 is unchanged from SeaMonkey 2.33.1.)


SeaMonkey 2.38a2 has some changes...

Image

:wink:

So... I managed with this "test" profile. It looks like one of extensions was outdated (I've mad this profile under 2.31 and looks like didn't touched it since then).

1) I've renamed folder "extensions" (in profile "test") to hide it from SeaMonkey 2.25 "pre-Beta",
2) start of SM 2.35 - "Add-ons Manager" (and other things) works correct but I can not see any extension (including "Dom inspector),
3) close SM and making original name for "extensions" folder,
4) start SM 2.35 "pre-Beta" and I can see several tabs with notifications about disabled extensions; I've enabled them all and restarted SM... what resulted with the same error (see: first picture),
5) repeat steps 1-3,
6) this time after star of SM I've enabled one extension per session (restart after one enabled) and I've updated them,
7) after all extensions were enabled and updated (including "old Venkman") profile "test" works correct with 2.35 (and 2.38a2).

My extensions (in profile "test"):
Adblock Plus 2.6.9.1-signed
ChatZilla 0.9.91.1.1-signed
DOM Inspector 2.0.16
JavaScript Debugger 0.9.89.1-signed
Linkification 1.3.9
MinimizeToTray revived (MinTrayR) 1.1.2.1-signed
Quote Colors 0.3
SQLite Manager 0.8.3.1-signed

Conclusion: before updating to latest SeaMonkey make sure that all your extensions are updated... :-"

Later (or tomorrow) I'll test copy of my working profile (older and bigger than "test").

therube

User avatar
 
Posts: 17539
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 23rd, 2015, 1:58 pm

But you don't know which extension may have cause the issue initially?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

TPR75
 
Posts: 589
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted July 23rd, 2015, 2:22 pm

therube wrote:But you don't know which extension may have cause the issue initially?


None, I'm afraid. Or all of them.

I've just tested copy of my working profile (with every extension up to date) and it's the same error.

Troubleshooting window (about:support) shows:

Code: Select all
XML Parsing Error: undefined entity Location: jar:file:///C:/Program%20Files%20(x86)/SeaMonkeyBeta/omni.ja!/chrome/toolkit/content/global/aboutSupport.xhtml Line Number 37, Column 13:
        <h3>&aboutSupport.safeModeTitle;</h3>
------------^

(no picture because it's not small - info doesn't wrap)

HA!!! There it is! It's about additional language pack for 2.33 ("English US" in my profile) when I enabled it this time (after enabling all extension one by one) then I've reproduced this bug.

I'm using Polish version of SeaMonkey:
http://download.cdn.mozilla.net/pub/moz ... 2.33.1.exe
... with additional language pack ("English US"):
http://download.cdn.mozilla.net/pub/moz ... ngpack.xpi

My profiles were made under Polish version. That's why "pre-Beta" gone crazy.

When I removed (deleted) "langpack-en-US@seamonkey.mozilla.org.xpi" from "extensions" folder then SM 2.35 works correct.

Installer (or SeaMonkey later) should disable such extensions IMHO.

I hope that final (localized) versions will manage with such things... 8-)

Return to SeaMonkey Builds


Who is online

Users browsing this forum: Lemon Juice and 2 guests