MozillaZine

SeaMonkey 2.35γ 20150807 Win32 builds ready for testing

Discussion about Seamonkey builds
Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted August 7th, 2015, 11:48 am

Latest SeaMonkey 2.35γ contributed builds are now up on http://seamonkey.callek.net/contrib/
Code: Select all
seamonkey-2.35.en-US.win32-20150807.txt                 07-Aug-2015 08:25  869
seamonkey-2.35.en-US.win32-20150807.zip                 07-Aug-2015 08:17   41M
seamonkey-2.35.en-US.win32.installer-20150807.txt       07-Aug-2015 08:24  869
seamonkey-2.35.en-US.win32.installer-20150807.exe       07-Aug-2015 08:19   33M

These builds include the latest security fixes like Mozilla Foundation Security Advisory 2015-78.
SeaMonkey and Thunderbird do not ship the Firefox builtin PDF reader so we are not affected by this. However there are other security and crash fixes so do please help test these latest builds.

Phil

TPR75
 
Posts: 681
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted August 8th, 2015, 1:17 am

The same problem as before:
viewtopic.php?p=14248955#p14248955
(for both Default and Modern theme).

Just mentioning... :-"

TPR75
 
Posts: 681
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted August 8th, 2015, 6:46 am

Well, actually problem is with language packs - "install.rdf" file has wrong information about maximum version of SeaMonkey:

Code: Select all
<?xml version="1.0"?>
<!--

-->

<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
     xmlns:em="http://www.mozilla.org/2004/em-rdf#">
  <Description about="urn:mozilla:install-manifest"
               em:id="langpack-en-US@seamonkey.mozilla.org"
               em:name="English (US) Language Pack"
               em:version="2.33.1"
               em:type="8"
               em:creator="mozilla.org">

    <em:targetApplication>
      <Description>
        <em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
        <em:minVersion>2.33.1</em:minVersion>
        <em:maxVersion>2.*</em:maxVersion>
      </Description>
    </em:targetApplication>
  </Description>
</RDF>



When I changed "<em:maxVersion>2.*</em:maxVersion>" value to "2.33.*" (using 7-Zip in "extensions" in profile's folder) and I run once with SeaMonkey 2.33.1 then after next run with SeaMonkey 2.35 pre-beta I saw this:

Image

... and I was able to open "Add-ons Manager" to see this:

Image

Extension not compatible with SeaMonkey 2.35 was automatically disabled.

IMHO "maxVersion" for language packs should be strictly connected to version of SeaMonkey (at lest to e.g. "2.35.x"). It will save us possible troubles in future... :-k

Diamanti
 
Posts: 701
Joined: June 12th, 2008, 9:02 am

Post Posted August 8th, 2015, 9:50 am

Why not update also 64bit version (seamonkey-2.35.en-US.win64-20150612-212216.txt)?
I download it from akalla and work. Do it is good?

therube

User avatar
 
Posts: 19196
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted August 8th, 2015, 10:44 am

His 2.37 builds (in the beta directory) are current, so if he pulled after the patches landed, it should be OK.

Everything else looks to be old.

Why not update also 64bit version

There have never been any Windows 64-bit builds (by SeaMonkey).
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

James
Moderator

User avatar
 
Posts: 27447
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted August 8th, 2015, 1:40 pm

therube wrote:
Why not update also 64bit version

There have never been any Windows 64-bit builds (by SeaMonkey).

There are 64-bit SeaMonkey for Mac OSX (combined 32/64) and en-US 64-bit contributed builds for Linux, though built on same machines.

There is not even Win64 versiion for Firefox Release yet. However unless in changes again the Firefox 41.0 may likely be the first to have Win64 for Release so after this there may be a better chance to have Win64 for SeaMonkey Releases.

However the SeaMonkey community has its hands full enough as is in getting a current Release out for Win32 and Mac OSX and Linux as is.

patrickjdempsey

User avatar
 
Posts: 23734
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted August 13th, 2015, 4:08 pm

Diamanti wrote:Why not update also 64bit version (seamonkey-2.35.en-US.win64-20150612-212216.txt)?


Seriously? Just be happy that there's finally a 32-bit build on the way. Either that or donate the money so they can hire people to do 64-bit builds.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

LuvKomputrs

User avatar
 
Posts: 566
Joined: June 9th, 2010, 8:15 am

Post Posted August 15th, 2015, 9:00 am

Been using this build for several days and it's running very smoothly for me. :)
Haven't had any issues at all. :D

4td8s
 
Posts: 607
Joined: June 24th, 2009, 1:07 pm

Post Posted August 16th, 2015, 1:56 am

Diamanti wrote:Why not update also 64bit version (seamonkey-2.35.en-US.win64-20150612-212216.txt)?


perhaps you should ask rn10950 to build a win64 sm 2.35 for you, Diamanti. after all, he did make an unofficial win64 edition of sm 2.33.1.

i'll go try out this new sm 2.35y build on an old 32bit Win7 computer and see how it goes.

RDaneel
 
Posts: 438
Joined: January 19th, 2004, 2:43 pm
Location: Seattle, WA

Post Posted August 16th, 2015, 12:37 pm

I clean-installed "seamonkey-2.35.en-US.win32.installer-20150807.exe" yesterday on my Win10 64-bit system (after first doing an uninstall of 2.33.1), using my existing (and large) profile.

No problems observed, operating smoothly, memory usage as expected.

LMK if there is anything specific I should be looking for or checking... I will continue to use this build until the next one - and thanks for building this and making it available. :)

RDaneel
 
Posts: 438
Joined: January 19th, 2004, 2:43 pm
Location: Seattle, WA

Post Posted August 17th, 2015, 12:17 pm

Hmmm... spoke too soon - I wasn't sure yesterday, could have been something else, but now it is 2 days in a row where it isn't picking up my POP email correctly.

What I mean: I use Windows "Hibernate" at the end of each day, and then come back from that the next day. I am now seeing 3 separate but possibly related issues:

1) the usual "Check for new messages every 5 minutes" per-server email settings are not "coming back" when Windows is restored from the Hibernate - this has *always* worked with all previous SeaMonkeys, but was obviously not working, as I cannot turn on my computer in the morning without new email being present ;)

2) the "Get new messages" UI function used to default to "across ALL email accounts", now it seemed to just get the first entry, so I had to explicitly force this on my other account(s)

3) In fact, the regular "probes" of the POP servers (one "real", one the GMail simulated one) are not continuing at all - even after attempting to "kickstart" things - this was apparently masked yesterday by my stopping and restarting the SeaMonkey app

Let me know if there is anything I can check for or questions I can answer.

Edit: I have now confirmed that restarting SeaMonkey is both necessary and sufficient, in order to restore the automatic checking of all (both) my POP email accounts... the "Get new messages" button behavior is still now at this reduced functionality, defaulting to only the first of my two POP servers, rather than as before, defaulting to the "Get All New Messages" menu entry.

Philip Chee

User avatar
 
Posts: 6475
Joined: March 1st, 2005, 3:03 pm

Post Posted August 21st, 2015, 7:33 am

RDaneel wrote:Edit: I have now confirmed that restarting SeaMonkey is both necessary and sufficient, in order to restore the automatic checking of all (both) my POP email accounts... the "Get new messages" button behavior is still now at this reduced functionality, defaulting to only the first of my two POP servers, rather than as before, defaulting to the "Get All New Messages" menu entry.

I believe that this has been reported for Thunderbird as well. So looks like a bug in shared MailNews code.

Phil

RDaneel
 
Posts: 438
Joined: January 19th, 2004, 2:43 pm
Location: Seattle, WA

Post Posted August 22nd, 2015, 4:52 pm

Thanks, I see complaints appearing "identical" (well, for Thunderbird, of course ;) ) to mine - but no bug#.

In any case, it appears unlikely this will be fixed in a/"the" SM 2.35 release.

On that note, I will go over to your post about "BUILD1" and ask my next question.

Return to SeaMonkey Builds


Who is online

Users browsing this forum: No registered users and 2 guests