MozillaZine

Icon Fonts problem plans for fixing?

Discussion about Seamonkey builds
Scarlettrunner20

User avatar
 
Posts: 996
Joined: February 13th, 2003, 5:06 pm

Post Posted September 27th, 2015, 3:50 am

Pale Moon 25.7 and Firefox 41 fixed the Icon Fonts problem. What are the plans for fixing this in Sea Monkey? My home site (dslreports.com) is heavy on icon fonts.

Image Image



Being able to force my font choice on all websites is an accessibility issue for me. However, on sites that are heavy on icon fonts SeaMonkey is just about unusable and that includes my homepage at dslreports. Microsoft has not fixed the problem in IE 10/11 but for it dslreports sends the old style sheet without all the new icon fonts. That makes IE usable at dslreports.com but Sea Monkey gets sent the new style sheet with lots of icon fonts. It is a great relief to see this fixed in Fx 41 and earlier in Pale Moon 25.7. But I like Sea Monkey and with the looming lost of extensions for Fx as we have always known them and Electrolysis also coming to destroy Fx as we have known it, I would like to use SeaMonkey a lot more. Hence the question about the icon fonts problem.

therube

User avatar
 
Posts: 18312
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted September 27th, 2015, 6:11 am

WFM.

You're blocking them somewhere.
NoScript can do it, in its Embeddings tab, Forbid @font-face.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Scarlettrunner20

User avatar
 
Posts: 996
Joined: February 13th, 2003, 5:06 pm

Post Posted September 27th, 2015, 7:18 am

therube wrote:WFM.

You're blocking them somewhere.
NoScript can do it, in its Embeddings tab, Forbid @font-face.


Image

You haven't followed this issue? It's been all over dslreports for Pale Moon and Fx and there is even a current thread discussing it.

I'm not blocking anything. I am simply exercising the accessibility rights I have always had in ALL browsers. The problem is fixed in Pale Moon and now Fx 41. In IE it is not fixed but at least dslreports sends the old style sheet to IE 10/11 that doesn't use icon fonts so I see the old icons on it but many other websites are unusable now on IE 10. On IE Microsoft has always been very clear that this an ACCESSIBILITY setting in IE Options. I think even less of Microsoft since they have not fixed this yet a smaller browser like Pale Moon fixed it quickly.

The problem happens because I don't have the box checked under Preferences/fonts to allow websites to choose their own fonts. Anyone with that box unchecked (someone just posted a few days ago in dslr security forum thinking they had a virus on Fx40 because they had this problem) will not be able for their browsers (ALL browsers) to download icon fonts until the problem is fixed by the browser makers. I have NEVER had that box checked in all the years since I got my first computer in 1999 on any browser.

I don't have No Script. I tried it once on Fx and hated it. I didn't know it worked on Sea Monkey. At any rate, this problem needs to be fixed by the browser makers.

therube

User avatar
 
Posts: 18312
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted September 27th, 2015, 9:03 am

about:config, gfx.downloadable_fonts.enabled, reset its value to default, 'true'.
(That will not affect your [GUI] Preferences font selection.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Scarlettrunner20

User avatar
 
Posts: 996
Joined: February 13th, 2003, 5:06 pm

Post Posted September 28th, 2015, 3:13 am

The about:config setting was already set to "true" but I still had the problem.

I was still using SeaMonkey 2.35. I upgraded just now to 2.38 and it is FIXED with my not needing to do anything. :)

I see Proxo is reporting I am using Fx so I bypassed it and edited this post. Let's see if it now shows I am using SeaMonkey.

Hmm..still shows Fx ...it shouldn't. At any rate, I am using SeaMonkey 2.38 and this version of SeaMonkey fixes the icon font problem.

therube

User avatar
 
Posts: 18312
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted September 28th, 2015, 6:31 am

(Strange-ish looking UA you've got there.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Scarlettrunner20

User avatar
 
Posts: 996
Joined: February 13th, 2003, 5:06 pm

Post Posted September 29th, 2015, 6:36 am

That's Proxo setting its UA. I bypassed Proxo when I posted here so that wouldn't happen but it still happened. Sorry. Used to if I remembered to bypass Proxo here the correct user string would be appended...and that's been the case for all these years...until now.

I went to browserspy with Proxo enabled and it gave the Fx wrong build number user string as expected. I then bypassed Proxo and refreshed the page and browserspy saw this:

Mozilla/5.0 (Windows NT 6.2; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0 SeaMonkey/2.38

Return to SeaMonkey Builds


Who is online

Users browsing this forum: No registered users and 1 guest