MozillaZine


Email crash on latest (02/04/2020) unofficial build

Discussion about Seamonkey builds
RDaneel
 
Posts: 507
Joined: January 19th, 2004, 2:43 pm
Location: Seattle, WA

Post Posted February 4th, 2020, 2:49 pm

This is the worst email issue I have seen since recent 2.57 builds - and they aren't supposed to have functioning email.

On my Win 10 Pro system, I did my usual full profile backup - was running the 02/02/2020 64-bit build from Bill - and uninstall, then installed today's 02/04/2020 Windows 64-bit build from Bill... as frg notes, these seem to have been done way earlier than Bill's usual schedule.

After I am asked for my master password, I supply it, and the email client comes up first - but with some issues: the left pane has the full normal tree structure with my various servers/accounts, but NO message counts - and the right [message] pane is EMPTY.

While I can still use the browser - including all of my tabs, apparently properly restored - after about 2 minutes, I will see a crash. It seems to be trying - for some reason - to be rebuilding the MSF (index) files when it dies.

I have repeated this - each time, restoring my backed-up profile before starting SeaMonkey - a number of times, and it is "solid". :(

I allowed a few of the crashes to be reported, but as I don't know where to get the links, I have no pointers to specific crashes.

I am happy to do any requested tests... I do hope my backup made with the 02/02/2020 build is not itself bogus - but in any case, I can restore any emails from the Inbox file the "hard way". ;)

Finally, yes, I know I was supposed to be saving builds, but as they are downloaded directly to my RAM-drive based tmp, they sometimes are lost when I forget and do a reboot - if this is going to be a longer outage, I would be grateful if someone could post the 02/02/2020 Windows 64-bit build somewhere accessible... it at least worked AFAICT for my purposes.

Thanks!

hardys
 
Posts: 183
Joined: August 7th, 2015, 9:15 am

Post Posted February 4th, 2020, 3:38 pm

about:crashes will show the reports

frg
 
Posts: 1009
Joined: December 15th, 2015, 1:20 pm

Post Posted February 4th, 2020, 3:51 pm

It seems the build is bad but looks like a compiler problem. Bill had some problems yesterday. I informed him. If you don't have a working build saved please install the official 2.53.1 beta 1. The profiles are still compatible.

frg
 
Posts: 1009
Joined: December 15th, 2015, 1:20 pm

Post Posted February 4th, 2020, 4:25 pm

Seems only the x64 is affected. Sorry for the trouble. Latest builds for Linux and macOS are up. Windows is in progress.

frg
 
Posts: 1009
Joined: December 15th, 2015, 1:20 pm

Post Posted February 4th, 2020, 4:31 pm

Btw didn't loose anything. Seems the bad build was not able to open the mail db.

RDaneel
 
Posts: 507
Joined: January 19th, 2004, 2:43 pm
Location: Seattle, WA

Post Posted February 4th, 2020, 4:45 pm

Thanks, f-r (and I assume you have also been coordinating builds with Bill) - I am watching the ongoing Windows x64 build at Bill's - and I believe you are saying that the official builds should still be fine with my profile, this means any "master password" weirdness is behind us?

And I know this isn't your time zone by quite a ways - don't you sleep? ;)

frg
 
Posts: 1009
Joined: December 15th, 2015, 1:20 pm

Post Posted February 4th, 2020, 6:39 pm

The previous/current x64 2020-02-04 06:00 is fubar. The one onegoing should be fine. 2.53.1 and 2.53.2 are currently still profile compatible.

I lost some newsgroup counters after trying the bad build but probably only because I accidently installed a 2.49.5 instead of a good 2.53.2. doh. Needed to clean up the profile afterwards too. Should not happen to you.

> And I know this isn't your time zone by quite a ways - don't you sleep

Overrated :) On vacation and up late and down late too. Suits me better.

FRG

RDaneel
 
Posts: 507
Joined: January 19th, 2004, 2:43 pm
Location: Seattle, WA

Post Posted February 4th, 2020, 7:04 pm

Cool! The Builds By Bill(tm) Windows x64 just finished - and everything is back looking "normal".

Thanks for the help. :)

EDIT: BTW, can anyone point me to the description of what we can have in a useragent override? I hope there is some way of specifying meta stuff like build ID etc?

frg
 
Posts: 1009
Joined: December 15th, 2015, 1:20 pm

Post Posted February 4th, 2020, 7:14 pm

> Cool! The Builds By Bill(tm) Windows x64 just finished - and everything is back looking "normal".

Yes. Seems to be good. Just tested it too to be sure. :)

Now hitting it for today.

FRG

Return to SeaMonkey Builds


Who is online

Users browsing this forum: No registered users and 1 guest