MozillaZine

Automaticlly scrolling when clicking and dragging links

User Help for Mozilla Firefox
Space_Kn1ght
 
Posts: 10
Joined: November 19th, 2016, 3:44 pm

Post Posted April 21st, 2017, 8:35 am

Does anyone know how to turn this thing off? It's pretty annoying and Classic Theme Restorer doesn't seem to be able to turn it off.

LIMPET235
Moderator

User avatar
 
Posts: 37061
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted April 21st, 2017, 8:37 am

Moving to Firefox Support...
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-50.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.9.0.
RadioYachting. Conficker Test. (Always choose the "Custom" Install.)

dfoulkes

User avatar
 
Posts: 21868
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted April 21st, 2017, 8:39 am

I just tried out what I think that you are having a problem with... and I had no issues... so, you might want to detail out more steps/info on what you do to get it to do that... also.. have you tried Firefox safe-mode yet?

Try running Firefox in safe-mode... NOTE: This is a testing procedure only ... NOT for normal browsing.
-- On the menu bar, click the Help menu and select Restart with Add-ons Disabled....
Firefox will start up with the Firefox Safe Mode dialog. Click continue in Safe Mode and don't check any items.

Note: You can also start Firefox in Safe Mode by holding down the shift key while Single/Double clicking on the icon.
* (option key while starting Firefox on Mac).

-----------------------------------------------------------------------------------------
>What safe-mode does ..... Safe Mode temporarily affects the following:
* All extensions are disabled. --- * The userChrome.css and userContent.css files are ignored.
* The default theme is used, without a persona. --- * The default toolbar layout is used.
* The Just-in-time (JIT) JavaScript compiler is disabled. --- * Hardware acceleration is disabled.

-- Safe Mode has no effect on the following --
* The status of plugins is not affected.
* Custom preferences are not affected.

This is the link to the main KB article for Safe-Mode ... but, use the above info 1st...
Safe Mode - MozillaZine Knowledge Base
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

Space_Kn1ght
 
Posts: 10
Joined: November 19th, 2016, 3:44 pm

Post Posted April 21st, 2017, 9:11 am

I tried safe mode and it didn't fix it. It started when I updated to Firefox 53.0, I updated my desktop and my laptop and both seem to have the same issue I don't really know if this is a bug or not.

JayhawksRock

User avatar
 
Posts: 10346
Joined: October 24th, 2010, 8:51 am

Post Posted April 21st, 2017, 9:33 am

Maybe check and mess with prefs general.autoScroll and general.smoothScroll
Both are set to false for me .... no auto scrolling here
"Get your facts first, then you can distort them as you please."
~ Mark Twain

Space_Kn1ght
 
Posts: 10
Joined: November 19th, 2016, 3:44 pm

Post Posted April 21st, 2017, 9:43 am

Toggling them didn't work, I tried that before.

atlanto
 
Posts: 21
Joined: March 7th, 2015, 4:19 pm
Location: Japan

Post Posted April 21st, 2017, 4:40 pm

It is not a bug but a bugfix.
41708 - Should be able to scroll in the viewport while dragging
There is no option.

Space_Kn1ght
 
Posts: 10
Joined: November 19th, 2016, 3:44 pm

Post Posted April 21st, 2017, 8:35 pm

atlanto wrote:It is not a bug but a bugfix.
41708 - Should be able to scroll in the viewport while dragging
There is no option.

Wow, that's pretty annoying, I would atleast think CTR would have an option to disable it. I guess my main problem with it is that it scrolls way too fast, I opened up Chrome it it scrolls a lot more slower that Firefox.

therube

User avatar
 
Posts: 16999
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 22nd, 2017, 5:15 am

Wow, that's pretty annoying

Agreed.
I'll regularly drag "text URL" to the "tab" bar, & to now have the screen start moving, jumping...

It would be one thing if there were an option to toggle the behavior..., but as it is, flat out annoying.

(Yet another built-in virus.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

kreemoweet
 
Posts: 675
Joined: December 30th, 2009, 11:25 pm

Post Posted April 22nd, 2017, 5:45 am

Not just links, but any selected text fragment. You naysayers just don't get it: if Chrome does it, it's just gotta be the right thing to do!

Space_Kn1ght
 
Posts: 10
Joined: November 19th, 2016, 3:44 pm

Post Posted April 22nd, 2017, 3:53 pm

therube wrote:
Wow, that's pretty annoying

Agreed.
I'll regularly drag "text URL" to the "tab" bar, & to now have the screen start moving, jumping...

It would be one thing if there were an option to toggle the behavior..., but as it is, flat out annoying.

(Yet another built-in virus.)


One of the best selling points of Firefox is the ability to customize it more than any other mainstream browser. It really upsets me that they're going to throw it all away.

dickvl

User avatar
 
Posts: 51903
Joined: July 18th, 2005, 3:25 am

Post Posted Yesterday, 6:31 pm

I come across this when I drag a link in a specific position in a bookmarks folder (Bookmarks Toolbar or on the star).
It would be fine if there would be a timeout for this feature to kick in (about 500 milliseconds) to allow passing this 20px area.
Now you can only move the mouse as quickly as possible, so only a slight scroll happens.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 16 guests