MozillaZine

How to Change Firefox Timeout Setting.

Discussion of general topics about Mozilla Firefox
Protocol

User avatar
 
Posts: 390
Joined: October 18th, 2003, 12:44 am

Post Posted July 19th, 2004, 3:38 am

I have noticed that Firefox times out very quickly. How do you extend that so it doesn't time out so quickly?

GateKpr06
 
Posts: 171
Joined: July 10th, 2004, 6:20 pm

Post Posted July 19th, 2004, 4:08 am

wut do you do that makes it time out?

or wut are you doing when it does?

Protocol

User avatar
 
Posts: 390
Joined: October 18th, 2003, 12:44 am

Post Posted July 19th, 2004, 4:14 am

Some websites that I visit are slow (especially some Forums). IE will load the page after some time, but Firefox times out.

GateKpr06
 
Posts: 171
Joined: July 10th, 2004, 6:20 pm

Post Posted July 19th, 2004, 4:20 am

i don't know if this will work b/c i don't mess with it...but configuration mania has an http network feature that deals with sessions.

Maybe this will help.

GateKpr06
 
Posts: 171
Joined: July 10th, 2004, 6:20 pm

Post Posted July 19th, 2004, 4:39 am


jbash
 
Posts: 101
Joined: November 17th, 2003, 1:39 pm
Location: Chicago

Post Posted July 19th, 2004, 1:16 pm

I was just searching for advice on this and found:
http://forums.mozillazine.org/viewtopic ... tion+timed

Which suggests:
2) Add several seconds to the value of the network.http.connect.timeout key.

BTW & FWIW, this has become a much more common occurence for me since updating to FF9.2--could be that coincidentally our network slowed down as the same time, but???

jim b

Protocol

User avatar
 
Posts: 390
Joined: October 18th, 2003, 12:44 am

Post Posted July 19th, 2004, 8:05 pm

Thanks all! I will try them. The about:config suggestion looks promising.

danm
 
Posts: 1115
Joined: February 2nd, 2004, 7:51 pm

Post Posted July 20th, 2004, 10:41 am

I'm not a network guy but it looks to me like this advice may be out of date. Give it a try, by all means. If it doesn't help, try bumping the value of network.http.keep-alive.timeout. For this to have any effect you may also need to use the HTTP/1.0 protocol, rather than the default 1.1. Do that by setting network.http.version to the string 1.0. If you're using a proxy server, you may also want to adjust the equivalent network.http.proxy.* settings. (Type network.http into the about:config Filter field to see a list of interesting http prefs.)

I've never needed to mess with these things. I'd be curious to hear what worked.

Squid13

User avatar
 
Posts: 85
Joined: December 26th, 2003, 8:42 pm
Location: Cantonment, FL

Post Posted July 20th, 2004, 10:47 am

I'm having the same problem on some web pages, it times out before it can load. I'll be watching this thread.

what2be
 
Posts: 2
Joined: July 20th, 2004, 2:58 pm

Post Posted July 20th, 2004, 3:00 pm

I too have been experiencing alot of dns errors from timeout. Most of the time it happens a second or two after either typing in the url or clicking a link from a web page. Ill try the suggestions and see if it helps.

Protocol

User avatar
 
Posts: 390
Joined: October 18th, 2003, 12:44 am

Post Posted July 20th, 2004, 6:50 pm

Well, I have tried all the suggestions offered except for danm's without any success. I will try danm's suggestion soon.
Firefox need to be friendly to the slower websites or people will return to IE.

Squid13

User avatar
 
Posts: 85
Joined: December 26th, 2003, 8:42 pm
Location: Cantonment, FL

Post Posted July 21st, 2004, 7:42 am

I got this over at DSL reports and so far it seams to help. Go to the answer from Lanik.
http://www.dslreports.com/forum/remark, ... ~mode=flat

what2be
 
Posts: 2
Joined: July 20th, 2004, 2:58 pm

Post Posted July 21st, 2004, 11:37 am

I too have tried changing the timeout without success. But I did fix my problem, in a completely different way.

I looked through my registry at the run key and noticed something that was spyware, or adware. I removed those entries and then ran ad aware. After running ad aware I foudn some more registry keys that needed to be deleted. After I did that and rebooted I havent had a problem since. The reason that made me thing of it being a browser problem and not a network (per say) problem was that my p2p file sharing was working fine, it was the browser that was giving me fits. (on random websites)

My problem might not be the exact same as yours, but Im listing my exact problem below to see if it helps anyone else.


===================
When starting firebird (sometimes) , it gives me a dns (timeout) error going to my home page. (my.yahoo.com)
When clicking a favorite it gives me a dns (timeour) error (sometimes) (about 40% of the time)
When creating a new tab and firebird trys to load my home page (my.yahoo.com) it gives a dns error (aoubt 50% of the time)
When typing in URL's by hand, it usually worked. (all the time I think but not sure)
If I clicked refresh after every timeout error, it would work on the 3 or 4 time.

Hope this helps someone..

Geoff

Protocol

User avatar
 
Posts: 390
Joined: October 18th, 2003, 12:44 am

Post Posted July 25th, 2004, 12:52 am

Well, I have tried everything, but I still get timeouts where IE doesn't. So I guess this is a glitch with the latest version. I will just have to wait for the next release and hopefully it will be fixed.

SkyPilot
 
Posts: 2175
Joined: August 9th, 2004, 1:18 am

Post Posted August 10th, 2004, 9:17 pm

// Turn on timer-based reflow management
user_pref("content.notify.ontimer", true);

// Sets the allowed time between reflows in microseconds
user_pref("content.notify.interval", 750000);

user_pref("content.interrupt.parsing", true);
user_pref("content.max.tokenizing.time", 2250000);
user_pref("content.maxtextrun", 8191);
user_pref("content.switch.threshold", 750000);

// Set the number of reflows to do before waiting for the rest of the page to arrive
user_pref("content.notify.backoffcount", 5);

// Turn initial paint delay to
user_pref("nglayout.initialpaint.delay", 500);

// Set Maximum Connections Per Server
user_pref("network.http.max-connections", 48);
user_pref("network.http.max-connections-per-server", 16);
user_pref("network.http.max-persistent-connections-per-proxy",16);
user_pref("network.http.max-persistent-connections-per-server", 8);


Place in User. JS

Got this off the forum. Put it in my user.js and haven't had a time-out since. Hope it helps.

Return to Firefox General


Who is online

Users browsing this forum: No registered users and 6 guests